Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #169  
Old 12-11-2013, 09:46 AM
MajorTom's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Indiana
Posts: 352
Thanks: 10
Thanked 27 Times in 20 Posts
Rep Power: 1526
MajorTom has a reputation beyond reputeMajorTom has a reputation beyond repute
Garage
Radio update:

Missed a few days but wanted to report I have not had any Phone Requires Service messages since picking up a week ago today. Looks like, at least in my case, the antenna WAS the culprit!
__________________

__________________


______________________________________
2014 Grand Cherokee Summit
Cashmere Pearl
Jeep Brown Interior - V6
Reply With Quote
  #170  
Old 12-11-2013, 11:45 AM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Cincinnati, Ohio
Posts: 178
Thanks: 0
Thanked 15 Times in 11 Posts
Rep Power: 598
schmieg is on a distinguished road
Re: UConnect 8.4 - North America

Quote:
Originally Posted by MajorTom View Post
Radio update:

Missed a few days but wanted to report I have not had any Phone Requires Service messages since picking up a week ago today. Looks like, at least in my case, the antenna WAS the culprit!
Glad to hear it. I thought it had to be something besides the radio with all the problems you had and the multiple radios. At least you have the latest radio version.
__________________

__________________
--- Mike
2014 Grand Cherokee Overland, 3.6 Liter, OAII, Adv. Tech Group
Reply With Quote
  #171  
Old 12-11-2013, 11:55 AM
Member
 
Join Date: Oct 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 304
barry@hvhomemedia.com is on a distinguished road
Re: UConnect 8.4 - North America

Just got off the phone with the service manager. The last 3 in days in Ny is been between 20 and 30 degrees. I was told leaving the Climate Control on Auto then when I remote start it remotely or manually the Climate will be on. The last 2 days started the truck both ways with Climate control on Auto. Climate Control was off. Service manager so new updates available and unfortunately I need to live with it for now.
__________________
Reply With Quote
  #172  
Old 12-11-2013, 12:32 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,047
Thanks: 207
Thanked 146 Times in 119 Posts
Rep Power: 89265
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by barry@hvhomemedia.com View Post
Just got off the phone with the service manager. The last 3 in days in Ny is been between 20 and 30 degrees. I was told leaving the Climate Control on Auto then when I remote start it remotely or manually the Climate will be on. The last 2 days started the truck both ways with Climate control on Auto. Climate Control was off. Service manager so new updates available and unfortunately I need to live with it for now.
Just trying to be helpful here, so if you're already familiar with this, just ignore it.
Attached Files
File Type: pdf tsb_wk2_2400213.pdf (111.7 KB, 24 views)
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #173  
Old 12-11-2013, 02:27 PM
Premium Member
 
Join Date: Jul 2013
Posts: 482
Thanks: 0
Thanked 21 Times in 16 Posts
Rep Power: 17652
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by MajorTom View Post
Radio update:

Missed a few days but wanted to report I have not had any Phone Requires Service messages since picking up a week ago today. Looks like, at least in my case, the antenna WAS the culprit!
Good to know. Go in and say you have crappy XM reception, get new antenna, get rid of "phone needs service" - maybe.
__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #174  
Old 12-11-2013, 06:06 PM
MajorTom's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2011
Location: Indiana
Posts: 352
Thanks: 10
Thanked 27 Times in 20 Posts
Rep Power: 1526
MajorTom has a reputation beyond reputeMajorTom has a reputation beyond repute
Garage
Quote:
Originally Posted by TurboRush View Post
Good to know. Go in and say you have crappy XM reception, get new antenna, get rid of "phone needs service" - maybe.
With all the problems I had, that was not one if them. Strange indeed!
__________________


______________________________________
2014 Grand Cherokee Summit
Cashmere Pearl
Jeep Brown Interior - V6
Reply With Quote
  #175  
Old 12-12-2013, 09:46 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 965
Thanks: 34
Thanked 58 Times in 49 Posts
Rep Power: 1942
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: UConnect 8.4 - North America

Looks like international now has version 13.43.7 out. Wonder if new NA version is soon to come?
__________________
Reply With Quote
  #176  
Old 12-12-2013, 10:16 PM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 187
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 773
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by silvermax04 View Post
Looks like international now has version 13.43.7 out. Wonder if new NA version is soon to come?
Interesting - thanks for the heads up! The last update came out on Thursday 10/3 for International and then on Monday 10/7 for NA. Perhaps they are following the same distribution process. Int'l today (Thursday) - so be on the lookout on Monday!!!
__________________
Reply With Quote
  #177  
Old 12-12-2013, 10:20 PM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 187
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 773
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by silvermax04 View Post
Looks like international now has version 13.43.7 out. Wonder if new NA version is soon to come?
Actually, I just checked a VIN that I know is Int'l and it still shows 10/3 as the update date. Where did you see the 13.43.7?
__________________
Reply With Quote
  #178  
Old 12-12-2013, 10:22 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 965
Thanks: 34
Thanked 58 Times in 49 Posts
Rep Power: 1942
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by clowenthal View Post
Interesting - thanks for the heads up! The last update came out on Thursday 10/3 for International and then on Monday 10/7 for NA. Perhaps they are following the same distribution process. Int'l today (Thursday) - so be on the lookout on Monday!!!
I checked the uconnect download site and nothing yet but maybe sometime soon like you said will keep an eye out
__________________
Reply With Quote
  #179  
Old 12-12-2013, 10:22 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,880
Thanks: 529
Thanked 848 Times in 467 Posts
Rep Power: 1926998
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
I posted the info in the 8.4 international thread with files for Europe and OZ.
__________________
Reply With Quote
The Following User Says Thank You to Willx For This Useful Post:
  #180  
Old 12-12-2013, 10:34 PM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 187
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 773
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by silvermax04 View Post
I checked the uconnect download site and nothing yet but maybe sometime soon like you said will keep an eye out
I looked at the Int'l thread and they attached the TSB for the new update that was created on 12/5/13. The TSB indicates that the update for the RA3 and RA4 radio will be updated to 13.38.52. The RJ3, RJ4, RG3 and RG4 will be updated to **13.43.7**.

So based on this I'd guess NA isn't going to see an update for a while.
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Supplier for "import parts" in North America? suzieque Engine Performance/Intake/Exhaust 2 01-02-2013 01:36 PM
Jeep Grand Cherokee to get 3.0L diesel V6 in North America by 2013 Thrumcap Diesel Powered 2012+ Export Grand Cherokee 7 04-18-2011 08:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community