Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #205  
Old 12-15-2013, 09:39 AM
Vtail's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2012
Location: Twin Cities, MN
Posts: 538
Thanks: 18
Thanked 101 Times in 61 Posts
Rep Power: 1359
Vtail has disabled reputation
Quote:
Originally Posted by Willx View Post
I have not been happy with the sound quality in comparison to other sources. When plain run of the mill FM sounds better than SXM, I see no value in the service.
On SXM I get channels (like FOX news and bluegrass music) that I can't get on regular radio. The local talk stations I used to listen have all moved to AM and the quality and reception are horrible, so I was looking for an alternative. We'll see how I feel about it when it is time to renew.
__________________

__________________
Current garage/hangar:
2014 Grand Cherokee Summit EcoDiesel Cherry Red w/Jeep Brown interior
2011 John Deere 1023E diesel tractor
2009 Jetta TDI (better half's ride)
2007 Harley Softail Deluxe
1966 Beechcraft Bonanza "V-tail"
1930 Ford Model A - restoration in process
Reply With Quote
The Following User Says Thank You to Vtail For This Useful Post:
  #206  
Old 12-15-2013, 09:49 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,880
Thanks: 529
Thanked 848 Times in 467 Posts
Rep Power: 1926998
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by Vtail View Post
On SXM I get channels (like FOX news and bluegrass music) that I can't get on regular radio. The local talk stations I used to listen have all moved to AM and the quality and reception are horrible, so I was looking for an alternative. We'll see how I feel about it when it is time to renew.
I mainly listen to music, so I can totally see how it would be better for you. The station controls the commercial volumes thought and you are correct it is annoying. Instead of listening to the commercial I turn it down half way until I can hear the music came back or switch stations.... so they are not selling me with that tactic.
__________________

__________________
Reply With Quote
  #207  
Old 12-16-2013, 09:41 AM
Member
 
Join Date: Oct 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 305
barry@hvhomemedia.com is on a distinguished road
Re: UConnect 8.4 - North America

Did the update on Saturday. No noticeable change.
__________________
Reply With Quote
  #208  
Old 12-16-2013, 09:42 PM
simplewon's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Dec 2013
Location: USA Kentucky
Posts: 98
Thanks: 9
Thanked 2 Times in 2 Posts
Rep Power: 338
simplewon is on a distinguished road
Garage
Re: UConnect 8.4 - North America

Does anyone have 13.33.7 saved somewhere? I've searched, links only to uconnect which offers the latest. Or does a factory reset put it back to what it came with?
__________________
2014 SRT Jeep
2007 GT Roadster Nissan
1998 5.9 Limited Jeep
Reply With Quote
  #209  
Old 12-18-2013, 12:58 PM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2013
Location: Auburn, AL
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
HunleyGroup is on a distinguished road
Re: UConnect 8.4 - North America

Going to try to be brief:

Had issues with system since dealer tried to update the system to 13.38.52. Since then, the nav position shows me in a different state, UConnect has no connection (no 3G symbol at all) and "Phone Requires Service" notification was intermittent. Dealer FINALLY (after 4 visits) was able to convince Chrysler to send new head unit. Dealer has been AWESOME to work with by the way! New radio was installed last week, and I now have proper working navigation. BUT, still no UConnect and now there is no satellite radio signal available. I just get a message that says "acquiring signal". None of the UConnect Apps work. Dealer was told to install new antenna, they did that yesterday. Still, no satellite radio and no UConnect signal. Chrysler has now told them to inspect the wiring harness from front to back from antenna to radio. If that does not solve, Chrysler wants to send another new head unit. This started about 2 months ago. They did update to 13.48.3 yesterday. Noticed the new apps are there, but of course, I cannot connect to UConnect store so nothing works for me right now. Anyone have ideas on what could be causing such an issue with connectivity? New head unit, new antenna, what else could they possibly replace? By the way, once they put the new head unit in, I get the 1X and 3G symbol once in a while in a very good coverage area. But it does not last very long, and it is not enough signal to even open the app store. New antenna made NO DIFFERENCE at all! Just wanted to get some ideas here...
__________________
Reply With Quote
  #210  
Old 12-19-2013, 12:02 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 685
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1109
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: UConnect 8.4 - North America

the service is sprint.. are you sure its a good service area?

maybe its not the antenna, but the connections to the antenna.


did the update last night. smooth. got the new apps, tried pandora. Works well, its nice that you can even pick new stations on it.
__________________
Reply With Quote
  #211  
Old 12-19-2013, 12:17 PM
New Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2013
Location: Auburn, AL
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
HunleyGroup is on a distinguished road
Re: UConnect 8.4 - North America

That is exactly what I was thinking. I have owned the Jeep for 4 months and for the first 2 it got a perfect signal. It was not until the dealership did the FIRST update to 13.38.52 that I lost the connection completely! After that, the dealership tried a few tests, Chrysler even sent a "test antenna" that could be directly connected to the head unit with no wires. They said that the signal going into the head unit was good and decided to replace the head unit. The new unit had the same problem with the additional issue of not having satellite radio signal. The dealership has installed a new antenna now, they have checked the wires running all the way to the head unit, and have determined that they want to replace the head unit once again. Incidentally, when the update was done, I lost my navigation. It had me located in a totally different state. When they replaced the head unit, the navigation system was working properly and still is even to today. I found that a bit odd...
__________________
Reply With Quote
  #212  
Old 12-26-2013, 02:27 PM
Member
 
Join Date: Mar 2010
Location: Seattle
Posts: 81
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 4296
mputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond reputemputnik has a reputation beyond repute
Re: UConnect 8.4 - North America

I know, not a big deal, but I would love to be able to switch between F/C without changing M/KM on the odometer. Small wish, easy to implement and I have it on my other car.
__________________
Reply With Quote
  #213  
Old 01-07-2014, 01:14 PM
Member
 
Join Date: Oct 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 305
barry@hvhomemedia.com is on a distinguished road
Re: UConnect 8.4 - North America

Was driving to Christmas eve dinner on a major ny highway, ten minutes in radio, nav and climate completely froze up. Heater went off nav stop navigating and radio was stuck where it was. Manual controls vol, etc. no response. Had to pull over shut the truck off and open the drivers door and wait 45 seconds for the off light around the start button to go off and then restart the truck and all controls came back. Brought the truck to the dealer this past Saturday they "pulled the codes" and said there was a communication disconnection. They are going to call Chrysler tech for an answer but prob going to change the radio again. Which will be #5. This is just astounding to me. Waiting for a response from the service manager. This is such BS. 2014 JGCL with 1500 miles. Very sad.
__________________
Reply With Quote
  #214  
Old 01-07-2014, 02:03 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,047
Thanks: 207
Thanked 146 Times in 119 Posts
Rep Power: 89265
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: UConnect 8.4 - North America

If this is radio #5, aren't you thinking lemon law?
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #215  
Old 01-07-2014, 03:42 PM
Member
 
Join Date: Oct 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 305
barry@hvhomemedia.com is on a distinguished road
Re: UConnect 8.4 - North America

Already in the works.
__________________
Reply With Quote
  #216  
Old 01-07-2014, 03:56 PM
Premium Member
 
Join Date: Jul 2013
Posts: 482
Thanks: 0
Thanked 21 Times in 16 Posts
Rep Power: 17652
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: UConnect 8.4 - North America

Insanity is doing the same thing over and over and expecting different results. At this point how can they really believe its the head unit and not something upstream/downstream screwing with it?
__________________

__________________
2014 Overland - Granite, Hemi
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Supplier for "import parts" in North America? suzieque Engine Performance/Intake/Exhaust 2 01-02-2013 01:36 PM
Jeep Grand Cherokee to get 3.0L diesel V6 in North America by 2013 Thrumcap Diesel Powered 2012+ Export Grand Cherokee 7 04-18-2011 08:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community