Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #289  
Old 07-18-2014, 09:17 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 1,629
Thanks: 99
Thanked 167 Times in 147 Posts
Rep Power: 2453
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: UConnect 8.4 - North America

Quote:
Originally Posted by apinkel View Post
I thought you might be onto something there... but I tried it twice and it still acted the same way.

I should add that the band settings stick... i.e. I have bass set to -5, eq at +3 and High at -2... these settings save and restore as expected.

But the act of opening the equalizer and making one small adjustment (say dropping the midgrange by a notch) and the radio seems to apply a different eq profile.

There's a thread about this over in the VIP area of the forum. Several people have reported the same thing. I checked mine yesterday and sure enough, it does the same.
__________________

__________________

Garage: The Ghost
Reply With Quote
The Following User Says Thank You to MDBones For This Useful Post:
  #290  
Old 08-11-2014, 10:29 AM
Premium Member
My Jeep: 2014 WK2
 
Join Date: Apr 2014
Posts: 231
Thanks: 10
Thanked 14 Times in 13 Posts
Rep Power: 2306
46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute46er has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by barthjf View Post
Just an FYI for everyone getting the invalid VIN error message. I opened a ticket with Chrysler/Uconnect.
I did the same last week and this morning it worked just fine.
__________________

__________________
2014 Grand Cherokee Limited, Bright White, MDH 031503, V6, QTII, nav, sun roof, fold flat pass seat
Reply With Quote
  #291  
Old 08-11-2014, 09:07 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2014
Location: NJ
Posts: 41
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 305
maxbear3145 is on a distinguished road
Re: UConnect 8.4 - North America

Does anyone have a copy of UCONNECT® 8.4AN_RA4 (14.25.05) ? I just tried to put a valid vin ... and it came up with you have exceeded the download limit... please call... yada yada...


thanks
mike
__________________
Reply With Quote
  #292  
Old 08-11-2014, 09:20 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,457
Thanks: 354
Thanked 382 Times in 331 Posts
Rep Power: 1802104
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: UConnect 8.4 - North America

Quote:
Originally Posted by maxbear3145 View Post
Does anyone have a copy of UCONNECT® 8.4AN_RA4 (14.25.05) ? I just tried to put a valid vin ... and it came up with you have exceeded the download limit... please call... yada yada...


thanks
mike
Supporting members of Jeep Garage can download it in the VIP section.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
The Following User Says Thank You to bill_de For This Useful Post:
  #293  
Old 08-17-2014, 07:51 PM
Summit360's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Toronto Canada
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 644
Summit360 is on a distinguished road
Re: UConnect 8.4 - North America

I installed the Uconnect upgrade this weekend. The back-up camera works perfectly now - no stutter and no grainy image. I didn't check to see if the mute stays on after a power down and restart, or if the screen returns to the previous one after a phone call. I will check on those items tomorrow.
__________________
Reply With Quote
  #294  
Old 08-25-2014, 04:18 AM
seeingwhite's Avatar
How long until the reckoning?
 
Join Date: Jul 2013
Location: FFH
Posts: 591
Thanks: 180
Thanked 83 Times in 59 Posts
Rep Power: 3753
seeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond reputeseeingwhite has a reputation beyond repute
The 2015 I picked up over the weekend has a slightly newer version of UConnect than the one available here and on the UConnect website. 14.25.11 I believe. Seems to work pretty well overall. Manually moving around/exploring the map NAV screen is terrible though and pretty much not worth the effort and lag.

The sirrius traffic actually worked really well leaving DC and saved me a bunch of time.
__________________
2015 Grand Cherokee Overland
V8, ORA II, Blu-ray RES, RAX Jailbreak
Reply With Quote
  #295  
Old 08-25-2014, 05:45 PM
Member
 
Join Date: Aug 2014
Posts: 106
Thanks: 3
Thanked 6 Times in 2 Posts
Rep Power: 316
airgas1998 is on a distinguished road
Re: UConnect 8.4 - North America

so I go to uconnect website for the latest fw, and I can't get any further than installing the navigator. once it does that it goes no further doesn't pick-up in the browser like the tutorial said. any ideas anyone?
__________________
Reply With Quote
  #296  
Old 08-25-2014, 05:52 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2014
Location: NJ
Posts: 41
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 305
maxbear3145 is on a distinguished road
Re: UConnect 8.4 - North America

call them ... let us know how you make out... i have been to lazy to sit in the car for 20 min while they fix the issue.
__________________
Reply With Quote
  #297  
Old 08-25-2014, 05:59 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 1,243
Thanks: 11
Thanked 109 Times in 100 Posts
Rep Power: 2147
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Quote:
Originally Posted by airgas1998 View Post
so I go to uconnect website for the latest fw, and I can't get any further than installing the navigator. once it does that it goes no further doesn't pick-up in the browser like the tutorial said. any ideas anyone?
Premium membs download direct from this forum, otherwise add the Uconnect website to allowed sites in security settings.... The cure all is to install Safari for Windows and it will work perfectly with Uconnect. I have win 8.1 am very techy and couldn't get it and akamai to play nice with any browser except Safari.
__________________
Reply With Quote
  #298  
Old 08-25-2014, 06:23 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,393
Thanks: 43
Thanked 107 Times in 86 Posts
Rep Power: 2635
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Try adding the website to the compatibility list that is what i had to do to get it to work with win 8.1. After doing that it worked fine
__________________
Reply With Quote
  #299  
Old 08-25-2014, 06:35 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Oct 2013
Location: Bay Village, OH
Posts: 1,243
Thanks: 11
Thanked 109 Times in 100 Posts
Rep Power: 2147
14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute14SummitHemi has a reputation beyond repute
Quote:
Originally Posted by silvermax04 View Post
Try adding the website to the compatibility list that is what i had to do to get it to work with win 8.1. After doing that it worked fine
Ya that won't work with all 8.1 installs, there are conflicts that the akamai client has with some web server settings and how you obtain your dns, firewall setup, etc..
__________________
Reply With Quote
  #300  
Old 08-25-2014, 06:43 PM
Member
My Jeep: 2014 3.2L KL
 
Join Date: Apr 2014
Location: Middle GA
Posts: 17
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 332
CarlsDad is on a distinguished road
Re: UConnect 8.4 - North America

Luckily I still have a working XP machine available. It works great with IE8.
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Supplier for "import parts" in North America? suzieque Engine Performance/Intake/Exhaust 2 01-02-2013 01:36 PM
Jeep Grand Cherokee to get 3.0L diesel V6 in North America by 2013 Thrumcap Diesel Powered 2012+ Export Grand Cherokee 7 04-18-2011 08:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.