Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-02-2014, 05:22 PM
Premium Member
 
Join Date: Sep 2010
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1529
ftffom is on a distinguished road
Uconnect 8.4AN is dead

This afternoon when I started my Jeep the Uconnect unit was dead - black screen. No back-up camera, no radio or hvac controls, etc. It worked earlier today. Glad that there are still buttons/knobs for the hvac controls, though I have no idea what temperature it is set on.

Has anyone else reported this issue and what is the likely source of the problem?
__________________

__________________
Current: 2014 Jeep Grand Cherokee
Summit 4x4, V6
Brilliant White / Grand Canyon Jeep Brown
Delivery May 4, 2013
Reply With Quote
  #2  
Old 03-02-2014, 05:26 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,854
Thanks: 86
Thanked 74 Times in 61 Posts
Rep Power: 570926
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
Re: Uconnect 8.4AN is dead

remove the Radio fuse or disconnect the negativ cable from the Batterie.
__________________

__________________
All Uconnect Software

www.mydrive.ch

username: mygig@soxag
Password: gasolio

Reply With Quote
  #3  
Old 03-02-2014, 05:32 PM
Member
 
Join Date: Jun 2011
Location: greasy cardboard box
Posts: 156
Thanks: 0
Thanked 21 Times in 17 Posts
Rep Power: 1885
fnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond reputefnkychkn has a reputation beyond repute
Re: Uconnect 8.4AN is dead

radio may require an update as per TSB 08-049-13G.
__________________
I'd give my right arm to be ambidextrous.
Reply With Quote
  #4  
Old 03-03-2014, 07:29 AM
Member
 
Join Date: Apr 2013
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 535
perruz is on a distinguished road
Re: Uconnect 8.4AN is dead

It happend to me a week after the radio was replaced; took it back to the dealer and they had to replace the radio again. They tried to update it but it didn't work.

I'm on my fourth radio, had the last one replace last week.
__________________
Reply With Quote
  #5  
Old 03-03-2014, 08:25 AM
Raptor Rage's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2014
Location: Ft Lauderdale, FL & West Union , WV
Posts: 50
Thanks: 4
Thanked 8 Times in 8 Posts
Rep Power: 295
Raptor Rage is on a distinguished road
Garage
Re: Uconnect 8.4AN is dead

my radio is changing channels every 30 seconds just great another trip to the dealer
__________________



2014 Grand Cherokee limited 5.7 Hemi 8 speed auto
Cooper Zeon LTZ 285 50R20 Tires
Reply With Quote
  #6  
Old 03-11-2014, 07:06 PM
Premium Member
 
Join Date: Sep 2010
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1529
ftffom is on a distinguished road
Re: Uconnect 8.4AN is dead

Quote:
Originally Posted by ftffom View Post
This afternoon when I started my Jeep the Uconnect unit was dead - black screen. No back-up camera, no radio or hvac controls, etc. It worked earlier today. Glad that there are still buttons/knobs for the hvac controls, though I have no idea what temperature it is set on.

Has anyone else reported this issue and what is the likely source of the problem?
The dealer replaced the radio assembly. No explanation for why the original died.

Also replaced the blower fan (original was squeaky). The check engine late also came on the day before my appointment. They had to replace the oil cooler.

I am not feeling good about the reliability of this vehicle. Had no issues with my 2011.
__________________
Current: 2014 Jeep Grand Cherokee
Summit 4x4, V6
Brilliant White / Grand Canyon Jeep Brown
Delivery May 4, 2013
Reply With Quote
  #7  
Old 03-12-2014, 08:35 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 719
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1195
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Uconnect 8.4AN is dead

Quote:
Originally Posted by ftffom View Post
The dealer replaced the radio assembly. No explanation for why the original died.

Also replaced the blower fan (original was squeaky). The check engine late also came on the day before my appointment. They had to replace the oil cooler.

I am not feeling good about the reliability of this vehicle. Had no issues with my 2011.
ahhh welcome to the "damn, I should have kept my 2011" club.
__________________

__________________
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 JGC 8.4AN screen dead gda01 Troubleshooting/Problems Discussion 10 01-18-2014 06:29 PM
Uconnect 8.4AN with less features HELP!!! jzairick Grand Cherokee - WK2 - 9 01-14-2014 01:22 PM
Uconnect 8.4an camaross82 Trouble Shooting/Problems/Service 0 09-12-2013 01:57 PM
Uconnect 8.4AN question LSU_FAN Grand Cherokee - WK2 - 26 05-08-2013 11:19 PM
Uconnect 8.4A/8.4AN Manual tllapointe Audio/Visual/Navigation 7 05-08-2013 08:55 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community