uconnect issues - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-14-2016, 05:05 PM
New Member
 
Join Date: Oct 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
da01 is on a distinguished road
uconnect issues

Hi everyone

i own a jeep grand cherokee limited v6 and a couple of days ago a message appeared at the screen with the following legend: CHECKING FOR A USB STICK WITH AN UPDATE IFA A USB STICK WITHAN UPDATE IS DETECTED AN UPDATE CAN BE PERFORMED. and 3 minutes after that message it changed to: THERE WAS AN PROBLEM WHILE STARTING THE HEAD UNIT. and the screen was freezed i wasn't able to access any of the features in the screen it just stayed all black

i download the update required from uconnect website, follow all the procedures and try to install by myself the update, while installing the update it stopped completely rebooted and keep rebooting with a white screen saying PLEASE INSERT UPDATE USB. tried to install again the update but now doesn't read the usb anymore and the screen keeps rebooting again and again even while im driving showing the same legend on the screen

hope somebody can help with this problem

thanks

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-14-2016, 05:10 PM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,601
Thanks: 732
Thanked 1,065 Times in 826 Posts
Rep Power: 1805971
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: uconnect issues

First thing to try is disconnect the battery for 10 or 15 minutes. It has the same effect as rebooting a computer that has gone bonkers.


--
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #3  
Old 10-15-2016, 12:55 PM
New Member
 
Join Date: Oct 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
da01 is on a distinguished road
Re: uconnect issues

tried disconnecting the battery for around 30 minutes but the same result screen keeps asking for the usb and rebooting so annoying
Attached Images
File Type: jpg image1.JPG (380.3 KB, 20 views)
Reply With Quote
  #4  
Old 10-17-2016, 12:09 PM
JeepCares's Avatar
Jeep Customer Service
 
Join Date: Jan 2016
Location: Michigan
Posts: 278
Thanks: 3
Thanked 90 Times in 65 Posts
Rep Power: 201263
JeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond repute
Re: uconnect issues

Quote:
Originally Posted by da01 View Post
Hi everyone

i own a jeep grand cherokee limited v6 and a couple of days ago a message appeared at the screen with the following legend: CHECKING FOR A USB STICK WITH AN UPDATE IFA A USB STICK WITHAN UPDATE IS DETECTED AN UPDATE CAN BE PERFORMED. and 3 minutes after that message it changed to: THERE WAS AN PROBLEM WHILE STARTING THE HEAD UNIT. and the screen was freezed i wasn't able to access any of the features in the screen it just stayed all black

i download the update required from uconnect website, follow all the procedures and try to install by myself the update, while installing the update it stopped completely rebooted and keep rebooting with a white screen saying PLEASE INSERT UPDATE USB. tried to install again the update but now doesn't read the usb anymore and the screen keeps rebooting again and again even while im driving showing the same legend on the screen

hope somebody can help with this problem

thanks
Hi da01,

If you're still having trouble with the screen freezing, your dealership should be able to help troubleshoot. Let me know if you need any help setting up an appointment.

Kori
Jeep Social Care Specialist
Reply With Quote
  #5  
Old 10-17-2016, 02:03 PM
Member
 
Join Date: Aug 2010
Posts: 494
Thanks: 7
Thanked 58 Times in 53 Posts
Rep Power: 2938
Nonstop is on a distinguished road
uconnect issues

You'd think they could or would.
Jeepcares I really appreciate all of your input but I think this is one of the things you may want to contact if you dealers on and see how they respond to the statement "I would like to update my Uconnect and maps". Sure on a new purchase they'll try to do their "best" but in reality for a few year old they would rather climb Everest naked than do a damn thing about this around here.
__________________
2011 X 3.6
2000 WJ 5.2
Reply With Quote
  #6  
Old 10-17-2016, 03:40 PM
08Hemi's Avatar
Senior Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,977
Thanks: 142
Thanked 169 Times in 143 Posts
Rep Power: 369036
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Garage
Re: uconnect issues

Quote:
Originally Posted by Nonstop View Post
You'd think they could or would.
Jeepcares I really appreciate all of your input but I think this is one of the things you may want to contact if you dealers on and see how they respond to the statement "I would like to update my Uconnect and maps". Sure on a new purchase they'll try to do their "best" but in reality for a few year old they would rather climb Everest naked than do a damn thing about this around here.
I just did my update not too long ago (3rd time) and couple things to make sure:

1. Format the USB prior to doing anything; MUST be FAT32
2. 16GB to 32GB max usb size
3. Download the update again
4. Add to usb
5. Disconnect properly from your computer

Try that then plug the USB update in...if that doesn't work then the dealer is my only other thought.

Good luck!
__________________


2014 WK2 SRT aka "Jack" aFe Pro Dry-S, Corsa Cat-back, BT Goodies, Full LED's, Tint and mostly blacked-out
2008 WK 5.7L Limited aka "Jill" (Sold)
Reply With Quote
  #7  
Old 10-17-2016, 04:07 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,091
Thanks: 74
Thanked 293 Times in 257 Posts
Rep Power: 46487
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: uconnect issues

Quote:
Originally Posted by 08Hemi View Post
I just did my update not too long ago (3rd time) and couple things to make sure:

1. Format the USB prior to doing anything; MUST be FAT32
2. 16GB to 32GB max usb size
3. Download the update again
4. Add to usb
5. Disconnect properly from your computer

Try that then plug the USB update in...if that doesn't work then the dealer is my only other thought.

Good luck!
We will assume the only file on the USB stick is named swdl.iso

However, this does sound like it may be hardware going wonky.
Reply With Quote
  #8  
Old 10-17-2016, 04:44 PM
New Member
 
Join Date: Oct 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
da01 is on a distinguished road
Re: uconnect issues

im going to try with the FAT32 format. when downloading the update it said the usb should have a NTFS format

when downloading the archive the only archive in the usb is swdl

tried again this morning but it seems doesn't read the USB

gonna try tonight with the FAT32 format if not gonna take it to the dealer
Reply With Quote
  #9  
Old 10-17-2016, 06:49 PM
08Hemi's Avatar
Senior Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,977
Thanks: 142
Thanked 169 Times in 143 Posts
Rep Power: 369036
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Garage
Re: uconnect issues

Quote:
Originally Posted by da01 View Post
im going to try with the FAT32 format. when downloading the update it said the usb should have a NTFS format

when downloading the archive the only archive in the usb is swdl

tried again this morning but it seems doesn't read the USB

gonna try tonight with the FAT32 format if not gonna take it to the dealer
I really think that is your issue...FAT32 is everything I have seen and what has worked for me.

Let us know if it works...
Reply With Quote
  #10  
Old 10-18-2016, 05:49 PM
New Member
 
Join Date: Oct 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
da01 is on a distinguished road
Re: uconnect issues

tried everything to get the update done ... nothing worked , finally went to the dealer they said the head unit is damaged internally got to buy a new one doesn't apply any warranty due to mileage
Reply With Quote
  #11  
Old 10-22-2016, 10:44 PM
schmieg's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2013
Location: Cincinnati, Ohio
Posts: 547
Thanks: 6
Thanked 72 Times in 59 Posts
Rep Power: 1986
schmieg has a reputation beyond reputeschmieg has a reputation beyond repute
Re: uconnect issues

That's why I bought the MaxCare Lifetime contract. It's already paid for two radios and a blown rear shock.
__________________
--- Mike
2014 Grand Cherokee Overland, 3.6 Liter, OAII, Adv. Tech Group, MoPar Rock Rails

Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 UConnect phone pairing issues? Amylee Audio/Visual/Navigation 162 10-19-2013 02:17 PM
UConnect 2014 memory issues Roki303 Grand Cherokee - WK2 - 28 04-22-2013 01:27 PM
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 09:26 PM
Uconnect 8.4A issues kohj1978 Audio/Visual/Navigation 18 03-28-2013 09:25 PM
Uconnect issues Cascade159 Grand Cherokee - WK 2 03-16-2010 11:13 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.