Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-15-2013, 09:24 AM
JC_0105's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2012
Location: Atlanta
Posts: 301
Thanks: 108
Thanked 14 Times in 11 Posts
Rep Power: 5711
JC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond repute
Garage
Exclamation UConnect RA4 Nav with a mind of its own

I am on the latest UConnect release in my 2014 JGC (Edit: I thought I was on the latest but just saw 13.48.3 was posted a few days ago). Will update to that today to see if it resolves the issue.

I randomly have a very annoying issue where the navigation will get off track. It happens when I am using it to provide directions or when I am not using it with a location set. It appears to get confused and thinks I am on a different road and then it just goes off on it's own and will be completely off from where I really am. Has anyone else experienced this problem?

I attached some pictures of the GPS location and address location the Nav displayed and some google maps of how far off they were. The really odd thing is that the GPS coordinates didn't match the address the Nav displayed. I would at least think those items would be in sync. The actual location where I took the pictures is the 34.0887333, -84.2672333 coordinates that is on the Google Map picture showing the distance to the 2 locations the Nav was displaying.

What method is there to report this to Jeep besides going to a dealer? They are absolutely clueless about anything electronic and will be a complete waste of time. Hoping there is an online method that I can submit the details to instead since it is almost 2014 and we have this thing called the interwebs!
Attached Images
File Type: jpg IMG_1905.jpg (537.6 KB, 23 views)
File Type: jpg IMG_1904.jpg (529.2 KB, 29 views)
File Type: jpg GoogleMaps_Example1.JPG (168.6 KB, 19 views)
File Type: jpg GoogleMaps_Example2.JPG (121.1 KB, 16 views)
__________________

__________________
Past: '02 Laredo Sport v6 4x2 Graphite Metallic
Past: '05 Limited 5.7L 4x4 Black ~ Billstein Shocks ~ 32% tint
Current: '14 Summit HEMI 4x4 Black & Black
Job: IT Management

Reply With Quote
  #2  
Old 12-15-2013, 11:44 AM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 719
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1194
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: UConnect RA4 Nav with a mind of its own

try contacting jeep customer service?
__________________

__________________
Reply With Quote
  #3  
Old 12-15-2013, 09:08 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 816
Thanks: 0
Thanked 31 Times in 24 Posts
Rep Power: 73077
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: UConnect RA4 Nav with a mind of its own

Keep in mind that the way GPS works is, it's very close. So the NAV app will snap you to the road it thinks your on.

Sometimes if you are on a parallel road it the normal error might have you suddenly on the wrong road and it will give some weight to the route it calculated that you will follow it.

Until it sees you can't possible be on that route any longer and will try a new route on the nearest road.

I've seen this happen on every GPS system. Some more than others.

It's happened a few times on the GPS. But usually corrects itself.

There could also be a map error, which can happen and will really confuse it.

It depends how often and if it happens in more than certain locations to know if you do have a problem or not.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #4  
Old 12-15-2013, 09:20 PM
JC_0105's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Dec 2012
Location: Atlanta
Posts: 301
Thanks: 108
Thanked 14 Times in 11 Posts
Rep Power: 5711
JC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond reputeJC_0105 has a reputation beyond repute
Garage
Re: UConnect RA4 Nav with a mind of its own

It is way more than that in this case. I believe it was fixed in the latest UConnect update that I applied today. It has the following in the release notes.

** Navigation may not start or may lose position**.
-Loss of vehicle position on NAV map.

We'll see if it goes away now with these fixes.
__________________
Past: '02 Laredo Sport v6 4x2 Graphite Metallic
Past: '05 Limited 5.7L 4x4 Black ~ Billstein Shocks ~ 32% tint
Current: '14 Summit HEMI 4x4 Black & Black
Job: IT Management

Reply With Quote
Reply

Tags
ra4, uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Uconnect RA3 - RA4 / Engineering Menu *sox* Audio/Visual/Navigation 21 08-13-2014 03:42 PM
Wiring diagram for the MY14 RA4 UConnect 8.4 Radio gaidin43 Audio/Visual/Navigation 0 10-06-2013 08:26 AM
Release Schedule for UConnect 8.4N/RA4 Media/Info Apps ironroot Audio/Visual/Navigation 6 06-17-2013 02:47 PM
8.4AN (RA4) Nav question - traffic route alternives Sleestak Audio/Visual/Navigation 12 05-31-2013 01:36 PM
Can you upload MP3s to 2014 Overland with Uconnect 8.4AN/RA4? The Snowman Audio/Visual/Navigation 1 05-04-2013 10:13 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community