Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-27-2013, 10:09 AM
Premium Member
 
Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
omowbray is on a distinguished road
Uconnect system continually fails

Hello all,
This is my first post to this site. I've had my 2014 Grand Cherokee since August of this year. About a month after purchase the unconnect system froze, with the ominous "insert usb update" message. After I took it to the dealer and had the system restarted, the same thing happened. From there, I downloaded the uconnect update from this site, and nearly every 2-3 days the system does the same thing - flashing "insert USB update."

I've got a flash drive in my car, which I've used, and have re-downloaded the update multiple times. This seems to have no effect. However, after the update on the flash is re-installed, it runs fine. I just happen to start my car some mornings and the radio doesn't work.

Also, I've spoken with the dealership here and they are completely clueless and continually blame Chrysler for not having an update available yet.

Does anyone have any advice on anything I can do to fix this or how to work better with the dealership to get this right?

Thanks.
__________________

__________________
Reply With Quote
  #2  
Old 09-27-2013, 02:04 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 692
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1120
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Uconnect system continually fails

They should be replacing the unit. Minr used to freeze, blank out, etc... and it was replaced. Just doing an update wont fix a bad unit. You should try calling Chrysler Customer care.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
02 4.7 fails to crank Locker Troubleshooting/Problems Discussion 16 09-16-2013 11:29 PM
Never fails... kstruck Interior/Exterior/Visual 31 09-09-2013 04:22 PM
UConnect System edward.howes Audio, Video, Navigation & Electronic Modifications 2 01-27-2013 01:14 PM
Engine Fails To Start nick45 Trouble Shooting/Problems/Service 18 08-31-2012 07:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community