Updated to iOS 10 now no Audio through USB - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Audio/Visual/Navigation

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-16-2016, 08:37 PM
oneframe's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Mar 2016
Location: Vancouver, BC
Posts: 314
Thanks: 55
Thanked 35 Times in 32 Posts
Rep Power: 571
oneframe is on a distinguished road
Updated to iOS 10 now no Audio through USB

Hi,

Anyone else using an iPhone and updated to iOS 10 this week? I did and found that my usual route of listing to music through my iPhone via USB doesn't work any longer.

The odd thing is it recognizes the USB device - the song info is displayed on the UConnect screen including album artwork, but the actual audio plays through the phone and not the car stereo.

If I switch to Bluetooth, it works fine. But I wanted higher quality music output as well as the ability to charge which is attainable only when I plug the USB to Lightning cable.

Now my only choice is to listen via Bluetooth which I will obviously have to live with at this point. If I need to charge it, I can't use the USB plug in the front console because it confuses UConnect.

Waiting for Apple to hopefully fix.

__________________
2015 Jeep Grand Cherokee High Altitude Eco Diesel (Canada) - Valentine 1 + Blend Mount + Invisicord - Thinkware F750 front + rear Dash Cam + Cellink Battery B - Weathertec Front + 2nd Row + Cargo - Solar Gard Ultra Performance Ceramic Tint - 3M Paint Protection Film
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-16-2016, 10:05 PM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 182
Thanks: 129
Thanked 24 Times in 19 Posts
Rep Power: 2073
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Updated to iOS 10 now no Audio through USB

That is an interesting issue and unfortunate. Most of the chatter I've seen so far are complaints about battery life or the initial issue which was bricked phone. This is a new one.

I've experienced issues myself with new iOS versions and interaction with vehicles so I've resided to wait a while before upgrading. That doesn't help you much now. Have you tried restarting the UConnect system by chance? You could always downgrade to 9.3.5 before Apple stops signing it. Have you contacted Apple or UConnect to report this issue?

Thanks for bringing this up as I'll cautiously await further feedback before jumping into iOS 10.
Reply With Quote
  #3  
Old 09-16-2016, 11:53 PM
Member
My Jeep: 2015 6.4L SRT8 WK2
 
Join Date: Dec 2015
Posts: 236
Thanks: 16
Thanked 39 Times in 30 Posts
Rep Power: 582
Tinman4181 is on a distinguished road
Garage
Re: Updated to iOS 10 now no Audio through USB

Quote:
Originally Posted by oneframe View Post
Hi,

Anyone else using an iPhone and updated to iOS 10 this week? I did and found that my usual route of listing to music through my iPhone via USB doesn't work any longer.

The odd thing is it recognizes the USB device - the song info is displayed on the UConnect screen including album artwork, but the actual audio plays through the phone and not the car stereo.

If I switch to Bluetooth, it works fine. But I wanted higher quality music output as well as the ability to charge which is attainable only when I plug the USB to Lightning cable.

Now my only choice is to listen via Bluetooth which I will obviously have to live with at this point. If I need to charge it, I can't use the USB plug in the front console because it confuses UConnect.

Waiting for Apple to hopefully fix.
Try removing the phone from UConnect, doing a soft reboot, and then repairing it to see if that fixes it.
__________________
- 2015 SRT -
Reply With Quote
  #4  
Old 09-17-2016, 12:38 AM
Premium Member
 
Join Date: Aug 2013
Location: Boston
Posts: 1,724
Thanks: 39
Thanked 184 Times in 143 Posts
Rep Power: 76196
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: Updated to iOS 10 now no Audio through USB

It's working fine with iOS 10 on 6s plus with 2017 radio.

Both Uconnect App and BT Pairing shouldn't be related when it's just a USB device.
You don't even need either for USB to work.
__________________
07-24-2017 Summit 3.6L Velvet Red W/Black & Brown Int
Tires: OEM 20"/Nokian 18"
Situational awareness: Valentine One with V1Driver on IOS
Reply With Quote
  #5  
Old 09-17-2016, 09:52 AM
Jim_in_PA's Avatar
Super Moderator

My Jeep: 2012 5.7L WK2
 
Join Date: Jul 2012
Location: SE PA (central Bucks County)
Posts: 4,299
Thanks: 779
Thanked 570 Times in 455 Posts
Rep Power: 96062
Jim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond reputeJim_in_PA has a reputation beyond repute
Garage
Re: Updated to iOS 10 now no Audio through USB

In the past, un-pairing and re-pairing the device has fixed this issue, at least for BT connections. I'd try that even though this is a USB issue in case the BT pairing is messing something up.
__________________
2012 GC Overland Summit - Winter Chill with New Saddle interior. 5.7L HEMI V8 - Pirelli Scorpion Verde Plus "shoes" - LED fogs and DRLs



Day-job...Telecom Technical Sales
Avocations...Woodworking, Equestrian, Food, Photography
Reply With Quote
  #6  
Old 09-17-2016, 12:42 PM
oneframe's Avatar
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Mar 2016
Location: Vancouver, BC
Posts: 314
Thanks: 55
Thanked 35 Times in 32 Posts
Rep Power: 571
oneframe is on a distinguished road
Re: Updated to iOS 10 now no Audio through USB

UPDATE: RESOLVED!

First, thanks guys for chiming in. I did try the remove, forget, restart, then pair twice yesterday prior to posting with no luck.

I searched and found a similar issue on this for various vehicles as well but with iOS 9 (when it was released with Apple Music). And that turned out the culprit.

So the strange fix was to actually add a song to your Apple Music app and it will route the music through the Lightning port again.

What happened to me is that when I updated to iOS 10 I also happened to clean out my stored music in the Apple Music app because I exclusively listen via Spotify.

By zeroing out the music, it disables the USB music out and you can only stream what you have via Bluetooth. Whether this is a glitch it was never fixed in iOS 10.


Sent from my iPhone using JeepGarage
__________________
2015 Jeep Grand Cherokee High Altitude Eco Diesel (Canada) - Valentine 1 + Blend Mount + Invisicord - Thinkware F750 front + rear Dash Cam + Cellink Battery B - Weathertec Front + 2nd Row + Cargo - Solar Gard Ultra Performance Ceramic Tint - 3M Paint Protection Film
Reply With Quote
The Following User Says Thank You to oneframe For This Useful Post:
  #7  
Old 09-17-2016, 08:13 PM
jaybo41's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jul 2015
Location: Pittsburgh, PA
Posts: 182
Thanks: 129
Thanked 24 Times in 19 Posts
Rep Power: 2073
jaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond reputejaybo41 has a reputation beyond repute
Re: Updated to iOS 10 now no Audio through USB

That's awesome that you found the problem and have been able to resolve it. Aside from the bugs in the first release I am always concerned about how the new iOS will work with my vehicle. In 2012 (I think) the update completely hosed my bluetooth connectivity and I wasn't alone. Since that point, I've been leery about updating immediately.

Thanks for taking the time to report back with your findings and glad to hear all is working out
Reply With Quote
The Following User Says Thank You to jaybo41 For This Useful Post:
  #8  
Old 09-17-2016, 10:33 PM
BorderBob's Avatar
Member
 
Join Date: May 2015
Posts: 15
Thanks: 1
Thanked 4 Times in 2 Posts
Rep Power: 587
BorderBob is on a distinguished road
Re: Updated to iOS 10 now no Audio through USB

You are going to hate this, it no problems with my 2014 JGC with the 8.4 radio. IPhone 6 or current gen iPod touch (touch is USB, phone is Bluetooth)


Sent from my iPhone using JeepGarage
Reply With Quote
  #9  
Old 10-26-2016, 07:15 PM
Premium Member
 
Join Date: Dec 2010
Posts: 52
Thanks: 3
Thanked 2 Times in 1 Post
Rep Power: 2229
Shem is on a distinguished road
Garage
Re: Updated to iOS 10 now no Audio through USB

My issue with UConnect and iOS 10 is the BT audio stream. My iPhone 7 pairs perfectly with UConnect, acknowledges voice and audio connection, even receives audio data over the car speakers from voice calls normally. My problem is my Apple Music files residing on the iPhone's HD as well as Pandora or anything else with audio, it does not play through the car speakers. UConnect says it's paired with the iPhone, the iPhone says it's paired with UConnect, everything "looks" like it's audio streaming correctly, just no audio through the car speakers. I called UConnect support today and the rep claimed it is due to the older 730N RHR radio not accepting the higher quality music files on my iPhone 7. I don't understand how that could be, it's not streaming any audio. A side note, the iPhone 7's BT was perfectly with a separate BT headphone adapter I have. Any insight to a resolve on this would be greatly appreciated.


Shem
2011 Grand Cherokee Overland 4x4
Metallic Pewter
730N RHR radio
-OlllllllO-

Quote:
Originally Posted by oneframe View Post
UPDATE: RESOLVED!

First, thanks guys for chiming in. I did try the remove, forget, restart, then pair twice yesterday prior to posting with no luck.

I searched and found a similar issue on this for various vehicles as well but with iOS 9 (when it was released with Apple Music). And that turned out the culprit.

So the strange fix was to actually add a song to your Apple Music app and it will route the music through the Lightning port again.

What happened to me is that when I updated to iOS 10 I also happened to clean out my stored music in the Apple Music app because I exclusively listen via Spotify.

By zeroing out the music, it disables the USB music out and you can only stream what you have via Bluetooth. Whether this is a glitch it was never fixed in iOS 10.


Sent from my iPhone using JeepGarage
Reply With Quote
Reply

Tags
update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iOS 8.3 and audio playback damien79 Grand Cherokee SRT - WK2 1 04-23-2015 10:18 PM
iPhone 4S won't connect to 130S/RES through USB Port but iPhone 5S will? KJPECHO Audio/Visual/Navigation 2 06-26-2014 12:20 PM
iOS 6.1 + USB mufugger Audio/Visual/Navigation 4 02-06-2013 07:15 PM
Playing music through center console USB port RMac Audio/Visual/Navigation 75 07-28-2011 02:01 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.