Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT - WK2 > WK2 SRT General Discussion > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-27-2012, 05:28 PM
Member
My Jeep: 2012 SRT8 WK2
 
Join Date: Jun 2011
Posts: 48
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1266
Unsequestered is on a distinguished road
LED's off?

My LED's are not on when the vehicle is in park or drive when the lights are not on. In other words if the headlights are not on then the LED's are ALWAYS off. The only way I can get the LED's on is to start the vehicle with the remote or turn the headlights on. Also just to be clear, I don't mean running lights or any other light setting....it must be the full headlights. As far as I recall the LED's are always on when driving.

Is there some code/setting I hit accidentally that is causing this?
__________________

__________________
Reply With Quote
  #2  
Old 09-27-2012, 05:45 PM
Member
 
Join Date: Jul 2011
Posts: 482
Thanks: 0
Thanked 24 Times in 19 Posts
Rep Power: 1712
mlarco52 has a reputation beyond reputemlarco52 has a reputation beyond repute
Re: LED's off?

The LED's will not come on when the vehicle is in park and the headlights are in the off or auto position. If the headlights are in the off/auto position they [the led's] will only come on when the vehicle is engaged in drive, neutral, or reverse. If the headlights are the the led's will come on.

So you won't see the led's on unless you get someone to jump in your car for you and leave the headlights at auto or off, and then engage the vehicle into drive, neutral, or reverse then they [the led's] will pop on.
__________________

__________________
Reply With Quote
The Following User Says Thank You to mlarco52 For This Useful Post:
  #3  
Old 09-27-2012, 06:13 PM
Member
My Jeep: 2012 SRT8 WK2
 
Join Date: Jun 2011
Posts: 48
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1266
Unsequestered is on a distinguished road
Re: LED's off?

Quote:
Originally Posted by mlarco52 View Post
The LED's will not come on when the vehicle is in park and the headlights are in the off or auto position. If the headlights are in the off/auto position they [the led's] will only come on when the vehicle is engaged in drive, neutral, or reverse. If the headlights are the the led's will come on.

So you won't see the led's on unless you get someone to jump in your car for you and leave the headlights at auto or off, and then engage the vehicle into drive, neutral, or reverse then they [the led's] will pop on.
I was driving in a convoy on the expressway with family and they noticed it. So today I had someone drive it outside with sunlight while I watched. So like I said originally, the vehicle's LED's do NOT work when driving the vehicle with any light setting accept the full headlight setting.
__________________
Reply With Quote
  #4  
Old 09-27-2012, 07:21 PM
Mongoose9400's Avatar
Member
My Jeep: 2012 6.4L WK2
 
Join Date: Feb 2012
Location: Rio Rancho, NM
Posts: 829
Thanks: 0
Thanked 51 Times in 42 Posts
Rep Power: 0
Mongoose9400 is an unknown quantity at this point
The LEDs have two setting. From what you explain it appears that only the low setting is working for the LED bars. The low setting happens during remote start and when the headlights are turned on (either manually or in automatic mode). The high setting is when the Jeep is running, e-brake off, and in any transmission position besides park. This also includes if the lighting switch is turned to running/parking like and/or fog lights.

My best guess would be either they are faulty, bad LED strips or missing an electrical component somewhere (i.e. a relay/fuse) Or, an option in the StarScan needs to turn them on.

I would say a visit to the dealer to solve this.


Sent from my iPhone 5
__________________
Reply With Quote
  #5  
Old 09-27-2012, 08:36 PM
Member
My Jeep: 2012 SRT8 WK2
 
Join Date: Jun 2011
Posts: 48
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1266
Unsequestered is on a distinguished road
Re: LED's off?

Quote:
Originally Posted by Mongoose9400 View Post
The LEDs have two setting. From what you explain it appears that only the low setting is working for the LED bars. The low setting happens during remote start and when the headlights are turned on (either manually or in automatic mode). The high setting is when the Jeep is running, e-brake off, and in any transmission position besides park. This also includes if the lighting switch is turned to running/parking like and/or fog lights.

My best guess would be either they are faulty, bad LED strips or missing an electrical component somewhere (i.e. a relay/fuse) Or, an option in the StarScan needs to turn them on.

I would say a visit to the dealer to solve this.


Sent from my iPhone 5
Thanks all!

I figured it would lead to a dealer visit. I just thought I should ask you experts in case I did something stupid and maybe I could reverse it before taking it in.

Can't wait to let you know what the issue is.

My guess is the dealer screwed it up when it was there for a month fixing the transmission issue.
__________________
Reply With Quote
  #6  
Old 09-27-2012, 08:50 PM
Member
 
Join Date: Jul 2011
Posts: 482
Thanks: 0
Thanked 24 Times in 19 Posts
Rep Power: 1712
mlarco52 has a reputation beyond reputemlarco52 has a reputation beyond repute
Re: LED's off?

Hopefully just a blown fuse or something. Let us know what they find please would love to know what's behind this issue.

EDIT: Just went and checked the manual looks like the fuse that controls this is M15 but it controls a bunch of other stuff if you're not experiencing this stuff then it might be something else.

M15 Fuse Location
20 amp yellow fuse

Description:

Power Seat Module(s)
Adaptive Cruise Control
Audio Telematics
Daytime Running Lights Relay
Air Suspension Module
Instrument Cluster
__________________
Reply With Quote
  #7  
Old 09-27-2012, 09:06 PM
Mongoose9400's Avatar
Member
My Jeep: 2012 6.4L WK2
 
Join Date: Feb 2012
Location: Rio Rancho, NM
Posts: 829
Thanks: 0
Thanked 51 Times in 42 Posts
Rep Power: 0
Mongoose9400 is an unknown quantity at this point
Quote:
Originally Posted by mlarco52 View Post
Hopefully just a blown fuse or something. Let us know what they find please would love to know what's behind this issue.

EDIT: Just went and checked the manual looks like the fuse that controls this is M15 but it controls a bunch of other stuff if you're not experiencing this stuff then it might be something else.

M15 Fuse Location
20 amp yellow fuse

Description:

Power Seat Module(s)
Adaptive Cruise Control
Audio Telematics
Daytime Running Lights Relay
Air Suspension Module
Instrument Cluster
Is this a non SRT8 manual? The Air suspension module wouldn't be needed for the SRT8.


Sent from my iPhone 5
__________________
Reply With Quote
  #8  
Old 09-27-2012, 09:19 PM
Member
 
Join Date: Jul 2011
Posts: 482
Thanks: 0
Thanked 24 Times in 19 Posts
Rep Power: 1712
mlarco52 has a reputation beyond reputemlarco52 has a reputation beyond repute
Re: LED's off?

Nope it stated SRT8 manual, a lot of things that were carried over in the manual from the wk2 to the wk2 srt8 manual for some reason. Guess they didn't wanna go back and re-write it all.
Attached Files
File Type: pdf 2012_wk_owners_manual_srt8_2nd.pdf (4.04 MB, 3 views)
__________________
Reply With Quote
  #9  
Old 09-28-2012, 03:14 AM
EviL's Avatar
Member
My Jeep: 2012 6.4L WK2
 
Join Date: Jan 2012
Location: UAE
Posts: 335
Thanks: 0
Thanked 17 Times in 12 Posts
Rep Power: 439549
EviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond reputeEviL has a reputation beyond repute
Re: LED's off?

hey guys, i noticed that this problem only occurs in the foreign jeeps

my srt has no led bars when put on auto or even when the head lights are on

the dealership sez that all jeeps thats in the gcc area dont have that

as well as the remote start
__________________
Reply With Quote
  #10  
Old 09-28-2012, 10:26 AM
Member
 
Join Date: Feb 2011
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1359
JEEPYOU is on a distinguished road
Re: LED's off?

I have not been back to the dealer (too damn busy), but my assumption is that the DRL LED's have a setting that allows them to be turned off and on... but only with the Star-Scan tool.

Since I refused to pay the dealer prep on my Jeep (and they did not "prep" it), my guess is that the DRL LED's were not set to "on" per the prep list provided by Jeep to the dealership.

Again, just a guess... but I think a pretty good one.
__________________
Reply With Quote
  #11  
Old 10-04-2012, 10:21 AM
Member
My Jeep: 2012 SRT8 WK2
 
Join Date: Jun 2011
Posts: 48
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1266
Unsequestered is on a distinguished road
Re: LED's off?

Update:

Went to the dealer yesterday and after a little over two hours of waiting there, the issue was not resolved.

I was told that all the settings look good and that they are going to send a copy of my settings to Chrysler to see if they can solve it. The dealer says that while the settings are as they should be it seems that the truck does not know that it is an SRT. This could be why the LED's are not working as they should.

They partially put the blame on the Chrysler rep that came down to look at it when it was in the shop for a month. They said that maybe he changed the software on it to try and solve the trans issue. Aside from this theory, as the dealer put it, "It just doesn't make sense." Unfortunately I am getting tired of this excuse with this truck after hearing that exact statement over and over again as it sat at the dealer for nearly a month.

Oh well...At least the truck is drivable.

Ill keep you apprised folks!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Premium LED Dome Light Kit (Jeep Specific) on SALE!! - Upgrade to LED NOW! XenonDepot XenonDepot 341 09-25-2014 03:29 PM
Philips LED bulbs on SALE!! - Upgrade to LED NOW! Discounts available! XenonDepot XenonDepot 0 10-20-2011 02:40 PM
***Side emmiting flexable LED strip!!!*** (LED EYEBROW) White WK Swagga Visual Modifications 70 09-09-2009 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community