Message: Service Adaptive Damping Suspension System - Page 8 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT - WK2 > WK2 SRT General Discussion > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #85  
Old 09-21-2014, 02:42 PM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Hi guys .. Got the same message on the screen yesterday
ForumRunner_20140921_222918.png

Came stright here & searched the forums ...
looked behind the rear passenger tire and found the wire loose but with no damage

ForumRunner_20140921_223006.png


Here u could see the other side

ForumRunner_20140921_223155.png

And this shows the wire back in

ForumRunner_20140921_223207.png

The car seems stuck in the (stiff) mode and i still have the message on the screen is there any way to clear it ?
Would unplugging the battery work ?

I'm trying to avoid the dealer (no warranty )

Reply With Quote
Sponsored Links
Advertisement
 
  #86  
Old 09-23-2014, 07:30 AM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Unplugged the battery for a day ... As soon as I started the SRT, I got the message again !!!!


There's no damage to the wires ! So where is the problem
Reply With Quote
  #87  
Old 09-23-2014, 07:31 AM
CLStech's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Nov 2011
Location: RTP, NC
Posts: 2,168
Thanks: 1,360
Thanked 594 Times in 403 Posts
Rep Power: 1548600
CLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond repute
Garage
Quote:
Originally Posted by Saudi.SRT8 View Post
Unplugged the battery for a day ... As soon as I started the SRT, I got the message again !!!!

There's no damage to the wires ! So where is the problem
Possibly the control module itself...
__________________
The Albino: 2014 SRT Grand Cherokee
Bright White - Black/Sepia - Black Chrome - Tow Package - High Performance Audio - Pano Roof
*Debadged | Black Vinyl Wrapped Roof | Reflective Caliper Wrap | Billet Technology Catch Can & Accesories | Injen Intake | LED Interior Swap | LED Puddle/Entry Lighting | Lower Grill Badge | Tint | 6000K Headlights | 3000K Foglights | Road Magnet Mid Springs | Headlight DRL Mod | RAX Jailbreak | Rear Fog Lights | Electronic Cutouts | BlackOps End Links | Borla S-type | Velgen VMB5 22x10.5*
Instagram: CLStech
Twitter: CLStech
Reply With Quote
Sponsored Links
Advertisement
 
  #88  
Old 09-23-2014, 08:00 AM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Where is the control module located ? Is it something I could change? Any part number?
Is it something the Road Magnets did ?
Reply With Quote
  #89  
Old 09-23-2014, 08:43 AM
CLStech's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Nov 2011
Location: RTP, NC
Posts: 2,168
Thanks: 1,360
Thanked 594 Times in 403 Posts
Rep Power: 1548600
CLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond reputeCLStech has a reputation beyond repute
Garage
Re: Message: Service Adaptive Damping Suspension System

Quote:
Originally Posted by Saudi.SRT8 View Post
Where is the control module located ? Is it something I could change? Any part number?
Is it something the Road Magnets did ?
Not sure exactly... Here is the post talking about the module
Quote:
Originally Posted by Cage View Post
Hi mate, this is exactly what happened to me.

They replaced the passenger side shock and the module in the steering wheel as SRTWIL had and all good. Tell your service department to get it done and don't take no for an answer. It took about 6 weeks for it to come in.
__________________
The Albino: 2014 SRT Grand Cherokee
Bright White - Black/Sepia - Black Chrome - Tow Package - High Performance Audio - Pano Roof
*Debadged | Black Vinyl Wrapped Roof | Reflective Caliper Wrap | Billet Technology Catch Can & Accesories | Injen Intake | LED Interior Swap | LED Puddle/Entry Lighting | Lower Grill Badge | Tint | 6000K Headlights | 3000K Foglights | Road Magnet Mid Springs | Headlight DRL Mod | RAX Jailbreak | Rear Fog Lights | Electronic Cutouts | BlackOps End Links | Borla S-type | Velgen VMB5 22x10.5*
Instagram: CLStech
Twitter: CLStech
Reply With Quote
The Following User Says Thank You to CLStech For This Useful Post:
  #90  
Old 09-23-2014, 08:46 AM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Thanks for the help ...


any more inputs guys ?
Reply With Quote
  #91  
Old 09-24-2014, 10:04 AM
Red Suns's Avatar
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2013
Location: PNW
Posts: 137
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 1649
Red Suns is on a distinguished road
Re: Message: Service Adaptive Damping Suspension System

Quote:
Originally Posted by Saudi.SRT8 View Post
Unplugged the battery for a day ... As soon as I started the SRT, I got the message again !!!!


There's no damage to the wires ! So where is the problem
1. Out of curiosity, was it raining/wet recently when you got the message?

2. You might want to try the following which was mentioned in an earlier post.

Quote:
Originally Posted by aussiesrt View Post
Hi Cage, we seem to have exactly same problem. Mine comes and goes, it's funny you say now its stopped raining i'll go and have a look. Mine only seems to play up after we have had some rain, which it did again yesterday as it is pouring in central Queensland. What I have discovered though is if you unplug the wire connector that is closest to the shock, then put it back together, the message will clear. To do this , do it one at a time and check to see if message goes away.
3. Just for the record, I too *just* got this "Service Adaptive Damping Suspension System" message for the first time yesterday. It came on and went away twice during a 4 hour drive and went away after it was parked for an hour. It was raining but I haven't had a chance to crawl underneath to check or to rule out for possible damage to the strut controller wires yet.
Reply With Quote
  #92  
Old 09-24-2014, 10:22 AM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Quote:
Originally Posted by Red Suns View Post

1. Out of curiosity, was it raining/wet recently when you got the message?.
I was washing the car before I got the message ...

Ummm. I'll try to unplug the wires, if I could figure out where are the connectors .
Reply With Quote
  #93  
Old 09-29-2014, 12:35 AM
Red Suns's Avatar
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2013
Location: PNW
Posts: 137
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 1649
Red Suns is on a distinguished road
Re: Message: Service Adaptive Damping Suspension System

Well, so much for my theory on the possible correlation of moisture and the prompting of the " Service Adaptive Damping Suspension System" message.

Earlier in the day, I gave a thorough visual check of the bilstein shocks and struts. I found nothing out of the ordinary or any wires or connectors out of place.

Was running some errands this clear and dry, 60F degree evening, after driving normally down a straight portion of the freeway for about 30min, and out of the blue I get pinged with the message again.

I then pulled over, restarted the Jeep, the message was cleared and 5 min later I get pinged with the same message.

I pull over again and restart the Jeep. However, this time, after driving another 15 min, I get nothing.

Next time I will be capturing a pic of each time I get pinged with this message in hopes this will be enough for the service folk at the dealership to take corrective action.

I cannot fathom at this point whether or not this is due to a possible defective controller or defective Bilstein shock/strut.

I will try to confirm if I lose the functionality of both the cruise controller and reverse guidance lines as posted earlier in this thread the next time I get this message.

Does anybody know off hand of their is a TSB on either component?

Full firm on these adaptive struts and shocks is not fun on slightly uneven roads...
Reply With Quote
  #94  
Old 09-29-2014, 07:37 AM
Saudi.SRT8's Avatar
Member
 
Join Date: Mar 2012
Posts: 168
Thanks: 2
Thanked 13 Times in 10 Posts
Rep Power: 2110
Saudi.SRT8 is a name known to all
Quote:
Originally Posted by Red Suns View Post
Well, so much for my theory on the possible correlation of moisture and the prompting of the " Service Adaptive Damping Suspension System" message.
...
Now I get the message in 5-10 sec after the start ...

How to disconnect the connectors from the shocks ? What's the way to do it ? I'm afraid that I'll cut or break something
Reply With Quote
  #95  
Old 09-30-2014, 02:06 AM
aussiesrt's Avatar
Member
My Jeep: 2014 6.4L SRT WK2
 
Join Date: Feb 2014
Location: Blackwater
Posts: 120
Thanks: 88
Thanked 10 Times in 8 Posts
Rep Power: 1343
aussiesrt is on a distinguished road
Garage
Re: Message: Service Adaptive Damping Suspension System

Well mate as for the messages, since the update from the dealership everything has been good, I tried the wire search for problems , shut down and restart didn't work but until the update nothing worked
Reply With Quote
  #96  
Old 10-29-2014, 08:06 PM
hankwedge's Avatar
Hank
My Jeep: 2014 6.4L SRT8
 
Join Date: Feb 2012
Location: Pittsburgh
Posts: 744
Thanks: 28
Thanked 37 Times in 30 Posts
Rep Power: 2966
hankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond reputehankwedge has a reputation beyond repute
Garage
Quote:
Originally Posted by aussiesrt View Post
Well mate as for the messages, since the update from the dealership everything has been good, I tried the wire search for problems , shut down and restart didn't work but until the update nothing worked
I'm a little late I n this but I got the code going on and off right now and is the recall that just came out? Software update?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Active Damping Suspension noise? Milous Grand Cherokee SRT - WK2 20 01-11-2013 07:10 PM
"Service 4wd system" message 21076 Troubleshooting/Problems 5 01-03-2013 04:50 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 08:31 AM
Service Light - SERVICE 4WD SYSTEM - ?? Only 30K miles.... babygorilla Grand Cherokee - WK 4 02-17-2011 07:09 PM
Service 4WD System Message cain45 Grand Cherokee - WK 18 09-13-2010 05:49 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.