Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT - WK2 > WK2 SRT General Discussion > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-10-2012, 04:41 PM
Premium Member
My Jeep: 2012 6.4L SRT8 WK2
 
Join Date: Feb 2012
Location: Redding CA
Posts: 222
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1235
radbushi has a reputation beyond reputeradbushi has a reputation beyond reputeradbushi has a reputation beyond repute
Tranny Issue

I got on my jeep hard this morning and shifting from 1st to 2nd It seemed to hit nutral for a second or two then engaged. Anyone else seen this. I have 5800 miles on it.
Thanks
__________________

__________________
Reply With Quote
  #2  
Old 12-10-2012, 04:48 PM
Member
 
Join Date: Aug 2012
Posts: 323
Thanks: 2
Thanked 18 Times in 17 Posts
Rep Power: 59119
A.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond repute
Re: Tranny Issue

My guess is you hit the rev limiter, mines done that when I got on it hard from a stop. Only on the 1-2 shift have I done it
__________________

__________________
Reply With Quote
  #3  
Old 12-10-2012, 04:55 PM
Premium Member
My Jeep: 2012 6.4L SRT8 WK2
 
Join Date: Feb 2012
Location: Redding CA
Posts: 222
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1235
radbushi has a reputation beyond reputeradbushi has a reputation beyond reputeradbushi has a reputation beyond repute
Re: Tranny Issue

You are probably right, thanks for the input!
__________________
Reply With Quote
  #4  
Old 12-10-2012, 05:01 PM
Member
 
Join Date: Aug 2012
Posts: 323
Thanks: 2
Thanked 18 Times in 17 Posts
Rep Power: 59119
A.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond repute
Re: Tranny Issue

Quote:
Originally Posted by radbushi View Post
You are probably right, thanks for the input!
No prob, only other time I've had a delay in the shift is when the tranny is cold and I jumped on it
__________________
Reply With Quote
  #5  
Old 12-10-2012, 05:02 PM
HAMMMERHEAD's Avatar
Member
 
Join Date: Oct 2011
Location: The Ozarks
Posts: 369
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1458
HAMMMERHEAD is on a distinguished road
Re: Tranny Issue

Its funny you mention this Radbushi, mine has been doing this on occasion, but only in track mode. Mine seems to be doing it just around the 2nd to 3 second while its pulling in 1st gear on a hard launch. Im pretty sure its not the limiter as I have mine raised to 6600. It sounds a lot like the tranfer case chain is slipping just for a moment. I have read where others have this going on too.
__________________
Reply With Quote
  #6  
Old 12-10-2012, 05:08 PM
Member
 
Join Date: Aug 2012
Posts: 323
Thanks: 2
Thanked 18 Times in 17 Posts
Rep Power: 59119
A.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond repute
Re: Tranny Issue

Quote:
Originally Posted by HAMMMERHEAD View Post
Its funny you mention this Radbushi, mine has been doing this on occasion, but only in track mode. Mine seems to be doing it just around the 2nd to 3 second while its pulling in 1st gear on a hard launch. Im pretty sure its not the limiter as I have mine raised to 6600. It sounds a lot like the tranfer case chain is slipping just for a moment. I have read where others have this going on too.
Are you talking about where the rpms start dropping between 3-4k when you launch hard and then it picks back up again?
__________________
Reply With Quote
  #7  
Old 12-10-2012, 05:09 PM
Premium Member
My Jeep: 2012 6.4L SRT8 WK2
 
Join Date: Feb 2012
Location: Redding CA
Posts: 222
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1235
radbushi has a reputation beyond reputeradbushi has a reputation beyond reputeradbushi has a reputation beyond repute
Re: Tranny Issue

It was definly cold. Outside temp was about 45 and I had only gone about 3 blocks befor I got on it.
__________________
Reply With Quote
  #8  
Old 12-10-2012, 05:12 PM
HAMMMERHEAD's Avatar
Member
 
Join Date: Oct 2011
Location: The Ozarks
Posts: 369
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1458
HAMMMERHEAD is on a distinguished road
Re: Tranny Issue

Quote:
Originally Posted by A.V.GCSRT8 View Post
Are you talking about where the rpms start dropping between 3-4k when you launch hard and then it picks back up again?

Oh no. This is an actual slip. If feels a LOT like the chain is slipping. It feels fully mechanical, not like the safety nanny cutting the engine back from trying to power brake it on a launch. If its not a chain slipping, something is binding up for sure, but I have only noticed it in track mode. Doesnt track mode actually lock a percentage of power to the front?
__________________
Reply With Quote
  #9  
Old 12-10-2012, 05:22 PM
Member
 
Join Date: Aug 2012
Posts: 323
Thanks: 2
Thanked 18 Times in 17 Posts
Rep Power: 59119
A.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond reputeA.V.GCSRT8 has a reputation beyond repute
Re: Tranny Issue

Quote:
Originally Posted by HAMMMERHEAD View Post
Oh no. This is an actual slip. If feels a LOT like the chain is slipping. It feels fully mechanical, not like the safety nanny cutting the engine back from trying to power brake it on a launch. If its not a chain slipping, something is binding up for sure, but I have only noticed it in track mode. Doesnt track mode actually lock a percentage of power to the front?
Oh ok, put it in auto stick with the traction control off and see if it still does it. I'm thinking it has something to do with that, maybe allowing more power to get to the front wheel at launch. I think we need a LSD for the front, so it at least will split the power to both axles instead of just one
__________________
Reply With Quote
  #10  
Old 12-10-2012, 05:42 PM
Premium Member
My Jeep: 2012 6.4L SRT8 WK2
 
Join Date: Feb 2012
Location: Redding CA
Posts: 222
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1235
radbushi has a reputation beyond reputeradbushi has a reputation beyond reputeradbushi has a reputation beyond repute
Re: Tranny Issue

For me it felt like I pushed the shifter up into nutral. The engine kept reving then it was like I puled it back into drive. I didn't like the feeling of it at all.
__________________
Reply With Quote
  #11  
Old 12-10-2012, 06:51 PM
HAMMMERHEAD's Avatar
Member
 
Join Date: Oct 2011
Location: The Ozarks
Posts: 369
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 1458
HAMMMERHEAD is on a distinguished road
Re: Tranny Issue

Quote:
Originally Posted by A.V.GCSRT8 View Post
Oh ok, put it in auto stick with the traction control off and see if it still does it. I'm thinking it has something to do with that, maybe allowing more power to get to the front wheel at launch. I think we need a LSD for the front, so it at least will split the power to both axles instead of just one
I had it in Track mode and set in Drive (my manual shift times are always slower) with TC turned off. I also held down on TC button for 5-10 seconds and the ESC turned off as well. I have had this truck for almost 6 months and it has never had near the power it now has with this cold air passing through. Its been fun for a couple days, but I could see breaking something with this much torque.




Quote:
Originally Posted by radbushi View Post
For me it felt like I pushed the shifter up into nutral. The engine kept reving then it was like I puled it back into drive. I didn't like the feeling of it at all.
Your description is spot on what I have felt. I might add I have experienced this berfore I put the Trinity tune in.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another Grand Cherokee Tranny Issue 02GrandHO Troubleshooting/Problems 34 03-06-2013 03:15 PM
2012 JGC Tranny Issue Laredo or Bust Trouble Shooting/Problems/Service 3 06-09-2012 01:41 PM
HELP! Possible tranny issue?? 06RC22 Troubleshooting/Problems Discussion 5 08-20-2011 03:27 PM
07 tranny issue, I think! JCFiredog Grand Cherokee - WK 19 02-01-2011 05:26 PM
05' wk tranny issue Allaboutjeeps14 Troubleshooting/Problems Discussion 3 10-19-2009 04:44 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community