Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT - WK2 > WK2 SRT General Discussion > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-19-2013, 05:59 PM
Niva's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Sep 2013
Location: Houston, TX
Posts: 45
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 270
Niva is on a distinguished road
UConnect issues with SD card and Audio from Bluetooth

Hey guys,

I own a brand new 2014 SRT GC.

As of yesterday I can no longer access my SD card, I think the system did an update as I lost most of my saved radio stations (but not all). Previously the card had worked fine. I just checked my card at the PC and it's working fine, all the files are there, no corruption from what I could tell. I had it locked too while it was in the Jeep.

Similarly the system stopped straming audio through BT which had worked fine previously. It still says my phone is connected, and my phone thinks it connected as it doesn't play through its speakers, but no audio coming out through the jeep's speakers.

When selecting the BT or SD card icons I just get "Connect Media" text in the main display.

Any advice would be appreciated, this litereally started happening yesterday and I can't seem to figure out what exactly caused it.

Everything else on the system is fine, maps, radio work great, no sluggishness. Like I said I did lose some previously saved radio stations but not all. It appears like there was a software update overnight. Is this normal? Anyone else affected?
__________________

__________________
Reply With Quote
  #2  
Old 09-21-2013, 12:43 PM
Member
 
Join Date: Aug 2012
Posts: 63
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 684
Dguth is on a distinguished road
This happened repeatedly to me on my 2014. Uconnect works fine except nothing works on the media button. Even when I hard connected my phone to the USB port, it still would not recognize any media input. Couple ways to fix. You can reset the uconnect by pushing in simultaneously on the two big knob buttons. Hold for about 5 seconds and it will reset. Media should then work and recognize your SD card. If problem continues just pull out the SD card entirely. I had to do that with mine. I don't leave my SD card in anymore as it was locking up every time I got in the car. With SD card out it recognizes the Bluetooth streaming on my phone, no problem. I think the system gets real finicky with certain high volume SD cards.
__________________

__________________
Reply With Quote
  #3  
Old 09-22-2013, 07:22 PM
Niva's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Sep 2013
Location: Houston, TX
Posts: 45
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 270
Niva is on a distinguished road
Re: UConnect issues with SD card and Audio from Bluetooth

Thank you for the response sir,

I have some updates. I did discover that at some points, randomly, the card would work again and so would bluetooth. It is as you describe, all of the "media" connections get broken when this is an issue.

The SD card I am using is a 32GB Kingston. Is this too big? Can others report similar issues and what is a safe size/brand card to use which doesn't cause these sort of issues.

Yeah I've generally left the card disconnected now and at least bluetooth seems to work better.
__________________
Reply With Quote
  #4  
Old 09-30-2013, 02:58 PM
Premium Member
My Jeep: 2012 6.4L SRT8 WK2
 
Join Date: Feb 2012
Location: Redding CA
Posts: 221
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1066
radbushi has a reputation beyond reputeradbushi has a reputation beyond reputeradbushi has a reputation beyond repute
Re: UConnect issues with SD card and Audio from Bluetooth

Quote:
Originally Posted by Niva View Post
Thank you for the response sir,

I have some updates. I did discover that at some points, randomly, the card would work again and so would bluetooth. It is as you describe, all of the "media" connections get broken when this is an issue.

The SD card I am using is a 32GB Kingston. Is this too big? Can others report similar issues and what is a safe size/brand card to use which doesn't cause these sort of issues.

Yeah I've generally left the card disconnected now and at least bluetooth seems to work better.
My wifes '12 300srt8 does fine with 32gig cards but won't read a 64gig.
__________________
Reply With Quote
  #5  
Old 12-17-2013, 06:54 AM
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Dec 2013
Location: Victoria, Australia
Posts: 12
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 147
adamputts is on a distinguished road
64gb is a later tech. Anything 2gb & below is SD, 4gb & above is SDHC & 64gb & above is SDXC hence why it's not working. It's a different format about 32gb.
__________________
Reply With Quote
  #6  
Old 12-17-2013, 07:10 PM
Schleprock's Avatar
Member
My Jeep: 2010 6.1L SRT8
 
Join Date: Feb 2011
Location: MD/DE
Posts: 862
Thanks: 17
Thanked 47 Times in 36 Posts
Rep Power: 2188
Schleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond repute
Re: UConnect issues with SD card and Audio from Bluetooth

Anyone have an exact SD Card they know works? I need to buy one.
__________________
RJ
2014 Redline Pearl Jeep Grand Cherokee SRT8

2010 Bright Silver Jeep Grand Cherokee SRT8 (Billet Catch Can, Billet Shorty Antenna, BWoody 4" CAI, Custom CMR Tune)
2013 Grabber Blue Shelby GT500
(traded in) 2012 Mineral Gray Jeep Grand Cherokee SRT8
Reply With Quote
  #7  
Old 12-17-2013, 07:33 PM
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Dec 2013
Location: Victoria, Australia
Posts: 12
Thanks: 0
Thanked 5 Times in 3 Posts
Rep Power: 147
adamputts is on a distinguished road
Re: UConnect issues with SD card and Audio from Bluetooth

Any card should work 32gb & below. Nothing should work above.
__________________
Reply With Quote
  #8  
Old 12-17-2013, 07:40 PM
SNUKE's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2013
Location: Sydney, Aus
Posts: 1,972
Thanks: 40
Thanked 140 Times in 124 Posts
Rep Power: 4282
SNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond reputeSNUKE has a reputation beyond repute
Garage
Re: UConnect issues with SD card and Audio from Bluetooth

I successfully use this Sony 64GB SDXC card in my MY14 GC.



I noticed the little user card that is attached to the shifter when you buy the car says it must be 16GB or under, but this is not the case.

Make sure the card is formatted to FAT32 and you should not have any problems.
My card currently has more than 40GB of music and podcasts on it.
__________________
I'm just want it for the "shorter headlamps".

MY14 GC Limited, 3.0 CRD, Lux II, Granite Crystal, 18" Wheels, Tubular Side Steps.
Ordered: July 7 2013 Delivered Nov 25th
Reply With Quote
  #9  
Old 12-17-2013, 08:20 PM
Premium Member
 
Join Date: Aug 2013
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 261
bspllc is on a distinguished road
I'm using a 64 gig card also. I have it formatted ntfs. I did have a problem after switching cards. It didn't read all of the songs after putting it back in. I checked on the computer and all the songs were there. I reformatted and then it worked fine again.
__________________
Reply With Quote
  #10  
Old 12-18-2013, 08:24 AM
Schleprock's Avatar
Member
My Jeep: 2010 6.1L SRT8
 
Join Date: Feb 2011
Location: MD/DE
Posts: 862
Thanks: 17
Thanked 47 Times in 36 Posts
Rep Power: 2188
Schleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond reputeSchleprock has a reputation beyond repute
Re: UConnect issues with SD card and Audio from Bluetooth

Thanks guys.

__________________
RJ
2014 Redline Pearl Jeep Grand Cherokee SRT8

2010 Bright Silver Jeep Grand Cherokee SRT8 (Billet Catch Can, Billet Shorty Antenna, BWoody 4" CAI, Custom CMR Tune)
2013 Grabber Blue Shelby GT500
(traded in) 2012 Mineral Gray Jeep Grand Cherokee SRT8
Reply With Quote
  #11  
Old 12-19-2013, 02:24 PM
Member
 
Join Date: Oct 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 185
morrow3615 is on a distinguished road
Re: UConnect issues with SD card and Audio from Bluetooth

I've had my 2014 GC for 6 months and the SD card has worked fine until this week. It has started the same things that you have described. I can reboot to make it start again but the next time I stop and start the vehicle, the unit will not read my card. I'm using an 8GB card and thought maybe the card was going bad. Doesn't sound like it.
__________________
Reply With Quote
  #12  
Old 01-06-2014, 10:20 AM
talltale's Avatar
Premium Member
My Jeep: 1947 2.4L CJ
 
Join Date: Aug 2013
Posts: 88
Thanks: 12
Thanked 8 Times in 6 Posts
Rep Power: 336
talltale is on a distinguished road
Re: UConnect issues with SD card and Audio from Bluetooth

Quote:
Originally Posted by Dguth View Post
This happened repeatedly to me on my 2014. Uconnect works fine except nothing works on the media button. Even when I hard connected my phone to the USB port, it still would not recognize any media input. Couple ways to fix. You can reset the uconnect by pushing in simultaneously on the two big knob buttons. Hold for about 5 seconds and it will reset. Media should then work and recognize your SD card. If problem continues just pull out the SD card entirely. I had to do that with mine. I don't leave my SD card in anymore as it was locking up every time I got in the car. With SD card out it recognizes the Bluetooth streaming on my phone, no problem. I think the system gets real finicky with certain high volume SD cards.
This has started happening to me. The system worked fine for over 50 hours of use and then started randomly malfunctioning on a long road trip. I'm using a properly formatted 16GB SD card. I also have the latest software installed. It's a little irritating to say the least.
__________________

__________________
Ordered 8/12. Production Scheduled 8/15. Produced 9/28. Delivered 11/25. Overland 4x4 CRD, Deep Cherry Red/Brown Light Frost, ORA-II, Adv Tech.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth phone / Uconnect Polomaan Audio/Visual/Navigation 14 02-27-2014 08:25 AM
Bluetooth Streaming Audio DJGeyer Audio/Visual/Navigation 6 11-11-2013 08:36 AM
How to disable Bluetooth Audio PERMANENTLY 8.4AN? mswlogo Audio/Visual/Navigation 0 08-21-2013 05:31 PM
Adding Uconnect/Bluetooth camaro430sut Audio/Visual/Navigation 4 10-29-2012 12:02 PM
Bluetooth Audio WITHOUT Phone Big Green Audio/Visual/Navigation 18 03-13-2012 07:16 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community