Fogs not working - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Interior/Exterior/Visual

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-25-2016, 09:15 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2015
Location: SW FL
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 691
Kduniverse is on a distinguished road
Fogs not working

Just noticed both fogs not working, regardless of the green light indicating so on the dash. Any idea what to check? There's not too much info available, but I don't think there's a fuse. Read something about the FCM, but not much info there as well. If the dash light is indicated they're on, could it be something serous like the FCM? This is on a 2011.

Thanks,
KD

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-25-2016, 09:50 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 52,721
Thanks: 1,931
Thanked 2,255 Times in 1,403 Posts
Rep Power: 7789718
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Fogs not working

Reset the vehicle by pulling by pulling the negative on the battery off for a few minutes. Also step on the brake pedal a couple times. It could be both bulbs have blown at the same time. I doubt it...but possible.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 07-25-2016, 07:25 PM
Todd3.6's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: Twin Cities, MN
Posts: 839
Thanks: 5
Thanked 80 Times in 69 Posts
Rep Power: 350631
Todd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond repute
Re: Fogs not working

Quote:
Originally Posted by Scottina06 View Post
Reset the vehicle by pulling by pulling the negative on the battery off for a few minutes. Also step on the brake pedal a couple times. It could be both bulbs have blown at the same time. I doubt it...but possible.
I would check the bulbs...
They are basically incandescent 'backup' bulbs and if you haven't done anything to replace them yet, then they probably burnt out.

Do yourself a favor and upgrade to LED 'bulbs':
http://www.xenondepot.com/PSX24W-LED...24w-led-hp.htm

OR entire LED fog lights (Chinese knock-off of the JW Speaker units):
https://www.amazon.com/Lights-Tracto...dp/B00V7NEPYG/
Reply With Quote
The Following User Says Thank You to Todd3.6 For This Useful Post:
  #4  
Old 07-25-2016, 08:57 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2015
Location: SW FL
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 691
Kduniverse is on a distinguished road
Re: Fogs not working

No luck with disconnecting the negative cable. Anything else to check before a trip to the dealer?
__________________
Thanks,
KD
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 JGC Overland HID Fogs Not Working Limp003 Interior/Exterior/Visual 7 04-08-2014 06:33 AM
I wonder if it's possible to retro Blazer fogs in the 99'-03' fogs Amelie Interior/Exterior/Visual 1 06-21-2011 10:35 AM
Power mirror not working. Dealer not much help. brent Grand Cherokee - WK 10 02-18-2010 10:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:38 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.