Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Interior/Exterior/Visual

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-20-2014, 10:27 PM
Member
 
Join Date: Nov 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 529
pruitt14 is on a distinguished road
HID Fog and High Beam problem

I have installed a HID kit in my fogs on my 2013 Limited (stock HID headlights). I used a secondary harness for power and an error eliminator.
Problem: They were working fine until my auto-high beams kicked on. After the high beams went off, the fogs did not return. I tried turning lights off. I checked the inline fuse. I tried turning the car off and back on. NOTHING HAS RESOLVED THIS DILEMMA


Sent from my iPhone using JeepGarage
__________________

Reply With Quote
  #2  
Old 04-21-2014, 08:26 PM
Member
 
Join Date: Nov 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 529
pruitt14 is on a distinguished road
Re: HID Fog and High Beam problem

Anybody? Bueller?
__________________

Reply With Quote
  #3  
Old 04-21-2014, 09:18 PM
Todd3.6's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: Twin Cities, MN
Posts: 486
Thanks: 1
Thanked 31 Times in 26 Posts
Rep Power: 349650
Todd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond reputeTodd3.6 has a reputation beyond repute
Re: HID Fog and High Beam problem

Quote:
Originally Posted by pruitt14 View Post
I have installed a HID kit in my fogs on my 2013 Limited (stock HID headlights). I used a secondary harness for power and an error eliminator.
Problem: They were working fine until my auto-high beams kicked on. After the high beams went off, the fogs did not return. I tried turning lights off. I checked the inline fuse. I tried turning the car off and back on. NOTHING HAS RESOLVED THIS DILEMMA


Sent from my iPhone using JeepGarage
I'm only guessing here because I own a 2012...
You confused the computer somehow and probably the only way to fix it is to reset the computer.

The big problem is that every state mandates that the fog lights turn off when high beams are on. So when your computer turned on your high beams, it didn't see the right signal from the fog lights and then refused to send power back to them.

The fact that fog lights must turn off when the high beams come on is the exact reason why I would never use HIDs in the fog lights. Depending on the quality of the HID power supply, it can take from a couple seconds to a minute for the HIDs to come up to full power after a restart.

If you want to use HIDs in the fogs lights. I would recommend simply running a new wiring harness, relay, and independent switch to turn them on. Yes they would stay on with the high beams, but I highly doubt you would get pulled over by the REOs (Revenue Enforcement Officers) for that infraction.
Reply With Quote
  #4  
Old 04-21-2014, 10:02 PM
ChrisWk's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Oct 2009
Location: Atlanta, Ga
Posts: 1,074
Thanks: 0
Thanked 6 Times in 6 Posts
Rep Power: 375692
ChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond reputeChrisWk has a reputation beyond repute
Garage
Re: HID Fog and High Beam problem

I read you have to turn off the auto headlight option and use the manual mode.
__________________
HEMI Dark Khaki Pearl SRT8 Full Body Kit, Roof Rails,SRT8 Engine Strut Bar, Lund Rear Spoiler, MYGIG INSTALLED with LOCKPICK, Kenwood Sub, SRT8 Intake,Taylor Spark Plug Wires,G2 Silver Painted Brake Calipers, Billet Tech Catch Can, Addco Sway Bar Rear, WK Eibach Lowering Springs, SRT8 Bilstein Shocks, Xenon Volt HID Lows 6k,Chrome SRT Reps 255/45/20
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xenon High-beam flicker issue dubsdeuces Trouble Shooting/Problems/Service 20 06-10-2011 03:40 PM
Passenger high beam chance Grand Cherokee - WK 7 12-18-2010 10:20 PM
High Beam/Windshield Wipers JEEPWK2 Grand Cherokee - WK2 - 8 11-07-2010 03:43 PM
Automatic High Beam Calibration Nickba Troubleshooting/Problems Discussion 2 07-01-2010 05:04 PM
GEN 3 ebay questions high beam RYANSWJ Visual Modifications 4 03-03-2010 10:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.