Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > 2011+ Dodge Durango-WD

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 10-28-2013, 12:39 PM
davewg's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Medford, NJ
Posts: 814
Thanks: 104
Thanked 56 Times in 44 Posts
Rep Power: 140473
davewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by vertrkr View Post
Dealer called asking my permission to flash the computer as there's an RRT (rapid response transmittal) for the key fob/antenna. They didn't know anymore than that. Man I wish Milous would do a Durango site like wk2jeeps.com.

They also asked for my pics to send to Chrysler engineering. That's all I got for now.
I wish he would too. Maybe PM him and/or Willx and see if they can respond to this thread on that....

Did the dealer provide you with a loaner?
__________________

__________________
'14 Durango Limited AWD Deep Cherry Red
'05 Yukon XL Denali
'67 Corvette Stingray
Reply With Quote
  #14  
Old 10-28-2013, 01:00 PM
vertrkr's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Walnut Creek, CA
Posts: 421
Thanks: 22
Thanked 101 Times in 69 Posts
Rep Power: 350176
vertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by davewg View Post
I wish he would too. Maybe PM him and/or Willx and see if they can respond to this thread on that....
Did the dealer provide you with a loaner?
Hate to bug the poor guy but I might do that. At the least I'd love if he could provide a thread with the latest TSB/RRT.

No loaner yet as I have not been to the dealer, had it towed without me.
__________________

__________________
'14 Citadel AWD 3.6L Sandstone/Tan
Tech, Tow, Captain Chairs
Reply With Quote
  #15  
Old 10-28-2013, 05:37 PM
vertrkr's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Walnut Creek, CA
Posts: 421
Thanks: 22
Thanked 101 Times in 69 Posts
Rep Power: 350176
vertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Got my Durango back. It was indeed the lower transmission cooler line the factory did not connect all the way in to the radiator. Paper work says they tested the connection, cleaned the engine bay and checked the tranny fluid level. It did not say they added any ATF but I can't imagine they didn't. I kept my eye on the tranny temp all the home. Phew! glad that's over, think I 'dodged' a bullet on this one or at least got a graze.

They also updated my uConnect radio software to 13.38.52 which is the RRT 13-071 they were talking about. Nothing has changed feature wise but it seems even more items in the Driving & Safety settings won't change unless the engine is running. The nav in cluster setting has remained checked now, at least after one restart.

http://www.wk2jeeps.com/tsb/tsb_wk2_0804913e.pdf
Attached Images
File Type: jpg IMG_3022.jpg (195.0 KB, 15 views)
__________________
'14 Citadel AWD 3.6L Sandstone/Tan
Tech, Tow, Captain Chairs
Reply With Quote
The Following User Says Thank You to vertrkr For This Useful Post:
  #16  
Old 10-28-2013, 08:25 PM
davewg's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Medford, NJ
Posts: 814
Thanks: 104
Thanked 56 Times in 44 Posts
Rep Power: 140473
davewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond repute
Quote:
Originally Posted by vertrkr View Post
Got my Durango back. It was indeed the lower transmission cooler line the factory did not connect all the way in to the radiator. Paper work says they tested the connection, cleaned the engine bay and checked the tranny fluid level. It did not say they added any ATF but I can't imagine they didn't. I kept my eye on the tranny temp all the home. Phew! glad that's over, think I 'dodged' a bullet on this one or at least got a graze. They also updated my uConnect radio software to 13.38.52 which is the RRT 13-071 they were talking about. Nothing has changed feature wise but it seems even more items in the Driving & Safety settings won't change unless the engine is running. The nav in cluster setting has remained checked now, at least after one restart. http://www.wk2jeeps.com/tsb/tsb_wk2_0804913e.pdf
Interesting. I need to ping Willx, because I think that's the version the JGC guys got access to a few weeks ago. I'd heard that it wasn't applicable to our vehicles.

Our truck is on 13.37.00.
__________________
'14 Durango Limited AWD Deep Cherry Red
'05 Yukon XL Denali
'67 Corvette Stingray
Reply With Quote
  #17  
Old 10-28-2013, 09:43 PM
Member
 
Join Date: Sep 2013
Location: NE Missouri
Posts: 65
Thanks: 0
Thanked 9 Times in 5 Posts
Rep Power: 386
chaunceyjb1 is on a distinguished road
Re: Durango dumped its oil, connection came loose to radiator

I read through the symptoms addressed and this one stuck out:

Navigation shows vehicle in San Antonio, TX.

Would be kinds frustrating to always be in San Antonio. "Damn, I back in San Antonio again!"

John
__________________
Reply With Quote
  #18  
Old 10-29-2013, 07:00 AM
davewg's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Medford, NJ
Posts: 814
Thanks: 104
Thanked 56 Times in 44 Posts
Rep Power: 140473
davewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

I reached out to Willx last night, and per the TSB/RRT version 13.38.52 is now applicable to 2014 WD (Durango) where it had not been previously. He wasn't aware, but the bulletin date was from over the weekend. He's been busy working on diesel stuff.

Premium members can get the files from the VIP section, but my guess is they'll be available for download from the UConnect site too.
__________________
'14 Durango Limited AWD Deep Cherry Red
'05 Yukon XL Denali
'67 Corvette Stingray
Reply With Quote
  #19  
Old 10-29-2013, 08:00 AM
Premium Member
 
Join Date: Aug 2013
Posts: 313
Thanks: 9
Thanked 38 Times in 27 Posts
Rep Power: 651
Gtaz19 is on a distinguished road
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by davewg View Post
I reached out to Willx last night, and per the TSB/RRT version 13.38.52 is now applicable to 2014 WD (Durango) where it had not been previously. He wasn't aware, but the bulletin date was from over the weekend. He's been busy working on diesel stuff.

Premium members can get the files from the VIP section, but my guess is they'll be available for download from the UConnect site too.
it is...

https://rsur.extra.chrysler.com/rsur/Uconnect.do
__________________
______________________________
2014 Black R/T - 5.7L HEMI V8 AWD
Technology Group, Trailer Tow Group IV, Premium Nappa Leather Group, Second-Row Fold / Tumble Captain Chairs, Power Sunroof, Uconnect(R) 8.4 AN, 20-Inch X 8-Inch Polished / Painted Wheels
Reply With Quote
  #20  
Old 10-29-2013, 08:15 AM
davewg's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Medford, NJ
Posts: 814
Thanks: 104
Thanked 56 Times in 44 Posts
Rep Power: 140473
davewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by Gtaz19 View Post
Good deal. Now we need a guinea pig

I think I have a 4GB USB stick around here somewhere...
__________________
'14 Durango Limited AWD Deep Cherry Red
'05 Yukon XL Denali
'67 Corvette Stingray
Reply With Quote
  #21  
Old 10-29-2013, 08:20 AM
Premium Member
 
Join Date: Aug 2013
Posts: 313
Thanks: 9
Thanked 38 Times in 27 Posts
Rep Power: 651
Gtaz19 is on a distinguished road
Quote:
Originally Posted by davewg View Post
Good deal. Now we need a guinea pig I think I have a 4GB USB stick around here somewhere...
Did the update a little while ago. Now all I have is a looped video on the Uconnect screen of Ron Burgundy laughing and pointing at me...
__________________
______________________________
2014 Black R/T - 5.7L HEMI V8 AWD
Technology Group, Trailer Tow Group IV, Premium Nappa Leather Group, Second-Row Fold / Tumble Captain Chairs, Power Sunroof, Uconnect(R) 8.4 AN, 20-Inch X 8-Inch Polished / Painted Wheels
Reply With Quote
  #22  
Old 10-29-2013, 08:23 AM
davewg's Avatar
Premium Member
 
Join Date: Jul 2013
Location: Medford, NJ
Posts: 814
Thanks: 104
Thanked 56 Times in 44 Posts
Rep Power: 140473
davewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond reputedavewg has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by Gtaz19 View Post
Did the update a little while ago. Now all I have is a looped video on the Uconnect screen of Ron Burgundy laughing and pointing at me...
You sure its not JoeyD? His profile picture bears a striking resemblance...

__________________
'14 Durango Limited AWD Deep Cherry Red
'05 Yukon XL Denali
'67 Corvette Stingray
Reply With Quote
  #23  
Old 10-29-2013, 09:25 AM
Member
 
Join Date: Sep 2013
Location: Michigan
Posts: 101
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 398
mcfarl58 is on a distinguished road
Re: Durango dumped its oil, connection came loose to radiator

Sucks, but glad everything is ok now. Chances are no permanent damage was done. I had a 1995 GMC Jimmy that dropped its oil drain plug on two occasions leaving it with next to no oil by the time I caught it (oil pressure gauge dropped and engine started sputtering). Thing still ran like a champ for years afterwards.
__________________
Reply With Quote
  #24  
Old 10-29-2013, 11:32 AM
JoeyD's Avatar
Premium Member
My Jeep: 2014 3.6L
 
Join Date: Oct 2012
Location: Northern NJ, USA
Posts: 518
Thanks: 50
Thanked 47 Times in 35 Posts
Rep Power: 14490
JoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond repute
Re: Durango dumped its oil, connection came loose to radiator

Quote:
Originally Posted by davewg View Post
You sure its not JoeyD? His profile picture bears a striking resemblance...
Stay classy, San Diego!
__________________

__________________
Reply With Quote
Reply

Tags
durango

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine oil in radiator 2005 WK 5.7 Hemi asuricat Grand Cherokee - WK 3 08-20-2013 04:35 PM
Dumped exhaust and passing inspection Sims Engine Performance/Intake/Exhaust 5 04-05-2012 08:33 AM
USB iPad connection zzkazu Audio/Visual/Navigation 4 02-16-2012 12:54 PM
USB connection problems Blsmith Wrangler-JK 2 04-17-2011 06:29 PM
Are there any connection points on WK2? JoeSchmoe007 Grand Cherokee - WK2 - 6 09-09-2010 06:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community