Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > 2011+ Dodge Durango-WD

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-04-2013, 11:06 AM
Member
My Jeep: 2014
 
Join Date: Aug 2013
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 512
jtdemaris is on a distinguished road
Trouble Shooting/Problems/Service

Since I've been cluttering up other threads with warranty repair notes, thought it was time to start one specific to the topic.
Have any other '14 owners run into problems?
__________________________________________
2014 Granite Durango Limited AWD
V6, captains chairs second row console, nav , lift gate, tow pkg.
__________________

__________________
Reply With Quote
  #2  
Old 11-04-2013, 11:14 AM
Member
My Jeep: 2014
 
Join Date: Aug 2013
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 512
jtdemaris is on a distinguished road
Re: Trouble Shooting/Problems/Service

My sad story so far is:
At 140 miles my D is sitting at service dept with a bad transmission. Message says "service transmission" and won't shift out of N. No other warning lights or leaks. Just backed it into the garage and this appeared.

The service department says the valve body needs to be replaced.
Waiting to find out how long until the (backordered) part gets in.

__________________________________________
2014 Granite Durango Limited AWD
V6, captains chairs second row console, nav , lift gate, tow pkg
__________________

__________________
Reply With Quote
  #3  
Old 11-04-2013, 01:24 PM
vertrkr's Avatar
Member
 
Join Date: Jul 2013
Location: Walnut Creek, CA
Posts: 428
Thanks: 22
Thanked 102 Times in 70 Posts
Rep Power: 350339
vertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond reputevertrkr has a reputation beyond repute
Re: Trouble Shooting/Problems/Service

My lower transmission line to the cooler either popped out or was not fully seated at the factory dumping a bunch of ATF. I still see specs of ATF appearing in the engine bay, I wipe them up and they reappear. Not sure if it's still leaking or if it's residual fluid getting blown out of all the cracks and crevices from the initial spill, leaning towards the later. To be sure, this morning I taped up some white card stock under the fittings to catch any drips.
__________________
'14 Citadel AWD 3.6L Sandstone/Tan
Tech, Tow, Captain Chairs
Reply With Quote
  #4  
Old 11-04-2013, 06:56 PM
Member
 
Join Date: Oct 2013
Location: Anderson, IN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
gjohnson3344 is on a distinguished road
Re: Trouble Shooting/Problems/Service

Problem with paint underside of hood drivers side corner near brake fluid tank and paint bubbles on passenger side fender under hood will be getting fixed Nov. 18.

Just noticed after updating 8.4 radio w Navigation the SD card for the stereo is doubling all the songs on the card. They don't show double on the PC but are on the stereo. Didn't do this prior to the update. Probably a software bug that will get fixed in a later update.
__________________
2014 Durango Limited AWD V6
2014 Charger SXT PLUS AWD V6
Reply With Quote
  #5  
Old 11-04-2013, 08:01 PM
JoeyD's Avatar
Premium Member
My Jeep: 2014 3.6L
 
Join Date: Oct 2012
Location: Northern NJ, USA
Posts: 528
Thanks: 50
Thanked 51 Times in 37 Posts
Rep Power: 14657
JoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond repute
Quote:
Originally Posted by gjohnson3344 View Post
Problem with paint underside of hood drivers side corner near brake fluid tank and paint bubbles on passenger side fender under hood will be getting fixed Nov. 18.

Just noticed after updating 8.4 radio w Navigation the SD card for the stereo is doubling all the songs on the card. They don't show double on the PC but are on the stereo. Didn't do this prior to the update. Probably a software bug that will get fixed in a later update.
Try reformatting the card (then name it something different.). Then plug in the Blank card into uconnect. After it reads the blank card, then go ahead and remove it and refill it with your music. Let us I know how it goes.
__________________
Reply With Quote
  #6  
Old 11-04-2013, 09:24 PM
Member
 
Join Date: Oct 2013
Location: Anderson, IN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
gjohnson3344 is on a distinguished road
Re: Trouble Shooting/Problems/Service

Reformated, placed empty in 8.4, returned to PC to reload then back to 8.4. Same results double entries and yes they play 2 times each if you just let it play.
__________________
2014 Durango Limited AWD V6
2014 Charger SXT PLUS AWD V6
Reply With Quote
  #7  
Old 11-04-2013, 10:07 PM
Member
 
Join Date: Aug 2013
Posts: 313
Thanks: 9
Thanked 38 Times in 27 Posts
Rep Power: 807
Gtaz19 is on a distinguished road
Quote:
Originally Posted by gjohnson3344 View Post
Reformated, placed empty in 8.4, returned to PC to reload then back to 8.4. Same results double entries and yes they play 2 times each if you just let it play.
Did you remove that card from the slot when updating using a USB drive?
__________________
______________________________
2014 Black R/T - 5.7L HEMI V8 AWD
Technology Group, Trailer Tow Group IV, Premium Nappa Leather Group, Second-Row Fold / Tumble Captain Chairs, Power Sunroof, Uconnect(R) 8.4 AN, 20-Inch X 8-Inch Polished / Painted Wheels
Reply With Quote
  #8  
Old 11-04-2013, 10:13 PM
Member
 
Join Date: Oct 2013
Location: Anderson, IN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
gjohnson3344 is on a distinguished road
Quote:
Originally Posted by Gtaz19 View Post

Did you remove that card from the slot when updating using a USB drive?
That I don't remember.
__________________
2014 Durango Limited AWD V6
2014 Charger SXT PLUS AWD V6
Reply With Quote
  #9  
Old 11-04-2013, 10:15 PM
Member
 
Join Date: Aug 2013
Posts: 313
Thanks: 9
Thanked 38 Times in 27 Posts
Rep Power: 807
Gtaz19 is on a distinguished road
Quote:
Originally Posted by gjohnson3344 View Post
That I don't remember.
The update instructions said to make sure nothing else was plugged in. I don't know however if that would cause your problem. This was not an issue for me after the update so that's my only guess...
__________________
______________________________
2014 Black R/T - 5.7L HEMI V8 AWD
Technology Group, Trailer Tow Group IV, Premium Nappa Leather Group, Second-Row Fold / Tumble Captain Chairs, Power Sunroof, Uconnect(R) 8.4 AN, 20-Inch X 8-Inch Polished / Painted Wheels
Reply With Quote
  #10  
Old 11-04-2013, 10:31 PM
JoeyD's Avatar
Premium Member
My Jeep: 2014 3.6L
 
Join Date: Oct 2012
Location: Northern NJ, USA
Posts: 528
Thanks: 50
Thanked 51 Times in 37 Posts
Rep Power: 14657
JoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond reputeJoeyD has a reputation beyond repute
Quote:
Originally Posted by gjohnson3344 View Post
Reformated, placed empty in 8.4, returned to PC to reload then back to 8.4. Same results double entries and yes they play 2 times each if you just let it play.
Did you try renaming the card? (Change the volume name?)

That's the last thing I can think of assuming this is a cache/indexing issue'
__________________
Reply With Quote
  #11  
Old 11-05-2013, 01:47 PM
Member
 
Join Date: Oct 2013
Location: Anderson, IN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 470
gjohnson3344 is on a distinguished road
Re: Trouble Shooting/Problems/Service

Reformatted the card, put 1 song on it, put in 8.4 = OK so I reformatted again put all songs back on and it appears to be ok. Did not rename (doesnt even have a name yet). ?????
__________________
2014 Durango Limited AWD V6
2014 Charger SXT PLUS AWD V6
Reply With Quote
  #12  
Old 11-08-2013, 10:40 AM
Member
My Jeep: 2014
 
Join Date: Aug 2013
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 512
jtdemaris is on a distinguished road
Re: Trouble Shooting/Problems/Service

At 140 miles my D is sitting at service dept with a bad transmission. Message says "service transmission" and won't shift out of N. No other warning lights or leaks. Just backed it into the garage and this appeared.

The service department says the valve body needs to be replaced.
Waiting to find out how long until the (backordered) part gets in.

__________________________________________

Got it back this week with a new valve body installed. So far no problems, after driving for close to the same number of miles I had before I had the original problem.
__________________

__________________
__________________________________________
2014 Granite Durango Limited AWD
V6, captains chairs w/second row console, nav & lift pkg, tow pkg.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Pictures trouble shooting Dena Troubleshooting/Problems Discussion 1 08-04-2012 10:36 AM
Suspension trouble shooting question 04wjfreedomedition Troubleshooting/Problems 2 04-13-2012 10:22 PM
Best HID kit install and trouble shooting guide. AcidCold Visual Modifications 15 03-27-2012 10:51 AM
Trouble shooting 4 X 4 CV joint or ..... Me Fix Troubleshooting/Problems 14 01-04-2012 05:41 PM
Any Problems With An Aftermarket Radio & Dealer Service Updates? 1stJeepGC Audio/Visual/Navigation 5 07-21-2011 09:01 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.