Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-24-2013, 12:25 PM
New Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mrbyrne is on a distinguished road
05 grand Cherokee 5.7 himi has awful whine sound when I first start

When I first start it up it revs real high for just a second and it makes this awful high pitched noise but then stops and runs normal. It does it when it has set for a while and when its real cold outside. Any help would be nice.
__________________

__________________
Reply With Quote
  #2  
Old 11-24-2013, 12:51 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,197
Thanks: 214
Thanked 173 Times in 138 Posts
Rep Power: 89731
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: 05 grand Cherokee 5.7 himi has awful whine sound when I first start

You will probably have better luck with this on the WK threads.
__________________

__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #3  
Old 11-24-2013, 07:55 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 811
Thanks: 0
Thanked 16 Times in 15 Posts
Rep Power: 277010
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
I would check the serpentine belt to see if that's the cause.

It could also very well be the ps pump. They are known to whine on initial startup when cold and I believe there was a tsb on some years related to replacing the reservoir to improve flow when cold.
__________________
Reply With Quote
  #4  
Old 11-24-2013, 08:07 PM
New Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mrbyrne is on a distinguished road
Thanx a lot... I will start with the power steering pump and see if that works. I appreciate your help.
__________________
Reply With Quote
  #5  
Old 11-24-2013, 09:55 PM
06HemiWK's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: Mar 2012
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1066
06HemiWK is on a distinguished road
Mine does the same thing 06 hemi wk.
__________________
Reply With Quote
  #6  
Old 11-24-2013, 11:06 PM
Hemi05WK's Avatar
Premium Member
 
Join Date: May 2009
Location: Taylor, MI
Posts: 444
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2538
Hemi05WK has a reputation beyond reputeHemi05WK has a reputation beyond reputeHemi05WK has a reputation beyond repute
Send a message via AIM to Hemi05WK
Re: 05 grand Cherokee 5.7 himi has awful whine sound when I first start

As stated above... Ck for the TSB. If its never been done, its a very good possibility.
__________________

__________________
2013 Charger R/T AWD - Billit Silver

1998 Jeep Grand Cherokee 5.9 - Slate

1997 Grand Cherokee Limited - 5.2 - Project


Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Grand Cherokee Laredo whine coming from engine bay!(Video) Smity Trouble Shooting/Problems/Service 2 03-19-2014 09:23 PM
2011 JEEP GRAND CHEROKEE 5.7L - Sound jms1986 Performance Modifications 2 05-06-2013 08:47 AM
No start issues 95 Grand Cherokee d.gasnik Troubleshooting/Problems Discussion 1 03-17-2013 02:17 PM
Grand Cherokee no start dpatten Troubleshooting/Problems 2 09-28-2011 09:11 PM
Hard to Start '04 Grand Cherokee bbd1012 Engine Performance/Intake/Exhaust 1 07-14-2010 11:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.