Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-11-2013, 11:40 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2011
Location: Concord, MI
Posts: 95
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1467
hemi_shox is on a distinguished road
05 grand immobilized

So I had some strut work done and afterwards, I turned the car on and it started right up with no issues. A few seconds later, it shut off. I tried to start it back up and not a thing. The engine light came up, the service this n that messages came up, all gear had a box around them, and the red dot security light was blinking. I'm thinking that the anti theft has been activated and I'm wondering how to reset or get rid of it. I've tried both keys and neither work. No check engine codes or key messages appear. I've tried resetting the battery and that doesn't do the trick either.

So the real question, is there any way I can reset this myself so I can get my car started and running again? I'd rather not take it to the dealer but I understand if that's my only option. Just thought maybe someone who's been in this situation could drop some input or guide me towards some

Thanks in advance guys
__________________

__________________
Reply With Quote
  #2  
Old 10-12-2013, 01:00 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2011
Location: Concord, MI
Posts: 95
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1467
hemi_shox is on a distinguished road
Re: 05 grand immobilized

Could this even be a battery issue? My tpms light goes off if I have a charger in and my remote entery doesn't either with one plugged in so I know there's at least one short. It does intermittently have a hard time starting(starter is two years old).
__________________

__________________
Reply With Quote
  #3  
Old 10-12-2013, 08:46 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 811
Thanks: 0
Thanked 16 Times in 15 Posts
Rep Power: 277011
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
It sounds more like an electrical issue. I would check the battery and terminals to start. After that, I would start checking the various modules for a short or loose connection. That being said, electrical issues re usually pretty tough to troubleshoot. The immobilizer will always let you start the vehicle with the wrong key, it'll just shut down a few seconds later. It should not have to be reset or cleared after it has been activated, and should return to normal with a proper key.
__________________
Reply With Quote
  #4  
Old 10-13-2013, 12:47 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Jun 2011
Location: Gunnison , CO
Posts: 251
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 57022
Bikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond repute
Re: 05 grand immobilized

How old is the battery?
__________________
2008 Laredo X 4.7 with 245/70-17 at2
2013 Hemi Durango Crew
Reply With Quote
  #5  
Old 10-13-2013, 07:44 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2011
Location: Concord, MI
Posts: 95
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1467
hemi_shox is on a distinguished road
Re: 05 grand immobilized

The battery is from January of 10. The key locks and unlocks the car but no exterior lights come on. They don't turn on using the switch either. The some lights are fine. The REC unit displayed the Chrysler logo when I turned it on, it's never done that before. There's no honk when I lock the car. I tried a jump and that did nothing.

Really stumped and frustrated at the moment
__________________
Reply With Quote
  #6  
Old 10-14-2013, 11:34 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,965
Thanks: 22
Thanked 29 Times in 28 Posts
Rep Power: 11432
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: 05 grand immobilized

Sometimes your battery can be so dead its not jumpable. Does it click or anything when you try to start?
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #7  
Old 10-14-2013, 11:55 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2011
Location: Concord, MI
Posts: 95
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1467
hemi_shox is on a distinguished road
Re: 05 grand immobilized

Everything clicks like it should when I try to start. Fans work, sound system, everything except headlights work
__________________
Reply With Quote
  #8  
Old 10-14-2013, 07:35 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2011
Location: Concord, MI
Posts: 95
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1467
hemi_shox is on a distinguished road
Re: 05 grand immobilized

Got it all figured out. What happened was, when I flipped the fuse boxes up to replace the strut mount, the two big connectors that attach to the fuse box closest to the battery came undone without me realizing. Plugged them back in, threw in a new battery just cuz and everything works like it should.
__________________
Reply With Quote
  #9  
Old 01-09-2014, 05:43 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469958
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 grand immobilized

Quote:
Originally Posted by dr.lee.baugh View Post
It sounds more like an electrical issue. I would check the battery and terminals to start. After that, I would start checking the various modules for a short or loose connection. That being said, electrical issues re usually pretty tough to troubleshoot. The immobilizer will always let you start the vehicle with the wrong key, it'll just shut down a few seconds later. It should not have to be reset or cleared after it has been activated, and should return to normal with a proper key.
My WK started doing this moments ago. It cranks and runs fine but then shuts off after 3 seconds.

It will crank every time I turn the key but it will always shut off after 3 seconds.

Do I just need a new key?
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #10  
Old 01-09-2014, 05:56 PM
WKYeti's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 76
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 776
WKYeti is on a distinguished road
Garage
Mine did this after sending my key through the washer.
__________________
Reply With Quote
The Following User Says Thank You to WKYeti For This Useful Post:
  #11  
Old 01-09-2014, 08:17 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,425
Thanks: 504
Thanked 87 Times in 81 Posts
Rep Power: 469958
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 grand immobilized

Quote:
Originally Posted by WKYeti View Post
Mine did this after sending my key through the washer.
Are you talking about my post above?
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #12  
Old 01-09-2014, 08:24 PM
WKYeti's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 76
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 776
WKYeti is on a distinguished road
Garage
Yep, it wouldnt recognize my chip. After letting it dry it worked fine. So maybe its a wet or damaged chip?
__________________

__________________
Reply With Quote
The Following User Says Thank You to WKYeti For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tony's Grand :: 2004 Jeep Grand Cherokee Limited HO TJXJWJ Member Garage Discussions 1 03-09-2014 06:31 PM
'99 Grand :: 1999 Jeep Grand Cherokee Limited JeepFreak12 Member Garage Discussions 0 06-04-2013 09:27 AM
Jeep Grand Cherokee SRT/8 Alpine Edition around course at Grand Prix of Baltimore Yaccster Showoff 0 09-11-2012 08:41 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.