Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-19-2011, 06:39 PM
Member
 
Join Date: Sep 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1103
jeepsnmopars is on a distinguished road
05 WK quirks

My 05 limited 4.7 just did something similar. I drove it to Florida and back at Thanksgiving 2300+ miles no issue. This past weekend my wife took it across the the U.P. of Michigan and on a very cold morning with icy roads starting back she described "service electric brake system" came on, all sorts of lights came on the dash, the heater and radio shut off, engine light came on and the traction control squiggly marks light came on. I told her to shut it off and restart it and see what happened. Everything went back to normal except the engine light stayed on. I told her drive it into the ground if you have to and get home and she did without issues and the engine light eventually went out. No problems since. From what I am reading online this is pretty normal for the 05 WK's so I am just going to monitor it for a while. It seems to me that a wheel sensor it the number one culprit. I did put a 2" lift in it and slightly bigger tires but that was well before my trip to Florida. My airbag light has been on since I got it and it does tick when I turn the steering wheel lock to lock so I assume that I may have issues with my clockspring as well. As long as it doesn't leave me stranded I am OK with it. Should be headed across the UP again in a couple weeks. We will see.....It does have 131k+ miles.
__________________

__________________
Reply With Quote
  #2  
Old 12-21-2011, 12:13 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652950
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 05 WK quirks

Hey, your post is deserving of its own thread, enough different things your dealing with from the thread you posted this on.

Anyway, there is a tsb for the clicking, not that it will fix it, there is a cancelor cam replacement that is slightly shorter iirc... I did it on mine, it helped some but didnt fix it, I am thinking when it annoys me enough ill take it apart and get a file involved and shave a little off of it. the part is less than 10 bucks iirc my employee cost was less than 5 bucks for the part.

Your problem is likely not a wheel speed sensor, cosidering the loss of other electronics, the wheel speed sensors are hard inputs directly to the abs module and will have NO effect on other module functions. I have seen a couple things causing the airbag light decently common on the wk, the wiring under the passanger seat likes to get munched up, dont know exactly why, there is not much there, i think typically when I see it people are stuffing crap under the seats. I know when I put my grand cherokee together I had a seat weight calibration error that had the abs lamp on, using the calibration weights and the witech I was able to sort that out quickly

I have seen a problem with the interior junction block where an internal relay is not making good contact causing inop heater and airbag light intermittantly (you wouldnt notice the airbag light that was already on).
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 12-27-2011, 07:39 PM
New Member
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jackr is on a distinguished road
Re: 05 WK quirks

Had same problem a while back . the dealer replaced dash AC console as well as ignition switch and it solve the probelm for several years with no problems. I would obviously start withthe ignition switch around $35.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission quirks?l cloud11244 Trouble Shooting/Problems/Service 2 08-06-2011 07:45 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community