Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 02-16-2012, 10:34 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469765
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 WK - Trouble Starting W/Warm Engine!

Quote:
Originally Posted by WildVisionsWK View Post
Awesome! About how difficult would soldering be for the controls? I don't have the experience, but I am extremely skilled at detail work, am patient, and I learn quickly. I have experience tinkering inside computers, doing custom builds, etc so I'm not a total klutz. Do you have any photos of your color change? I have always contemplated a color change for all my control dials/buttons. I wouldn't mind doing amber or red, personally.
Well, soldering is easy...I guess. It's kind of like using a hot glue gun but there are different techniques to consider. It's really not that bad...but then again, I do have a degree in Electronics Engineering.

Skilled but not an expert.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #14  
Old 02-16-2012, 10:36 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469765
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 WK - Trouble Starting W/Warm Engine!

This thread has gotten way out of hand.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #15  
Old 02-16-2012, 10:42 PM
WildVisionsWK's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 29303
WildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond repute
Re: 05 WK - Trouble Starting W/Warm Engine!

Quote:
Originally Posted by lll2for3lll View Post
Well, soldering is easy...I guess. It's kind of like using a hot glue gun but there are different techniques to consider. It's really not that bad...but then again, I do have a degree in Electronics Engineering.

Skilled but not an expert.
It sounds like something I could pick up fairly quickly after a day or two of experimenting on some scraps. I do fine art and work with a scalpel for most of my pieces (you can view my work at www.wild-visions.com) so I'm used to very tight, detailed work where errors are not easily forgiven.

The idea of being able to change the color of the backlights in my WK is exciting though, as it was on my list of 'things I'd love to change someday'
__________________
[SIGPIC][/SIGPIC]
___________________________
2005 3.7L V6 Laredo - Tinted Taillights | Plasti-Dipped Emblems + Pillars | 3K HID Projector Halo Fogs (pending shipment/installation)
Reply With Quote
  #16  
Old 02-16-2012, 10:47 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469765
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 WK - Trouble Starting W/Warm Engine!

Bob is only an hour away from you.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #17  
Old 02-16-2012, 10:54 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469765
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 WK - Trouble Starting W/Warm Engine!

http://www.wild-visions.com/

^^^Holy chit. Awesome work.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #18  
Old 02-16-2012, 11:11 PM
Diboblo's Avatar
Member
 
Join Date: May 2011
Location: Riverside, California
Posts: 314
Thanks: 45
Thanked 22 Times in 17 Posts
Rep Power: 16887
Diboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond repute
Re: 05 WK - Trouble Starting W/Warm Engine!

Quote:
Originally Posted by WildVisionsWK View Post
Awesome! About how difficult would soldering be for the controls? I don't have the experience, but I am extremely skilled at detail work, am patient, and I learn quickly. I have experience tinkering inside computers, doing custom builds, etc so I'm not a total klutz. Do you have any photos of your color change? I have always contemplated a color change for all my control dials/buttons. I wouldn't mind doing amber or red, personally.
If you want to drive out, I'll repair your climate control lights while you wait...

NO CHARGE

Send me a PM, or respond to this thread and we'll work it out.

As for the Jeep, I'm not familiar with the WK, but on the LX platform, the tank has a vapor purge solenoid. If the vehicle is "topped off" or over filled with fuel, this solenoid can be flooded. Once this happens, raw fuel is forced into the engine and it will flood. This can make for difficult, or non starting conditions, as well as under power and/or random engine failure.

On the '05/'06 LX, the only way to fix this is to replace the fuel tank.

As for the CEL, have you tried the key dance? From the ACC position, do this:

ACC/ON/ACC/ON/ACC/ON

Watch the digital odometer... you will see: _ _ _ _, then you may see your codes, then: d o n e, or, _ _ _ _ ,then d o n e.

I have a reader. I can check for codes when you come over for me to repair the CC lights, if you wish.

Just throwing things against the wall to see what sticks.

Hopefully someone with more experience on the WK platform will address my comments.

Bob
__________________
Reply With Quote
The Following User Says Thank You to Diboblo For This Useful Post:
  #19  
Old 02-17-2012, 12:57 AM
WildVisionsWK's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 29303
WildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond repute
Re: 05 WK - Trouble Starting W/Warm Engine!

Bob,

Thank you for the generous offer! That would actually be amazing! I will definitely let you know a few days in advance when I can swing out there (my college schedule keeps me pretty busy Monday - Thursday, and then I have a long 12-hour shift at the emergency animal hospital that I volunteer at on Saturdays). Probably a Friday or Sunday would be the best bet, although Tuesday or Wednesday could work if it's in the morning/early afternoon.

If we're already going to fiddle with the backlights, and different colors are an option, I would love to explore that and would definitely be willing to pay whatever the price may be for that upgrade.

I will definitely try the ACC/ON combo and see if it brings up anything, along with checking the car now that it's cold to see if I can hear the fuel pump buzzing/whining. If I do, then clearly it's not working when the car is warm. If it's still silent, then I'm at a loss as to what's going on.
__________________
[SIGPIC][/SIGPIC]
___________________________
2005 3.7L V6 Laredo - Tinted Taillights | Plasti-Dipped Emblems + Pillars | 3K HID Projector Halo Fogs (pending shipment/installation)
Reply With Quote
  #20  
Old 02-17-2012, 09:34 AM
Diboblo's Avatar
Member
 
Join Date: May 2011
Location: Riverside, California
Posts: 314
Thanks: 45
Thanked 22 Times in 17 Posts
Rep Power: 16887
Diboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond reputeDiboblo has a reputation beyond repute
Re: 05 WK - Trouble Starting W/Warm Engine!

Also, if this is an evap canister/purge valve issue, try running the car without the gas cap.

Conversely, when the car is hard to start, or won't start, remove the gas cap & let it sit for just a minute, or two, then fire it up. If the car functions properly, you have an issue with a flooded evap canister and a flooded purge valve.

It's worth a shot, and it's free diagnosis

Bob
__________________
Reply With Quote
  #21  
Old 02-17-2012, 04:23 PM
WildVisionsWK's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Los Angeles, CA
Posts: 49
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 29303
WildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond reputeWildVisionsWK has a reputation beyond repute
Re: 05 WK - Trouble Starting W/Warm Engine!

Last night I checked the car but didn't hear the fuel pump buzz. This morning, however, it buzzed every time and was clearly working. I did the key dance and couldn't get any codes to stay, but 'transmission over temp' flashed on the EVIC briefly. I'm not sure what's going on, except that:

Fuel pump buzzes/runs when the car is totally cold, but doesn't turn on at all when it's warm.

The EVIC pulls up no numerical codes but flashes 'transmission over temp' briefly every time I do the key dance. It doesn't stay though, it just briefly flickers.
__________________
[SIGPIC][/SIGPIC]
___________________________
2005 3.7L V6 Laredo - Tinted Taillights | Plasti-Dipped Emblems + Pillars | 3K HID Projector Halo Fogs (pending shipment/installation)
Reply With Quote
  #22  
Old 02-17-2012, 06:53 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469765
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: 05 WK - Trouble Starting W/Warm Engine!

I would start with the fuel pump.

As for the trans light flicker, I wouldn't worry about it. As long as you recently had the trans serviced.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warm up times ? GCUK Export & Diesel Powered Jeep Models 9 01-24-2012 05:56 AM
no warm air jdb2797 Troubleshooting/Problems 6 01-12-2012 09:29 PM
Slow engine starting issues on 2006 Jeep Commander 5.7L Hemi Thomaskr 2005+ Jeep Commander XK 1 03-29-2011 10:14 PM
Warm heat sasquach1950 Troubleshooting/Problems 5 12-06-2010 10:15 AM
Trouble Starting 99 4.7 jimd4x4 Troubleshooting/Problems 4 03-16-2010 02:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community