Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-26-2010, 08:04 PM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Jul 2010
Location: Florida
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1596
Architect is on a distinguished road
06 Grand Cherokee - Electrical Problem wih Dash Cluster

Hello all,

I have a 2006 Jeep Grand Cherokee Laredo with 80k+ miles. (Bought it used at 29k miles). I have been experiencing random electrical problems. The symptom is that the all the lights and gauges on the dash cluster go on and off erratically and sometimes stay off for a few minutes. This also includes the A/C system. As the gauges go off so does the A/C fan.

I have taken the Jeep to the dealer now going on 5 or more times and quite frankly, they are stumped. They have replaced many significant modules [Front Control Module FCM ; Steering Control Module SCM ; Shift Control Module ShCM(?), Ignition switch (3x), etc. Many of these modules are in the $400-$500 range. Ouch! So, I pay the bill, jump in my Jeep and on the road for just 10 minutes and the problem is back. Honestly, did some test drive it or not?

The Jeep factory Engineers have been consulted and are aware of the problem. About the only thing that has not been replaced is the full wiring harness. The Electrical Technician is factory trained and has tried his best and also followed Jeep's guidance. But here I am, now up to nearly $2000 in expenses incl rental fees. Again ouch!

I am writing this to spread awareness that other Jeep owners experiencing this or similar problems may be aware of how difficult it is to solve. And if any of us have this same problem and do actually find the real solution to this, that it may get out there for other to know and maybe spare them what have gone and I am still going through.

The Service Manager was supposed to contact Chrysler and inform them of the state of my problem and see what they might do or even suggest. But in three weeks now , I have not heard a thing. I am being ignored. May just have to go the legal route, sad to say. To spend that much money, in earnest, on a repair and to be back at the same place I started is unacceptable.

Lately, one of the symptoms is that the intermittent failure is triggered by bumps in the road, bumps from road lane reflectors, etc. It makes me think that what I suspected all along was that it is simply a loose wire, or a shorted wire somewhere in the harness.

To add insult to injury, the initial visit to service was under warranty and subsequent visits were considered out of warranty, but were all stemming from the reason for first service visit. Clever reasons were given for why it was not covered under warranty. "...a different part has failed that is not the same as the original part (FCM) that failed, so it is therefor not covered...". All these parts replaced are all educated guesses.

Question: How does one find an abraded, or shorted wire in this electrical system? The Tech says it is not a bad ground.

Signed,

Flustered in Florida
aka Keith

********* * * * ************
__________________

__________________
Reply With Quote
  #2  
Old 07-26-2010, 08:14 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 25 Times in 25 Posts
Rep Power: 63464
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

I have had this exact problem. It has happened more than 5 times. I'm thinking it's the Light Switch going bad. I just put it on Auto and it never flickers anymore.

Mine has happened behind a cop also! My Exterior lights flickered with the dash board and a/c controls.
__________________

__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #3  
Old 07-26-2010, 08:14 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,419
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542703
robpp has disabled reputation
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

did they ever replace the light switch or the igniotion switch.

if you search, people have random lights on and off stuff its USUALLY one of those items. they are both cheap too. i mean search other forums, search hard. 98 out of a hundo its one of those 2 switches.

i know its been tt dealers and all you been thru, if the parts i listed have not been changed, i would at a minimum go get a salvage one and try it. heck the ifnition is ~40.

there is also a thread i saw on another forum where they did find a short, maybe contact that guy. it was a rub som ayb you have the same RUB.

http://www.jeep forum.com/forum/f67/900-dollars-shorted-wire-wk-1074127/

you need to get rid of the spaces for the link to work.
__________________
Reply With Quote
  #4  
Old 07-26-2010, 08:44 PM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Jul 2010
Location: Florida
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1596
Architect is on a distinguished road
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Quote:
Originally Posted by Chaoul1 View Post
I have had this exact problem. It has happened more than 5 times. I'm thinking it's the Light Switch going bad. I just put it on Auto and it never flickers anymore.

Mine has happened behind a cop also! My Exterior lights flickered with the dash board and a/c controls.

I would like to know more about the specifics of your electrical problem. All your gauges flicker and go on and off? i am told be a Jeep Tech that some electrical components "fail safe" to the ON state vs. off,
(wipers , headlights, etc). My external lights do not flicker or go on and off with this current problem.

I am confused about what light switch you are referring to... the light switch for headlights, etc???

I do not have an "Auto" mode on my light switch, (to the best of my knowledge). Don't think that was an option on my '06 Laredo.

Keith
__________________
Reply With Quote
  #5  
Old 07-26-2010, 08:48 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,419
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542703
robpp has disabled reputation
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

yeah hes talking about the light stalk. thats what i was also referring to as well. it goes bad, 06 its very popular.

ita about 60 bux for a new one. takes about 45 seconds to replace it.
__________________
Reply With Quote
  #6  
Old 07-26-2010, 08:56 PM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Jul 2010
Location: Florida
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1596
Architect is on a distinguished road
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Could that cause all dash cluster lights to flicker on and off and provide a check engine light as well as to initiate codes to the computer? example Code : B2100 yes, the ignition switch was replaced at least twice, as well as the Steering Control Module, the Shift Control Module, (2) Front Control Modules, plus some rewiring of fuse block.
__________________
Reply With Quote
  #7  
Old 07-26-2010, 09:14 PM
New Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jul 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
WSU_Tru_Coug is on a distinguished road
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Ive had a very similar problem with my 2000 WJ. I could not figure out what was the problem for the longest time. I would try to start it and all the gauges would start jumping and clicking. I would have to keep my foot on the gas or it would stall. I noticed one night that my lights turned on for no reason when I was sitting in my house. After a bunch of test and people telling me it was just a bad battery because they had no idea what it was, I turned my lights off of auto and just turned em on manually and have not had a problem for over a year. Sounds like those light switches are pretty sketchy and cost a lot of people a lot of unnecessary money.
__________________
Reply With Quote
  #8  
Old 08-01-2010, 09:24 AM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Jul 2010
Location: Florida
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1596
Architect is on a distinguished road
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

2010-08-01 10:14:00
Update on the ongoing saga with my dash cluster malfunction...

One forum (edmunds) user suggested that Jeeps are prone to problems relating to low voltage being delivered to the electrical system. it was stated that voltages less than approx. 13.5v could be a cause of problems. So... i went to Sears where I had purchased a DieHard battery (Jeep GC requires a special (truck) battery, not a typical car batt). They tested the battery and it delivered 13.9v to 14.0v consistently.

I am still trying to solve this problem, as the dealer after 7 visits has not fixed it as considerable cost. ($1500-$2100 so far).

Another supposition is that it may be a bad connector ot loose contact behind the firewall (interior) and is the BCM Body Control Module. Anyone familiar with this component? and where to locate it?

components replaced so far
  • Front Control Module
  • Steering Control Module
  • Shift Control Module
  • Ignition Power Module
  • Ignition Switch (2x)
  • Fuse Block

One of the symptoms, is that the problem occurs when the vehicle experiences bumps in the road or general vibration, but that it is also now happening more frequently at idle. And occasionally the ABS initiates.

Any thoughts and ideas are appreciated.

Thanks
Architect
Keith
__________________
Reply With Quote
  #9  
Old 08-01-2010, 10:22 AM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 25 Times in 25 Posts
Rep Power: 63464
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

I have the exact problem. My Whole DashBoard would Flicker and so would my Information Center, Radio and Headlights and Tailights and the A/C Control Center. I'm going to order the part soon. I'm just a little busy.
__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #10  
Old 08-01-2010, 06:41 PM
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jan 2010
Location: mid-Michigan
Posts: 450
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2262
Walt has a reputation beyond reputeWalt has a reputation beyond repute
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Quote:
Originally Posted by Architect View Post
2010-08-01 10:14:00
Update on the ongoing saga with my dash cluster malfunction...

One forum (edmunds) user suggested that Jeeps are prone to problems relating to low voltage being delivered to the electrical system. it was stated that voltages less than approx. 13.5v could be a cause of problems. So... i went to Sears where I had purchased a DieHard battery (Jeep GC requires a special (truck) battery, not a typical car batt). They tested the battery and it delivered 13.9v to 14.0v consistently.

I am still trying to solve this problem, as the dealer after 7 visits has not fixed it as considerable cost. ($1500-$2100 so far).

Another supposition is that it may be a bad connector ot loose contact behind the firewall (interior) and is the BCM Body Control Module. Anyone familiar with this component? and where to locate it?

components replaced so far
  • Front Control Module
  • Steering Control Module
  • Shift Control Module
  • Ignition Power Module
  • Ignition Switch (2x)
  • Fuse Block
One of the symptoms, is that the problem occurs when the vehicle experiences bumps in the road or general vibration, but that it is also now happening more frequently at idle. And occasionally the ABS initiates.

Any thoughts and ideas are appreciated.

Thanks
Architect
Keith
The one thing I do not see on the list is the clockspring (unless that's what the steering control module is). On the '08 WK, the clockspring, speed control stalk, and multi-function stalk all plug in together on the steering column.

Of the three components above, the clockspring is the biggest PITA. Also the most expensive.

Parallel approach recommendation: Call the Jeep Customer Care 800 number and get a Case Number assigned. Write a comprehensive letter detailing service dates, mileage, and compoents replaced and how much you paid. Be sure to explicitly state that this parts-replacement odyssey began before the 3yr/36K miles warranty expired. Fax that letter to your assigned customer care representative (you'll have to ask for a fax number when they call you). They meet as a technical committee to consider these complex cases. Yours seems worthy of more support by Jeep.
Jeep does not typically respond in writing, rather by phone.

Then again, there's always LemonAuto.com . They specialize in these types of cases. 1-888-453-6667. Ask for Steven Toth. Chrysler will dig in if you choose to use them.
__________________
'08 WK Limited, 5.7L HEMI, Quadra-Trac II, Bright Silver Metallic, Class IV Hitch, Michelin LTX M/S tires, Billet Technology oil catch can, Fumoto oil drain valve.
Reply With Quote
  #11  
Old 08-11-2010, 09:58 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: May 2010
Location: Richmond, VA
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1693
Eaglelope is on a distinguished road
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

My 2005 WK just started doing this a few days ago. Driving at night the exterior lights flashed, then went out, dash lights out (radio stayed on), then the whole dash lit up again all in about half a second. Within a few seconds the dash settled down 9warning lights off). It did this several times so I pulled over, turned off ignition, checked battery connections, pcm connections, fuses, relays, all looked good. Started back up and no problems for a few days.
I was thinking maybe the ignition switch but now not so sure. Please keep us posted on what you find.
__________________
Reply With Quote
  #12  
Old 08-11-2010, 10:32 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,500
Thanks: 885
Thanked 1,097 Times in 752 Posts
Rep Power: 7718452
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 06 Grand Cherokee - Electrical Problem wih Dash Cluster

Quote:
Originally Posted by Eaglelope View Post
My 2005 WK just started doing this a few days ago. Driving at night the exterior lights flashed, then went out, dash lights out (radio stayed on), then the whole dash lit up again all in about half a second. Within a few seconds the dash settled down 9warning lights off). It did this several times so I pulled over, turned off ignition, checked battery connections, pcm connections, fuses, relays, all looked good. Started back up and no problems for a few days.
I was thinking maybe the ignition switch but now not so sure. Please keep us posted on what you find.

I would check the battery posts and have the battery checked. Clean the posts real good and use that battery post grease(?) that most auto parts stores sell.
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Cherokee hood problem robw Cherokee-SJ and XJ 5 04-09-2013 07:20 AM
99 grand cherokee ltd. 4.7l dschaumberger Troubleshooting/Problems 0 07-11-2010 09:15 PM
99 Grand Laredo Horn problem. Unholyskorn86 Troubleshooting/Problems 3 04-26-2010 02:57 PM
06 grand cherokee Joes Jeep Troubleshooting/Problems 2 02-02-2010 10:58 AM
99 Jeep Grand with Heating Problem rconrad Troubleshooting/Problems 1 11-28-2009 04:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.