Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-15-2011, 06:24 AM
Member
My Jeep: 2007 4.7L WK
 
Join Date: Dec 2009
Location: Florida
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1776
cflguitar is on a distinguished road
Unhappy '07 GC Laredo won't start! HELP!

My 2007 GC Laredo won't start. The battery is fine. Sometimes when I go to start it, it won't turn over. All the accessories turn on no problem. When I let it sit for a few hours it sometimes will start back up. I did notice that when I turn the key to try to start it and it tries to turn over and doesn't, the engine light flashes 10 times and stops. My dad mentioned the wireless control module but when I took it to the dealership it would start every time for them so they couldn't check it. The dealership replaced my ignition switch and pigtail wires (which cost me ($437) because someone else was having the same problem and they thought that could be it.

Anyone have any thoughts?
Please help! Need to get this fixed ASAP!
Thanks!
__________________

__________________
Reply With Quote
  #2  
Old 12-15-2011, 07:53 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2011
Location: Massachusetts
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1241
oldgeezer is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

Similar problem on my ZJ. Turned out to be bad starter wiring and the transmission neutral safety switch. Make sure that the shifter is pushed fully into park if there is any play. I did not get the engine light flashing though. Hope that this helps with a few more possibilities.
__________________

__________________
Reply With Quote
  #3  
Old 12-15-2011, 05:47 PM
BigTicket13's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Oct 2011
Location: Macomb, MI
Posts: 437
Thanks: 0
Thanked 13 Times in 10 Posts
Rep Power: 9504
BigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond reputeBigTicket13 has a reputation beyond repute
Re: '07 GC Laredo won't start! HELP!

I would go through and check all of your connections to your battery both positive and negative. make sure they haven't been cut or pulled out in any way shape of form. This could cause it because to my knowledge when you remove the battery or disconnect it for that matter it restarts or flashes your ECU in a sense. This could cause the problem with the flashing light and it would explain why you only are able to turn the vehicle over sometimes. Just my thoughts but I could be wrong.
__________________
Reply With Quote
  #4  
Old 12-15-2011, 09:55 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653004
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: '07 GC Laredo won't start! HELP!

if the wcm was faulty it would not let it even attempt to start, if it sees the wrong key in the ignition it wont even let it crank, there will typically be numerous codes generated when the wcm goes belly up.

I have seen some starters that made no noise when they failed.

I dont know what you mean by

Quote:
I did notice that when I turn the key to try to start it and it tries to turn over and doesn't
need a bit better information for interwebz diagnostics
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #5  
Old 12-16-2011, 08:00 AM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2010
Location: South Jersey
Posts: 137
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1640
Drew is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

The two most common things I seem to read about the most are the starters (not as much on the 3.7 though) and the battery cable connections, especially the cable connection on the starter. It gets cruddy on the starter.
__________________
Reply With Quote
  #6  
Old 12-17-2011, 12:07 PM
dssilvestri's Avatar
Member
My Jeep: 2008 5.7L WK
 
Join Date: Apr 2011
Location: Back Woods of NY
Posts: 235
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1514
dssilvestri is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

It must be the starter motor. Last year my zj's blew the day i sold it and i had to change it fast. It would randomly choose when to start and it blew while i was on an errand and luckily enough i waited a little bit and it started just enough to get it home. Try that mine made no noise when it went bad, it could be 95% possible its the starter motor
__________________
Oo||||||oO
08 WK Hemi
White. Loaded.
Reply With Quote
  #7  
Old 12-17-2011, 04:06 PM
New Member
 
Join Date: Dec 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
07wkflex is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

Just went through the exact same problem 2 weeks ago on my 07. The dealer replaced the starter 3 months ago and then all of a sudden this started happening. Turned out to be the alternator/battery harness. Mopar p/N 56047792ac. The pigtail that attaches to the starter goes bad. THE PART COSTS @$130 and if you are somewhat handy you could save yourself 2 hours dealer cost labor. Hope this helps...good luck
__________________
Reply With Quote
  #8  
Old 12-17-2011, 07:02 PM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: '07 GC Laredo won't start! HELP!

The dealership replaced my ignition switch and pigtail wires (which cost me ($437) because someone else was having the same problem and they thought that could be it.

Anyone have any thoughts?
Please help! Need to get this fixed ASAP!
Thanks![/QUOTE]


believe hes done that
__________________
Reply With Quote
  #9  
Old 12-17-2011, 09:00 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2011
Location: Massachusetts
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1241
oldgeezer is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

Really confused? They charged you $400.+, but the problem still remains? What exactly is the approach to be used with dealers that charge $$$, with no resolution to the problem, and the customer is still having the same original problem? What am I missing in this equation? Surely not an isolated event, but curious what the effective approach should be to get the problem(s) solved/resolved? Where I worked in the Defense industry(Patriot,Hawk Missile systems), there always had to be a "root" cause solution to the problem(s) and accountability. Perhaps I am becoming jaded in my age(65) and am no longer willing to accept the "new" approach?(Whatever that seems to be). My response is not intended to "dis" dealers, but more often than not, we continue to hear disatisified customers. If I am out of line, let me have it. Personal negative experiences are available if needed to be delinitaded ,but am trying to minimize any further Dealer bashing. The best part of the forum(in general) is that we try to share similar instances with the intent of helping each other and help minimize $$$ outlayed to fix the problem. Happy Holidays to all.
__________________
Reply With Quote
  #10  
Old 12-18-2011, 02:07 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113269
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: '07 GC Laredo won't start! HELP!

Oldgeezer,

No worries on dealer bashing, dealers suck!

Clfguitar,

You said the engine light flashes so what are the codes?
Is your battery the original one? If so get a new one.
Has it ever died while driving down the road?
Do your relays click when you go to start it? Might want to swap one at a time and see if it makes a difference.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #11  
Old 12-19-2011, 12:18 AM
New Member
 
Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
05/4.7 is on a distinguished road
Re: '07 GC Laredo won't start! HELP!

I have been dealing with a similar issue with my 05 4.7. Try disconnecting / reconnecting the PCM quick connectors located underneath the primary and secondary fuse boxes. I belive that the issue may require a reflash but i have not been willing to pay up the $300 my local stealership is asking for.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Start of My WK snow99dohc Members Rides 42 04-22-2012 03:48 AM
Anyone have a Laredo E with Remote Start? JeepJunkie Tech Tips/DIY/How To 4 12-19-2011 12:33 PM
99 4.7l No start...Please Help... SuperTuner12010 Engine Performance/Intake/Exhaust 3 05-05-2011 01:04 PM
Hello everyone, 2006 laredo wont start??? zlacko Troubleshooting/Problems 13 10-13-2010 08:00 PM
Is sunroof standard on Laredo or Laredo X? tkln Grand Cherokee - WK2 - 11 09-19-2010 03:05 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.