08 Laredo advice - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-27-2016, 11:08 AM
Member
 
Join Date: Nov 2015
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 409
cadolid is on a distinguished road
08 Laredo advice

Hi I have an 08 Laredo 3.7. It has 78k miles and I have owned since 66k. I have an issue with when I start it probably about 30% of the time so will probably be hard to replicate the issue. When I start the vehicle it will idle very rough for a couple seconds then the vehicle will shake and then stall out. It will then usually restart fine after i turn off and then restart it. It's had a new battery, new sparkplugs, transmission and coolant flushed since I've owned it. I've had the dealer and precision tune auto tell me no other problems they can find with it. Any advice? Just don't want it to get worse. Thanks

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-27-2016, 07:28 PM
coaldigger's Avatar
Member
 
Join Date: Oct 2015
Posts: 111
Thanks: 24
Thanked 13 Times in 13 Posts
Rep Power: 537
coaldigger is on a distinguished road
Re: 08 Laredo advice

You can try pulling throttle body and clean. Run some injector cleaner through a tank of fuel. I use techron.
Reply With Quote
  #3  
Old 04-28-2016, 07:00 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Apr 2016
Location: NY
Posts: 46
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 276
Ifinn03 is on a distinguished road
Re: 08 Laredo advice

Try a complete cleaning of the fuel system and combustion chamber
Reply With Quote
  #4  
Old 04-28-2016, 07:11 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Apr 2016
Location: NY
Posts: 46
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 276
Ifinn03 is on a distinguished road
Re: 08 Laredo advice

Mine had the same problem. Hard start, rough idle, and idle jumping in park or neutral. Flushed the cooling system made it a little better, but, found out down the road it was the pre gapped performance pugs that where not at the rite specs. .055 ( wrong)and jeep calls for NJK .043. I've used variety of high end plugs, but have found out through experience that it was just a waste of cash money. Also, check throttle body/Intake/Intake vacuum lines/Complete air intake system and hose connections/Fuel system, fuel injectors/combustion chamber. Which is all a relatively a cheap fix
Reply With Quote
  #5  
Old 04-28-2016, 08:54 AM
Member
 
Join Date: Nov 2015
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 409
cadolid is on a distinguished road
Re: 08 Laredo advice

Thanks guys..I will try what coaldigger said first and see what happens. I am female and don't know a whole lot about working on cars but I'm sure I can figure it out about cleaning throttle and trying techron.
Reply With Quote
  #6  
Old 04-28-2016, 09:35 AM
coaldigger's Avatar
Member
 
Join Date: Oct 2015
Posts: 111
Thanks: 24
Thanked 13 Times in 13 Posts
Rep Power: 537
coaldigger is on a distinguished road
Re: 08 Laredo advice

Check out some throttle body cleaning vids on YouTube. If you look inside throttle body and see lots of carbon buildup then it could use a good cleaning. But it could be bad plugs as well. With jeeps there are so many things and variables that affect idle. Engine coolant temp sensors,plugs,injectors,fuel pump up stream o2 sensors,cam and crank sensors etc. But if your not seeing check engine light/ codes it should be something simple. Every sensor imaginable has been replaced on mine and the idle still stinks. Some of it is jeep/ Chrysler .
Reply With Quote
  #7  
Old 04-28-2016, 10:44 PM
Member
 
Join Date: Nov 2015
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 409
cadolid is on a distinguished road
Re: 08 Laredo advice

No codes or lights on so hopefully a simple fix. This is my first jeep and surely won't be my last. Its been a pretty solid vehicle so far. Thanks again
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Advice/Input on XD Series Monster w/ +18 offset for '14 JGC Laredo E maclovin Suspension/Driveline/Brakes/Wheels/Tires 0 09-30-2014 11:48 PM
Advice on 13 Laredo Max Steel mods Cuja444 Grand Cherokee - WK2 - 17 06-02-2014 04:50 PM
Laredo 4x2 Tire Advice rbe2 Suspension/Driveline/Brakes/Wheels/Tires 2 03-24-2014 02:01 PM
Advice on ordering a base model Laredo E 4x2 onyx962 Grand Cherokee - WK2 - 7 08-03-2011 04:58 PM
"blacked" out 06 laredo and looking for advice on a lower stance giordanonv Grand Cherokee - WK 10 10-21-2010 08:17 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.