Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-19-2013, 10:07 PM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
'08 WK Hemi poor/low idle

Hey all, so first time posting, but having issues with my newly acquired '08 WK Overland with hemi. At idle, it will be fine then drop below 500 rpms and almost stall, then catch itself and come back. I have had it stall a few times so far and have replaced the following
-Crank sensor
-cam sensor
-Egr valve
-cleaned Throttle body which was dirty-just wiped off butterfly.

Any thoughts? Could this be a failing MAP?

Has 75k on it, plugs done at 69k, and I have PCV to do this week.

Any advice would be awesome
__________________

__________________
Reply With Quote
  #2  
Old 02-19-2013, 11:47 PM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
What level is the trans fluid at? What type of oil you using?
__________________

__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #3  
Old 02-20-2013, 08:16 AM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
Re: '08 WK Hemi poor/low idle

Trans fluid level was ok when I last checked. Oil is 5w-30 just changed about 3 weeks ago.
__________________
Reply With Quote
  #4  
Old 02-20-2013, 08:41 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
The hd I needs to run on 5w20 in order for mds to work properly.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #5  
Old 02-20-2013, 08:57 AM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
Re: '08 WK Hemi poor/low idle

Do you think it is because of the MDS? It is either 5-30 or 5-20...it was 5 degrees that day and the local AAA shop did the work
__________________
Reply With Quote
  #6  
Old 02-20-2013, 09:30 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
No I don't think so I'm just throwing some ideas out there, how about plugs? What kind did you use and when were they last changed?
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #7  
Old 02-20-2013, 09:48 AM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
Re: '08 WK Hemi poor/low idle

Plugs were done before i purchased it.. done at dealership in IN-called them and got records. I am stumped on this one...seems like it runs fine otherwise, just issues at idle, when parking, or stopped at light.
__________________
Reply With Quote
  #8  
Old 02-20-2013, 11:10 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Try sea foaming it, I can in fuel tank and 1/2 in oil other half in brake booster line.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #9  
Old 02-20-2013, 11:11 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Also try the map sensor it's probably cheap, also possible to be a bad o2 sensor without codes.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #10  
Old 03-24-2013, 09:53 PM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
Re: '08 WK Hemi poor/low idle

Alright, so a quick update. Been cold out here in OH and busy with other projects but finally had time to mess with the Jeep. So I replaced the MAP sensor and took it for a test drive-no issues whatsoever.

Next day, remote started it, ran for 5 minutes then stalled at idle. I also seafoamed and then drove it on a 6 hour round trip, no issues. Only issue with the drive was stalling in reverse out of parking spot.

Whats next? haha
__________________
Reply With Quote
  #11  
Old 05-24-2013, 09:51 PM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 753
Thanks: 4
Thanked 9 Times in 9 Posts
Rep Power: 1153060
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
I would remove the throttle body completely and do a thorough clean, also is replace the spark plug wires
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #12  
Old 06-17-2013, 11:22 AM
Member
 
Join Date: Mar 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 866
arnsnk is on a distinguished road
Re: '08 WK Hemi poor/low idle

Update: Replaced throttle body with a brand new one. Already had 2 new PCMs installed. Still stalling about once a week.

Any suggestions? Can this be fuel related?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
low idle and stalling issue SvenskaJeepGuy Troubleshooting/Problems Discussion 11 05-26-2014 05:44 PM
Poor deer, poor Jeep, poor air suspension module some nitwit put in the bumper avalys Trouble Shooting/Problems/Service 12 12-12-2012 09:18 AM
08 Hemi idle drops too low intermittently & stalls bet_on_black Troubleshooting/Problems 6 10-30-2012 09:43 PM
low idle hummer recovery team Trouble Shooting/Problems/Service 6 08-17-2012 01:39 AM
Going after poor idle on 4.7... Anything else? Mr Chill Troubleshooting/Problems 5 07-21-2012 09:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community