Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-20-2012, 08:32 PM
New Member
My Jeep: 2005 4.7L WK
 
Join Date: Aug 2012
Location: Norcross, GA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jonm61 is on a distinguished road
2005 4.7L WK Starting Problem

I just posted this in the general troubleshooting, before realizing there was a WK troubleshooting section.

Background: Starting around May of last year, I noticed some intermittent issues, mostly taking an extra turn or two of the engine when starting, sometimes a little sluggishness on the gas.

1 year ago, went out, tried to start the Jeep and it would turn over, but never catch. Had it towed to the dealer, where they replaced the fuel pump.

2 weeks later, same problem. Had it towed in, where they told me they had pinched some wires when reinstalling the gas tank, which shorted and blew the relay.

A week later, dead battery, replaced under pro-rated warranty.

Every two months(ish) since, same problem.

First time, they (dealership) tore down the IPM, cleaned, reassembled, and problem solved.

Second time, after having it towed in, the tech popped the hood, smacked the top of the IPM, and it started right up. Since they couldn't figure out what the problem was, that was the "fix". My service advisor (I go to the same one every time) said that the techs would just do that and drive it in, so they couldn't figure out the problem. The smart thing, to me, would've been to push it into the shop and diagnose it while it was still dead...

Anyway, most of the times that it's happened, popping the hood and smacking the top of the IPM worked, until recently. Now, it tends to happen the day after it rains (not every time it rains, thankfully) and it will be fine the next day.

Today was one of those days and I needed it to start today, not tomorrow, so I started taking things apart. I figured that, since the initial problem was with fuel delivery, that odds are fair that would continue to be the problem area (vs. spark or air).

I looked at everything in the IPM and it didn't make sense. From what runs through there, it makes more sense that the problem would be in the PDC, since that's where the relay and fuse for the fuel pump are. So, I pulled it apart, checked to make sure everything was clean and dry (that's as far as I was prepared to go late in the day). I put it back together and it still wouldn't start.

Since they'd told me it was the IPM, I went ahead and pulled it, doing the same thing. Checking from the top, no change. However...

On the bottom of the IPM, there are two large connectors, one for each half of the box. I disconnected both, again just making sure it was clean & dry (I did blow each of them out with canned air). When I plugged them back in, it started right up.

So, I guess it's safe to say the problem is in the IPM. The thing is, I can't figure out what could be causing it. The only thing that has power running through there, that's not an "accessory" function, is the FCM (Front Control Module) which has 4 fuses, FCM Battery 1-4.

I'm not 100% on what the FCM does, though it's clearly pretty important.

Does anyone know if there is something that the FCM does that would affect starting? It's got to be either fuel or spark that is the problem...
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
08 Liberty Starting problem jhoberg Liberty-KJ and KK 1 09-06-2012 10:23 AM
Starting problem jdb2797 Engine Performance/Intake/Exhaust 15 08-06-2011 07:24 PM
2005 wk 3.7 Starting issue speakerboy38 Troubleshooting/Problems 10 03-24-2010 07:00 AM
2005 4.7L Starting Issues hamuel2003 Grand Cherokee - WK 9 03-01-2010 08:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community