2005 Grand Cherokee limited PCM/Electrical issues - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-21-2016, 08:13 PM
Member
 
Join Date: Mar 2016
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 346
Jeeplover2016 is on a distinguished road
2005 Grand Cherokee limited PCM/Electrical issues

Ok So 2.5 months ago I bought a 2005 Jeep Grand Cherokee Limited with the 5.7L hemi engine. It has a few issues upon buying which I fixed. Issues where steering wheel position sensor, Bluetooth connection issue, check gas cap issue, needed a tune up, multiple issues with the ignition switch. Codes are as followed- C140E, U0126, U1504, U0114, U0197, B2100, B2305, C0077, P0420, P0430, P0300, P0455, P0457. I resolved all off those issues except the Evap leak. It still says check gas cap. I figured it was the leak detection pump because it didn't run rough at all like it has a leak. I changed the pump and drove it over 500 miles without a issue and then it came back on again. The only other issue I had been having was the bank 2 sensor 2 issue saying the catalytic is bad but other people are having the same issue there. So most issues resolved until today. I had a message that keeps coming up that the memory seats are disabled on top of the check engine like for the bank 2 number 2 sensor. I got into it to drive it and it has a quarter of a tank of fuel got on a slight hill nose down and it stalled like the key was turned off. It would not start like it was out of fuel. Got it on more level ground and put a few gallons in it still no start just kept turning over. I let it sit for about ten minutes and turned it over and still didn't wanna start. I finally had to turn the key over and pump the gas to get it to start and then it jump the rpm to 3,500'without foot on the petal. Not only that it started fine after that even after a run to the store and back. Another issue its having is the sun roof is acting like it won't close all the way. It gets almost closed and acts like there's an obstruction there and re opens. It finally closed after a few tries of getting it to close. Also it's dropping into limp mode for no reason and throws no codes either. When you get it in limp mode most times you stop on level ground shut it down and restart it and it's fine. Also the transmission has issues regulating fluid pressure. It seems to take a few seconds to get to engage the drive gears in the transmission but reverse works just fine. But when the transmission is moving or the pressure is established in drive it works flawless except for the few times it has dropped into limp mode. ANY IDEAS IM LOST HERE. When the jeep is functioning correctly there is not issues like the 500 mile trip. Not a single issues except it dropped into limp mode once at 65mph then corrected upon restart.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 04-28-2016, 10:31 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Nov 2014
Location: Midwest
Posts: 63
Thanks: 6
Thanked 5 Times in 4 Posts
Rep Power: 894
pbruecken is on a distinguished road
Re: 2005 Grand Cherokee limited PCM/Electrical issues

This sounds like the classic bad connection in one of the big buss plugs. Since all these problems are seemingly unrelated (sunroof, transmission, engine, evap system, etc.), I would check the large computer buss plugs around the car for loose connections, rust or water leakage. If they all look good, I'd look at the computers and see if they have good grounds and look at them for corrosion.


Sent from my iPad using JeepGarage
Reply With Quote
  #3  
Old 04-29-2016, 12:43 AM
Member
 
Join Date: Mar 2016
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 346
Jeeplover2016 is on a distinguished road
Re: 2005 Grand Cherokee limited PCM/Electrical issues

I do notice as a follow up that if I pull the fuse for the pcm when it's acting up it clears everything and works find for a while. Then it acts up again and I re pull the pcm battery fuse and it clears again.
Reply With Quote
  #4  
Old 04-29-2016, 07:56 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Apr 2016
Location: NY
Posts: 48
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 350
Ifinn03 is on a distinguished road
Re: 2005 Grand Cherokee limited PCM/Electrical issues

Commander, Jeep Grand Cherokee and some Chryslers, Ram and Dodges sunroofs can loose their calibration and then not shut automatically. Mine was the same way and was leaking inside the headliner because of it. Easy simple fix just follow this link for :



Mine happened when I went through an automatic car wash and the force of the dryer lifted it up and down which messed up the positioning- stay away from automatic car washes! (But before that it would do what your was doing) which was also fixed after following instructions from the above link
Reply With Quote
  #5  
Old 04-29-2016, 09:56 AM
Member
 
Join Date: Mar 2016
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 346
Jeeplover2016 is on a distinguished road
Re: 2005 Grand Cherokee limited PCM/Electrical issues

Ok so took it too the dealer to look for the issue and it turns out there are a lot mis matched codes in the software. They are re flashing the system and making everything match again. Hope that works. Also diagnostics say they PCM doesn't show any faults like it's going bad. I'll let you know after a few days if it fixes it or not.
Reply With Quote
  #6  
Old 05-04-2016, 10:40 AM
Member
 
Join Date: Mar 2016
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 346
Jeeplover2016 is on a distinguished road
Re: 2005 Grand Cherokee limited PCM/Electrical issues

Ok Just an update after a week. Jeep updated the pcm and reconfigured it. Now it seems to have worked somewhat but I still have the tranny dropping into limp mode and the check engine light on as a result. The only other issue seen at this time it when driving it the idle is fine but when you come to a complete stop the idoe drops down to about 2-3 hundred rpms before recovering and idling normal at 5-6 hundred rpm. Does this every time you come to a complete stop while the transmission is in drive. In park the jeeps fine. Any suggestions???
Reply With Quote
Reply

Tags
grand cherokee, limited

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Grand Cherokee Electrical Issues FireCap Troubleshooting/Problems 5 12-30-2015 06:20 PM
05 Hemi Grand Cherokee Electrical Issues Please Help tasso96us Grand Cherokee - WK 2 11-29-2013 06:22 PM
Electrical issues abound in '11 limited, 3 modules fried everclearcrans Trouble Shooting/Problems/Service 5 02-16-2013 09:21 PM
98 Grand Cherokee Electrical Issues... jaysjeeps Troubleshooting/Problems 1 02-11-2013 09:20 PM
Pcm 4x2 = pcm 4x4 surfrman Grand Cherokee - WK 6 08-04-2010 07:17 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.