Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-07-2014, 10:49 PM
New Member
 
Join Date: Jul 2014
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 0
The Stig is on a distinguished road
2006 JGC 5.7 hemi transmission issues

I have a 2006, JGC 5.7 Overland, 85000 miles. Recently I have experienced some "thumping" sounds, seems to be coming from the transmission, usually happens when I go down a hill and let go off the accelerator. Have also got "Transmission over temp" a few times. The transmission oil is good.
One guy told me it could be the "Front axle housing support mount" or a "solenoid"...... If I took it to the dealership, and ran a diagnostic, would anything come up, if something was wrong with transmission?
__________________

__________________
Reply With Quote
  #2  
Old 07-08-2014, 07:04 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,917
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525871
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2006 JGC 5.7 hemi transmission issues

Welcome to the garage.
Your jeep has the 5-45RFE transmission. Some other members overhere also experienced the transmission overtemp message. When i remember well, the problem was with the transmission control module (inside the PCM). If you have an infrared temperature meter, you could monitor the transmission temperature at the moment the overtemp message is there, just to be sure there is not a real overtemp. I think that the thumping sound and the overtemp message are not related. Normally if the transmission has a failure, the TCM would have stored a message an you would have the check engine light with a related P0700 general transmission fault code from the PCM.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 07-08-2014, 01:32 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Feb 2014
Location: Wentzville, MO
Posts: 41
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 254
jtodaro is on a distinguished road
Garage
Re: 2006 JGC 5.7 hemi transmission issues

Quote:
Originally Posted by The Stig View Post
I have a 2006, JGC 5.7 Overland, 85000 miles. Recently I have experienced some "thumping" sounds, seems to be coming from the transmission, usually happens when I go down a hill and let go off the accelerator. Have also got "Transmission over temp" a few times. The transmission oil is good.
One guy told me it could be the "Front axle housing support mount" or a "solenoid"...... If I took it to the dealership, and ran a diagnostic, would anything come up, if something was wrong with transmission?
Your thumping will be most likely be your Top Front Differential Pivot Mount. Shouldn't be more than $180-250 to have fixed at most shops. Not sure on a DIY.
__________________
Reply With Quote
The Following User Says Thank You to jtodaro For This Useful Post:
Reply

Tags
2006, hemi

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions / Issues on new 2014 JGC Summit with Hemi BreakOnThrough Grand Cherokee - WK2 - 2 06-05-2014 11:08 AM
2006 WK Transmission not shifting SgtsDad Troubleshooting/Problems 11 03-16-2014 06:37 PM
Transmission Over Temp on 2006 Commander Kmackk Troubleshooting/Problems Discussion 9 06-26-2013 11:26 AM
Transmission Cooler Line Leak 2006 WK Help Laredo2006 Engine Performance/Intake/Exhaust 1 05-10-2013 07:33 AM
Slow engine starting issues on 2006 Jeep Commander 5.7L Hemi Thomaskr 2005+ Jeep Commander XK 1 03-29-2011 10:14 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community