Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-08-2010, 10:40 AM
New Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
scottmarion is on a distinguished road
2008 WK REQ Radio Issues - No Sound at times

I have a 2008 WK with Radio issues. Factory REQ Radio. At times when the vehicle is started, there will be no sound coming from the speakers. All Radio functions will work though; Change between AM/FM/SAT, AUX, and all info will appear as well like the song info etc. It will come back after a few restarts of the vehicle. I have had 2 radios replaced, ECM module replaced and the issue still occurs.

Does anyone know of what this may be or any fixes that may be out there?

Thanks for all of your help!
__________________

__________________
Reply With Quote
  #2  
Old 04-08-2010, 11:39 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12408
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: 2008 WK REQ Radio Issues - No Sound at times

wiring harness is my best bet let Matt chime in and see if he can help
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #3  
Old 04-08-2010, 11:40 AM
B.P.O.D's Avatar
RockNrolla/JG Founder

My Jeep: 2008 3.7L WK
 
Join Date: May 2009
Location: Bergen County, NJ / Bushkill, PA
Posts: 14,644
Thanks: 3
Thanked 9 Times in 8 Posts
Rep Power: 16732
B.P.O.D has disabled reputation
Send a message via AIM to B.P.O.D
Re: 2008 WK REQ Radio Issues - No Sound at times

hmmm that's odd. i had my radio for a year and never had an issue, is the truck still under warranty??? if so bring it to the dealer!
__________________
Irfan "Showing off is the fool's idea of glory."
can you beat me in a fight??? http://dreamps.mybrute.com
member of Black, Tri-State, 6 cylinder club 08 Brilliant Black Laredo (JG 3.7L Squad)- k+n 63-1545,magnaflow 10436,mygig(ren), HID's 6k lows, 6k+3k fogs,dual turn leds,led brows,v-led interior leds, cargo led strip, reverse hids, 92 led brake lights, tinted tails,custom powder coated mesh grill, srt sways, 15% tinted windows,illuminated visors,shorty antenna, HH Class III, cargo liner, thule snowboard rack,kayak rack, bike rack

Future mods - color matched side mirrors, black srt reps

My 1-step correction writeup

How To - LED BROW

Reply With Quote
  #4  
Old 04-08-2010, 11:52 AM
08Hemi's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,296
Thanks: 0
Thanked 26 Times in 31 Posts
Rep Power: 330453
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Re: 2008 WK REQ Radio Issues - No Sound at times

you said you have had 2 replaced? more than likely it is under warranty...has the dealer been helpful at all?
__________________
Reply With Quote
  #5  
Old 04-08-2010, 01:04 PM
New Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
scottmarion is on a distinguished road
Re: 2008 WK REQ Radio Issues - No Sound at times

They have been very helpful and done all replacements. Its stil got a year or 6,000 miles for the warranty. They just cannot find the real root cause. just hoping someone here might know something else.
__________________
Reply With Quote
  #6  
Old 04-08-2010, 03:21 PM
08Hemi's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,296
Thanks: 0
Thanked 26 Times in 31 Posts
Rep Power: 330453
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Re: 2008 WK REQ Radio Issues - No Sound at times

do you have the BA amp? my first thought would be to take the dash off and take a looksie at the wiring (very easy to do, takes about 15 mins, instructions on wkjeeps.com)...from there you can inspect the connections/wiring harness. Since you know it is not the unit itself (again, I am assuming that all 3 you have had were not faulty) I would inspect the harness as closely as you can. Something is causing the radio to NOT send a signal to the speakers...but the unit itself is functioning...when it is on do you get ANY feedback from the speakers?
__________________
Reply With Quote
  #7  
Old 04-08-2010, 03:26 PM
Matt's Avatar
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2009
Location: 34.076513,-118.429573
Posts: 9,269
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 11682
Matt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond reputeMatt has a reputation beyond repute
Re: 2008 WK REQ Radio Issues - No Sound at times

Yeah, I mean it's process of elimination.

Harness
Radio
Wiring
Amp
Wiring
Speakers


Obviously it can't be the speakers or the wiring from the amp to the speakers.

And you said you've had the radio replaced, so that's out.

It's got to be the harness (power side) or the amplifier... or the wiring between those two (which I doubt). The last thing I expect to fail is wiring, the first thing I suspect is the actual electronics.

As Brad said, make sure all connections are snug.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Top 1/4 Mile Times Robert Palmer At The Track 40 06-13-2011 10:26 PM
adding satellite radio and ipod/aux to RAQ radio fasteddy001 Audio, Video, Navigation & Electronic Modifications 3 02-20-2010 02:43 AM
Idea stolen a couple times over KidFresh5.7 Visual Modifications 24 11-17-2009 12:18 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.