Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-14-2014, 11:42 AM
New Member
 
Join Date: Mar 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ironmikelaw is on a distinguished road
2009 Jeeep Cam,. Crank position code issue

Hello everyone i'm looking for some advice
Let me start out by saying I am the auto parts business even with vast amount of customers I deal with I still come up with no concrete answer

My wife currently drives a 2009 Jeep grand Cherokee Overland with the 57 hemi
A week ago the check engine light came on and it through a cam and crank position sensor codes being in the auto parts business I do have access to a multiple of scan tools after checking the code I went to my local Jeep dealership that I have a business relationship with and purchase OE cam and crank position sensors after replacing the sensors and clearing the code the vehicle ran perfectly
However when I turn the vehicle off and restarted the code immediately reappears in the vehicle runs in a tape of limp mode with loss of power and the ability to use things like remote start and cruise control if I clear the code and start the vehicle immediately the vehicle runs perfect I'm even driven the vehicle for multiple hours with no issue whatsoever however once I shut the vehicle off and turn it back on the light comes back on in the process starts all over again I now have my wife clearing the code when she starts the vehicle each time I have consulted friends in the business and have checked wiring and have not come up with any concrete answer on why this is happening I did not know if a faulty knock sensor could make this happen if anybody has any information it will be greatly appreciated
__________________
Reply With Quote
Reply

Tags
2009

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No start condition. Cam Position Sensor indicated. Doug4230 Troubleshooting/Problems 17 09-19-2013 10:52 PM
Error Code P000D Camshaft 2 position slow response. 2011JeepGC Trouble Shooting/Problems/Service 7 03-21-2013 04:42 PM
picture of crank position sensor 2.7crd paul4314 Export & Diesel Powered Jeep Models 3 01-14-2013 05:03 PM
Starting Irritation and Crank Position Sensor 0l1v3r Engine Performance/Intake/Exhaust 20 02-20-2012 08:36 PM
Vacumn Leak Code and the vent position knob bmflyfish Troubleshooting/Problems 3 02-17-2010 06:39 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community