5.7 Starting Issue - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-11-2014, 12:35 PM
Member
 
Join Date: Jun 2014
Posts: 90
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1083
Jofus311 is on a distinguished road
5.7 Starting Issue

Been having a bit of a problem since I bought the truck, nothing major, i think. But now it's time to address it.

Some times, maybe once ever 30 starts, the truck will turn over but then immediatly turn off. I'll turn the key again and it will start right up. Any ideas?

Next issue is, and I've only noticed this while outside the truck and remote starting it, is that it doesn't always start smoothly (here come some terrible typed sound effects.....)

Normal start - Turn key & VROOOOOMMMM

Not Normal Start - Turn Key and Vrooo, chugachugachuga,vrooooooom. It only lasts a second or so, but it sounds like maybe it's being starved or something. It however always ends up starting.

Any ideas?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-11-2014, 12:40 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,031
Thanks: 74
Thanked 279 Times in 246 Posts
Rep Power: 46366
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: 5.7 Starting Issue

Quote:
Originally Posted by Jofus311 View Post
Been having a bit of a problem since I bought the truck, nothing major, i think. But now it's time to address it.

Some times, maybe once ever 30 starts, the truck will turn over but then immediatly turn off. I'll turn the key again and it will start right up. Any ideas?

Next issue is, and I've only noticed this while outside the truck and remote starting it, is that it doesn't always start smoothly (here come some terrible typed sound effects.....)

Normal start - Turn key & VROOOOOMMMM

Not Normal Start - Turn Key and Vrooo, chugachugachuga,vrooooooom. It only lasts a second or so, but it sounds like maybe it's being starved or something. It however always ends up starting.

Any ideas?
Ayup.

Try adding year, make, model since it may be something someone would recognize with that info.
Reply With Quote
  #3  
Old 09-11-2014, 01:16 PM
Member
 
Join Date: Jun 2014
Posts: 90
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1083
Jofus311 is on a distinguished road
Re: 5.7 Starting Issue

Quote:
Originally Posted by lstowell View Post
Ayup.

Try adding year, make, model since it may be something someone would recognize with that info.
I always forget that

2008 5.7 Hemi Limited Grand Cherokee
Reply With Quote
  #4  
Old 09-11-2014, 01:22 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,031
Thanks: 74
Thanked 279 Times in 246 Posts
Rep Power: 46366
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: 5.7 Starting Issue

Quote:
Originally Posted by Jofus311 View Post
I always forget that

2008 5.7 Hemi Limited Grand Cherokee
Add it to your profile info permanently to save time.

Anyhoo, I would suspect a fuel pressure sensor shutdown on the start if it weren't for that it seems to start after a time. Fuel filter clogged? Clogged cat?
Any problem codes?

Hopefully someone will recognize this, as my v8 is too new for it to have picked up any "charming foibles" such that I would recognize yours as being "oh yeah, that's the ground wire on the veeblefetzer" but hang in there, some real geniuses lurk here...
Reply With Quote
  #5  
Old 09-17-2014, 12:01 PM
Senior Member
 
Join Date: Feb 2010
Posts: 1,019
Thanks: 0
Thanked 23 Times in 22 Posts
Rep Power: 8997
dmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond repute
Re: 5.7 Starting Issue

How many miles on the OD, and do you have a record of maintenance ? IF 70k or more, and these were not done, I would do new EGR, MAP sensor, clean up the TB, adding Seafoam to gas tank and also to crankcase (change oil within 150 miles of adding) to free up stuck MDS lifters, etc..and also put on a catch can. Make sure to Reset the ECU after cleaning TB by disconnecting battery neg for a while.
__________________
2006 GC Overland QD II
5.7 Hemi, Modern Muscle 85 mm CNC ported TB, Apexi super voltage stabilizer, Billet Tech. Catch Can, Koni FSD shocks/struts, SRT8 sway bars, Cooper Discoverer SRX 255/65/17, Amsoil fluids, Diablosport Intune CMR tuned by Hemifever tuning.
Reply With Quote
  #6  
Old 09-17-2014, 04:37 PM
Member
 
Join Date: Jun 2014
Posts: 90
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1083
Jofus311 is on a distinguished road
Re: 5.7 Starting Issue

Quote:
Originally Posted by dmsfun View Post
How many miles on the OD, and do you have a record of maintenance ? IF 70k or more, and these were not done, I would do new EGR, MAP sensor, clean up the TB, adding Seafoam to gas tank and also to crankcase (change oil within 150 miles of adding) to free up stuck MDS lifters, etc..and also put on a catch can. Make sure to Reset the ECU after cleaning TB by disconnecting battery neg for a while.
52K on the odometer. I have some service history. But, I did extensive research here before I bought the car. As soon as I bought it I did;

PCV
EGR
MAP
Cleaned Throttle Body Spotless
Billet Tech Catch Can
Mobil 1 Synth Oil Change w/ Mopar Filter
16 New Champion 570s gapped to .44
New Serpentine Belt
2x Sea Foam Treatment (1 Can in gas, 1/2 can in brake booster line, 1/2 can in engine)
Always disconnected for 5 minutes after working on the truck

This problem persisted before and after (less frequently) all the work.

Maybe a crank position sensor or something like that.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WK Starting Issue wcjr Troubleshooting/Problems 29 10-27-2011 05:40 PM
07 starting issue- give it gas to keep it started? paroxysym Grand Cherokee - WK 11 03-01-2011 03:08 PM
2000 WJ Starting issue? StoneCold Engine Performance/Intake/Exhaust 6 02-14-2011 02:47 PM
help. starting issue. carfreak493 Trouble Shooting/Problems/Service 3 09-20-2010 09:14 PM
2005 wk 3.7 Starting issue speakerboy38 Troubleshooting/Problems 10 03-24-2010 08:00 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.