Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 07-10-2012, 10:11 AM
Unholyskorn86's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2009
Location: Bristol, CT
Posts: 566
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2381
Unholyskorn86 is on a distinguished road
Send a message via AIM to Unholyskorn86
Re: 5.8~6 MPG in city...

Replace fuel filter just to do it?
__________________

__________________
WANT TO MAKE MONEY? http://tinyurl.com/lolbusup
Then PM me for more info!
Reply With Quote
  #14  
Old 07-10-2012, 11:54 AM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,732
Thanks: 46
Thanked 14 Times in 12 Posts
Rep Power: 1141572
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
Re: 5.8~6 MPG in city...

^ only filter these have is the strainer in the tank :-(
__________________

__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
  #15  
Old 07-11-2012, 04:35 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 932
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

I drove 36km, and tanked to full 15 litres, that gives 41.6 l/100km - 5.64 mpg.

I was at the mechanic and connected jeep to computer.

all o2 sensors works like new, front ones sinus is good, after cats are steady. map sensor works, tps works, mds works there were a test to all 4 mds cylinders, air temp sensor works etc.

injector times if I remeber correctly were around 1800Ás(ms) at idle. anyone knows is it good?

only code I have is , like I wrote before, p0499. I`ll order nvld pump and see what happens....

any ideas guys?
__________________
Reply With Quote
  #16  
Old 07-11-2012, 09:07 AM
Member
 
Join Date: Feb 2010
Posts: 853
Thanks: 0
Thanked 6 Times in 5 Posts
Rep Power: 7937
dmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond reputedmsfun has a reputation beyond repute
Re: 5.8~6 MPG in city...

If you have a Hemi and over 50k miles, whether ot not there is any code, just replace the MAP sensor, EGR, and PCV. All three are less than $100 total, are easy to install yourself, and you'll have no concerns as to thier functionality. Also replace the PCV to intake hose, as any small leak or crack will affect drivability and mpg. Make sure to clean the TB, and reset the ECU after putting it back on by disconnecting the battery neg. terminal for a while. Then put seafoam in the tank and oil. If you have the Hemi tick, that means your MDS lifters are sticking, making drivability and mpg worse. Seafoam in the oil cures this problem in about 100 miles.
__________________
2006 GC Overland QD II
5.7 Hemi, Modern Muscle 85 mm CNC ported TB, Apexi super voltage stabilizer, Billet Tech. Catch Can, Koni FSD shocks/struts, SRT8 sway bars, Cooper AT3's, Amsoil fluids, Diablosport Intune CMR tuned by Hemifever tuning.
Reply With Quote
  #17  
Old 07-11-2012, 10:03 AM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,802
Thanks: 33
Thanked 31 Times in 30 Posts
Rep Power: 88626
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: 5.8~6 MPG in city...

What is your MAP/vacuum reading?
__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
  #18  
Old 07-11-2012, 11:43 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 932
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

the car has ~26000 miles only, I ordered new plugs, pcv and nvld pump, I`ll change it when I get my hands on it. I dont know map readings , yeah I should write it down to check if they were ok at idle. this would show an air leakif there were.

I`ve read about seafoam, I dont know if I can get it here in Poland, mhm maybe I should import it and sell here since everybody is using it in USA...

I have no tick and the car has no drivability problems. engine runs smooth, no stalling , never died after stop etc.

oh and about egr. previous owner bought egr because there were only connector from harness and now its just laying doing nothing because there is no egr port.
I`ll make a photo later if you dont believe me. I reaserched the net to find hemi heads without egr port and couldnt find any. maybe its some weird version?
car was imported from canada. there is no egr port drilled in head and in intake the port is blocked by steel plug, it looks like factory plug.
__________________
Reply With Quote
  #19  
Old 07-11-2012, 12:20 PM
bcm0018's Avatar
Member
My Jeep: 2009 7.2L SRT8
 
Join Date: Mar 2012
Location: West Chester, PA
Posts: 40
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 944
bcm0018 is on a distinguished road
Re: 5.8~6 MPG in city...

How does your air filter look?

If it makes you feel any better my EVIC currently reads 5.5 mpg too cause it was recently reset. I avg ~8 for DDing.
__________________
Reply With Quote
  #20  
Old 07-11-2012, 12:33 PM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 932
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

air filter is clean.

here are pics of head and manifold. no egr.


__________________
Reply With Quote
  #21  
Old 07-14-2012, 09:46 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 932
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

I think I got it. odometer readings are incorrect, I just measured distance by trip A between lights and distance showed was 2 times less that measured on online map.

I had some time ago an error code u1418 mplausible right wheel distance signal.

I need to dig into it.
__________________
Reply With Quote
  #22  
Old 07-14-2012, 10:54 AM
bcm0018's Avatar
Member
My Jeep: 2009 7.2L SRT8
 
Join Date: Mar 2012
Location: West Chester, PA
Posts: 40
Thanks: 0
Thanked 4 Times in 2 Posts
Rep Power: 944
bcm0018 is on a distinguished road
Re: 5.8~6 MPG in city...

Quote:
Originally Posted by Jarek5_7 View Post
I think I got it. odometer readings are incorrect, I just measured distance by trip A between lights and distance showed was 2 times less that measured on online map.

I had some time ago an error code u1418 mplausible right wheel distance signal.

I need to dig into it.
Makes sense. If your odometer is off the evic will mpg will be off.
__________________
Reply With Quote
  #23  
Old 07-18-2012, 05:00 PM
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jan 2010
Location: mid-Michigan
Posts: 450
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2190
Walt has a reputation beyond reputeWalt has a reputation beyond repute
Re: 5.8~6 MPG in city...

Quote:
Originally Posted by Jarek5_7 View Post
.....msd started to work and I dont like it

I think its msd, because at low rpm, for example 30mph 1500 rpm it kicks in rpm rises , after second or two msd turns off. sometimes when cruising in the city for exmaple 40mph and slitly pressing accelerator it hesitetes for a second and them accelerate rapidly, too rapidly for this slight pedal pressing.

no codes expet P0499..
Use shifter to put it in 5th -or- use tow/haul button. Locks out MDS from functioning. Must be re-done after each restart.
__________________
'08 WK Limited, 5.7L HEMI, Quadra-Trac II, Bright Silver Metallic, Class IV Hitch, Michelin LTX M/S tires, Billet Technology oil catch can, Fumoto oil drain valve.
Reply With Quote
  #24  
Old 04-04-2013, 06:13 PM
Member
 
Join Date: Jan 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 601
bikerider72 is on a distinguished road
Re: 5.8~6 MPG in city...

did you find a solution for your gas mileage problem?? I have an 05 limited 5.7 and I get usually around 30L/100km around the city, much more than seems reasonable.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Laredo V6 4x2 MPG city millerkid095 Grand Cherokee - WK 12 08-09-2013 02:05 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community