Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-06-2012, 06:22 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
5.8~6 MPG in city...

5.8~6 MPG in city, below ~40mph. I checked o2 sensors, one was bad, voltage was steady, but after clearing connector it showed good results (scanned on computer by a mechanic). before it consumption was around 40l/100km so about 6mpg !!! after that I reset the pcm and mpg on computer and it states the same or little more??.

I have only 0499 fault which is nvld fault. can it be a problem?
car has power, and runs smooth.

where to look, any ideas?
__________________

__________________
Reply With Quote
  #2  
Old 07-06-2012, 08:52 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276904
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: 5.8~6 MPG in city...

Have you calculated your MPG manually to make sure the trip computer is correct?

How long did you drive it after the reset? It takes a while for the computer to re-calculate a stable average (something like 30 miles of driving).

I have a hard time believing you could be getting 6 MPG without any driveability issues or DTCs being set, unless you are forgetting to shut the engine off over night...
__________________

__________________
Reply With Quote
  #3  
Old 07-06-2012, 08:53 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,241
Thanks: 866
Thanked 975 Times in 689 Posts
Rep Power: 7717877
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 5.8~6 MPG in city...

more details please...engine? 4x4 or 4x2? miles? year?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #4  
Old 07-06-2012, 04:04 PM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

4x4, 2005, 42k km.

I fill up the tank to full, drove 50km in the city by next two days and then a little over 20 litres went into tank.

Its wierd for me too, its two times more than it should be I think and there are no driveability issues. engine isnt stalling, it has power, doesnt make black smoke...
__________________
Reply With Quote
  #5  
Old 07-06-2012, 04:55 PM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2842
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: 5.8~6 MPG in city...

gas leak somewhere? lol
__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #6  
Old 07-06-2012, 05:11 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2012
Location: SLO, CA
Posts: 132
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1127
Verminator is on a distinguished road
Re: 5.8~6 MPG in city...

is it stock or do you have any mods done? Is maintenance all up to date?
__________________
Reply With Quote
  #7  
Old 07-07-2012, 05:35 PM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

I bought it some time ago, fixed tranny, changed trans fluid, I`ll change engine oil next week. no mods, mds works, I can feel it operate.
__________________
Reply With Quote
  #8  
Old 07-08-2012, 02:11 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

As I wonder now, I dont think the car starts normally.

As I start it it cranks and sudenly start and very fast rpm goes to 2k, and then drops to idle, but its like vroom and fast rising to 2k. Like I would hold accelerator pedal for ahalf of second while starting.

I dont think it revs should go that high on start up.

leaky injector?
__________________
Reply With Quote
  #9  
Old 07-09-2012, 03:17 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2012
Location: SLO, CA
Posts: 132
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1127
Verminator is on a distinguished road
Re: 5.8~6 MPG in city...

Possible. Any erratic idling or random stalling?
__________________
Reply With Quote
  #10  
Old 07-09-2012, 05:25 PM
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jan 2010
Location: mid-Michigan
Posts: 450
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2195
Walt has a reputation beyond reputeWalt has a reputation beyond repute
Re: 5.8~6 MPG in city...

Quote:
Originally Posted by Jarek5_7 View Post
5.8~6 MPG in city, below ~40mph. I checked o2 sensors, one was bad, voltage was steady, but after clearing connector it showed good results (scanned on computer by a mechanic). before it consumption was around 40l/100km so about 6mpg !!! after that I reset the pcm and mpg on computer and it states the same or little more??.

I have only 0499 fault which is nvld fault. can it be a problem?
car has power, and runs smooth.

where to look, any ideas?
NVLD is the gas tank emissions system. Do not "overfill" your gas tank because there is a check valve for vapors to flow into the system, etc, etc, and will throw these codes if liquid goes through. I had a valve in the system go bad (under warranty) and mileage was definitely down at the time.

Not sure if the DTC can directly affect mileage, but disconnect negative battery cable push brake pedal to discharge voltage. It will reset adaptives and any codes.

Check 1 thing also: On the driver's side, near the power distrib. centers, there is a solenoid that sticks up. It vents gas tank vapors into the intake manifold. Make sure the discharge side is actually connected to your manifold. They sometimes get knocked off. That might also cause a DTC, not to mention a free passage of air directly into your intake manifold, bypassing the throttle body butterfly valve.
__________________
'08 WK Limited, 5.7L HEMI, Quadra-Trac II, Bright Silver Metallic, Class IV Hitch, Michelin LTX M/S tires, Billet Technology oil catch can, Fumoto oil drain valve.
Reply With Quote
  #11  
Old 07-10-2012, 02:49 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

solenoid under the hood is connected and intake doesnt draw air from loose hoose etc.

I followed instructions from service manual regarding code 499 it turned out to "replace nvld assembly". when I bought the car it was very hard to fill tank with fuel, now its ok because I removed nvld pump and poured out some water. I presume someone overfilled it and some gas stayed in hoose but it evaporated and only yellowish odorless fluid left in that hoose.

nvld pump needs replacing, its rusted inside.
__________________
Reply With Quote
  #12  
Old 07-10-2012, 10:09 AM
Member
 
Join Date: Mar 2012
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 936
Jarek5_7 is on a distinguished road
Re: 5.8~6 MPG in city...

I dont know if nvld pump can cause that poor milage...


also after fixing o2 sensor connection msd started to work and I dont like it

I think its msd, because at low rpm, for example 30mph 1500 rpm it kicks in rpm rises , after second or two msd turns off. sometimes when cruising in the city for exmaple 40mph and slitly pressing accelerator it hesitetes for a second and them accelerate rapidly, too rapidly for this slight pedal pressing.

no codes expet P0499..
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Laredo V6 4x2 MPG city millerkid095 Grand Cherokee - WK 12 08-09-2013 02:05 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community