Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-07-2013, 01:01 PM
Member
 
Join Date: Dec 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 657
Aferalhamster is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Quote:
Originally Posted by Madanio24 View Post
Falty wheel speed sensor
why would a wheel speed sensor cause the brake to lock up? would that cause the 4 wheel drive system warning too?
__________________

__________________
Reply With Quote
  #14  
Old 03-07-2013, 01:23 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276903
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Quote:
Originally Posted by Aferalhamster View Post
why would a wheel speed sensor cause the brake to lock up? would that cause the 4 wheel drive system warning too?

The computer uses the wheel speed sensors as part of the ABS and traction control system.

A faulty wheel speed sensor could send information that tricks the computer into thinking that the wheel is spinning at a different rate than the rest, causing the brakes to be applied in an attempt to get the sensor reading to equal the other three.

As to the 4WD warning I'm not so sure. I suppose it could, but I do not know which systems feed in information to set that light.
__________________

__________________
Reply With Quote
  #15  
Old 03-07-2013, 05:42 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,951
Thanks: 22
Thanked 29 Times in 28 Posts
Rep Power: 11320
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Plug in code reader. mine was doiung the exact same thing. faulty rear right speed sensor. fixed everything.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #16  
Old 03-07-2013, 10:30 PM
Member
 
Join Date: Dec 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 657
Aferalhamster is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

thank you. I ordered the part. Picking it up tomorrow. Hopefully it all works out.
__________________
Reply With Quote
  #17  
Old 03-08-2013, 10:22 PM
Member
 
Join Date: Dec 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 657
Aferalhamster is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

fixed. thank you all.
__________________
Reply With Quote
  #18  
Old 03-18-2013, 06:46 AM
Rexie1983's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2013
Location: Pretoria
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 574
Rexie1983 is on a distinguished road
Garage
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Good day all

Im brand new in this forum and really need your help.

I have a grand cherokee 5.7 Limited. I drove to bethal this weekend and some issues occurs. The " service electric break system " and " service 4WD system " popped up when i drove over a speed bump. The next service due in 7800km... Can anyone help me please in what i should do? Thanks.
__________________
Reply With Quote
  #19  
Old 03-20-2013, 12:52 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,951
Thanks: 22
Thanked 29 Times in 28 Posts
Rep Power: 11320
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Speed sensor.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #20  
Old 03-20-2013, 05:41 AM
Rexie1983's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Mar 2013
Location: Pretoria
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 574
Rexie1983 is on a distinguished road
Garage
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

thanks. they said it was a wheel sensor that touched the wheel
__________________
Reply With Quote
  #21  
Old 07-09-2013, 06:53 PM
New Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
greywulf4570 is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

checked into the Forum with the right side wheel speed sensors OBDII fault code... replaced the RHS front and rear wheel speed sensors... simple simon... fixed all the weird problems that was causing my lovely brides eyeballs to whenever she drove the car... Lights came on again today... OBDII says U1417 go figure... now its the LHS ... my bet is on the rear LHS...

hey to everyone in the forum... this diagnostic stuff is fun eh?
__________________
Reply With Quote
  #22  
Old 08-10-2013, 04:21 PM
Member
 
Join Date: Aug 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 413
laskowsa is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

I've got the same issues with the 4WD/ABS/ELEC Service light coming up....now the latest is the cruise control is acting up. YES YES I can hear it now "It's the speed sensor"

I don't own a OBDII reader cuz I've been using the key trick ON OFF method but I'm not pulling any faulty codes to determine what side the speed sensor is on? Any HELP?
__________________
Reply With Quote
  #23  
Old 08-10-2013, 05:02 PM
New Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
greywulf4570 is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

the fault OBDII fault code I had was U1417 indicating Driver side...so it was the rear sensor of the two. BUT... after I replaced it the "service 4WD" message became intermittent... it shows with no OBDII fault codes at all...all other warning lights and messages went away...every other time the car is started the warning does not show up for any driving period. I am thinking after cleaning the contacts on the sensor plug ... that the TCM needs to be reset..by disconnecting the battery so the system might reset...
__________________
Reply With Quote
  #24  
Old 08-19-2013, 02:01 AM
NoRice's Avatar
Member
 
Join Date: Aug 2013
Posts: 81
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 491
NoRice is on a distinguished road
Re: ABS light and "Service Elec Brake System" and gas mileage gone to 6mpg

Quote:
Originally Posted by Madanio24 View Post
Speed sensor.
Lol scrolling thru this post was hilarious. If they would have looked back they would have gotten their answer. New question for you tho as I have the same issue with the ABS and traction control. Where can I go to see which sensor needs replaced? Does Autozone do this?
__________________

__________________

College Student, 2005 Silver WK, 4.7L V8, Dipped Wheels, Matched Factory Tint, Flowmaster Muffler, ACTUAL Mods soon to come.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check elec brake system message and traction control and abs light on kycoolcat Troubleshooting/Problems 16 04-28-2014 01:49 PM
Abs light, service brake system and 4wd system chaase68 Troubleshooting/Problems 15 08-09-2012 05:49 AM
check elec brake system message? please help! kycoolcat Troubleshooting/Problems 2 07-03-2012 09:44 AM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM
Engine Light - "Not" Recording Mileage? GCL06 Grand Cherokee - WK 4 03-30-2010 09:06 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community