At a loss with the stalling, 2007 4.7 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-17-2016, 12:03 PM
paroxysym's Avatar
Senior Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 1,101
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 11431
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
At a loss with the stalling, 2007 4.7

so for the past few months I have been fighting a random stall... by random I mean sitting in a drive thru she will stall, doing 65mph she will just stall, cruising at a 20 or lower she will stall. not its not back to back ill go 3-4 days without any issue and then she will randomly stall. at one point I did get an idle issue DTC and a ASD related DTC but I addressed those and all has been well... so far I have replaced the following:

crank sensor (mopar)
camshaft sensor (mopar)
IAC valve (BWD, mopar unit took a dump within a few weeks)
coil packs (bosch)
spark plugs (OEM champions)
MAP sensor (mopar)
TPS (mopar)
EGR valve (mopar)
PCV valve (mopar)
line running from manifold to PCV(was dry rotted and causing a vac leak)
Remand'd PCM (also had it flashed with most up to date software)
throttle body (mopar)
throttle body gasket (mopar)

yes ive tried a lot and shes gotten better and better, and shes running great except for the damn stalling. she had a high idle for the longest time and she has since leveled out and is great.

any other thoughts? tranny fluid level is fine, changed 10k ago. battery was replaced a year ago with an autocraft AGM. she has 173k on her so im just wondering what else im missing. shes throwing NO CODES when she randomly shuts off. I did have the ignition replaced under the recall as well.

thoughts? ideas? opinions?

__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-17-2016, 09:30 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,561
Thanks: 23
Thanked 411 Times in 396 Posts
Rep Power: 529847
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: At a loss with the stalling, 2007 4.7

Does it always start immediately after it has stalled?Did you change or swap the ASD relay? All wiring checked for continuity while wiggling the bundle?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 10-17-2016, 10:23 PM
MoparFreak's Avatar
Member
 
Join Date: Oct 2016
Posts: 14
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 237
MoparFreak is on a distinguished road
Re: At a loss with the stalling, 2007 4.7

I'm having the same issue with mine. Replaced the crank sensor and cam sensor. Still stalling, and also will jerk during acceleration. My dodge ram had the same issue years ago. I found out that when replacing engine control sensors to use OEM. For whatever reason the aftermarket parts just don't work as far as communicating with the PCM. I bought a local parts store Crankshaft sensor for my truck and it ran worse than before, so I bought OE and haven't had an issue since. Looks like I will suffer the same expensive fate with the jeep as well.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-18-2016, 06:08 AM
paroxysym's Avatar
Senior Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 1,101
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 11431
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: At a loss with the stalling, 2007 4.7

Quote:
Originally Posted by Frango100 View Post
Does it always start immediately after it has stalled?Did you change or swap the ASD relay? All wiring checked for continuity while wiggling the bundle?
I did replace the ASD relay for shits and giggles when I replaced the throttle body this weekend.

yes it starts right back up no issues- for instance it shut down doing 70mph this AM, I coasted over to the shoulder and threw it in park. turned it off and it turns right back on. my lights stay on and everything, the engine just dies.

ive been reading it MAY be the battery cables? I did notice some corrosion around the neg battery post a couple weeks ago, cleaned it up and threw the cable back on it. im at a loss, cause ive replaced everything I can think of lol.

as for sensor brands, I went back and updated the OP.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #5  
Old 11-03-2016, 03:01 PM
paroxysym's Avatar
Senior Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 1,101
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 11431
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: At a loss with the stalling, 2007 4.7

bump..


ive narrowed this down to an electrical issue for sure. I was under the impression it was my ignition switch- but when it stalls/dies on the highway I lose power, all lights stay on, etc. im considering doing the foil wrap on my harness and PCM wires. I also plan on removing the battery tomorrow and checking under there to see if anythings busted. also picked up new plugs from the dealer, they look different than the ones I ordered online from summit- they have black tips. so I plan on checking those too.


ive stopped thinking its my throttle body, as I switched back to my fastman and there was no change in anything still stalled. stalled more with the OEM one.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #6  
Old 11-12-2016, 06:05 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Nov 2016
Location: IDAHO
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 203
JGCWK is on a distinguished road
Re: At a loss with the stalling, 2007 4.7

I would toss the Bosch Coils too get mopar. They aren't super cheap but I ran Bosch on my 2005 4.7 and I wouldn't stall like you but had stalling from drive to park occasionally. Switched to mopar and was good.
Reply With Quote
Reply

Tags
2007

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Grand Cherokee stalling while driving tonyee Troubleshooting/Problems 6 06-14-2015 11:45 AM
Stalling Issue - 2007 Hemi WK 07GrandCherokee Troubleshooting/Problems 1 10-13-2011 01:32 AM
MDS Disable = 2mpg loss bluethunderjeep Grand Cherokee - WK 25 06-27-2010 01:43 AM
Loss of coolant n8jay Grand Cherokee - WK 3 05-18-2010 11:08 PM
Loss in MGP after new plugs Kaliber35 Grand Cherokee - WK 4 03-15-2010 11:29 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.