Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-20-2011, 12:25 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Nov 2011
Location: Virginia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
heatherlstevenson@hotmail is on a distinguished road
Audio system has no power

I just purchased a 2008 jeep grand cherokee laredo and the factory radio/cd/sirius will not turn on....replaced fuse in fuse panel and still nothing .....any ideas on what the problem could be and what to do to fix it?
__________________

__________________
Reply With Quote
  #2  
Old 11-20-2011, 12:35 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,381
Thanks: 875
Thanked 1,046 Times in 721 Posts
Rep Power: 7718298
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Audio system has no power

fuse #12 under the dash?
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 11-20-2011, 09:45 AM
TurboDiesel's Avatar
Senior Member
My Jeep: 2008 3.0L WK
 
Join Date: May 2011
Location: Vancouver, BC
Posts: 1,240
Thanks: 3
Thanked 9 Times in 9 Posts
Rep Power: 103852
TurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond reputeTurboDiesel has a reputation beyond repute
Re: Audio system has no power

There's another fuse box under the dash?? I didn't know that lol
__________________
Reply With Quote
  #4  
Old 11-20-2011, 09:48 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,387
Thanks: 491
Thanked 75 Times in 72 Posts
Rep Power: 469854
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Audio system has no power

Yeah and it's a bitch to get to. Long needle nose pliers will be needed to get to some of them.

Edit: Unless Scott has some "magical" way to pull and replace them.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #5  
Old 11-20-2011, 12:08 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,381
Thanks: 875
Thanked 1,046 Times in 721 Posts
Rep Power: 7718298
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Audio system has no power

LOL....nope....thats it
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #6  
Old 11-20-2011, 12:52 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,387
Thanks: 491
Thanked 75 Times in 72 Posts
Rep Power: 469854
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Audio system has no power

Quote:
Originally Posted by Scottina06 View Post
LOL....nope....thats it
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #7  
Old 11-28-2011, 09:44 PM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Nov 2011
Location: Virginia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
heatherlstevenson@hotmail is on a distinguished road
Re: Audio system has no power

Pulled Fuse # 12....and it seemed fine...didnt replace it.....previously replaced the radio fuse (according to owners manual) and still the factory system which consists of the CD/MP3/Sirius and no navigation will not turn on/light up/anything.....what else could it be?
__________________
Reply With Quote
  #8  
Old 11-28-2011, 10:05 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,387
Thanks: 491
Thanked 75 Times in 72 Posts
Rep Power: 469854
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Audio system has no power

It's probably fried if the fuses are good.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #9  
Old 11-28-2011, 10:15 PM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27966
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Audio system has no power

Yeah it might be fried, pull it out and make sure everything is connected properly
__________________
"When my time on earth is gone, and my activities here are passed, I want they bury me upside down, and my critics can kiss my ass!"

- Bobby Knight
Reply With Quote
  #10  
Old 11-28-2011, 10:18 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,387
Thanks: 491
Thanked 75 Times in 72 Posts
Rep Power: 469854
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Audio system has no power

Sorry to hear that. I hope it's not fried.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #11  
Old 11-28-2011, 10:43 PM
Galaxie500's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Jan 2011
Location: SF Bay Area
Posts: 266
Thanks: 60
Thanked 1 Time in 1 Post
Rep Power: 8293
Galaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond repute
Re: Audio system has no power

Quote:
Originally Posted by heatherlstevenson@hotmail View Post
Pulled Fuse # 12....and it seemed fine...didnt replace it.....previously replaced the radio fuse (according to owners manual) and still the factory system which consists of the CD/MP3/Sirius and no navigation will not turn on/light up/anything.....what else could it be?
Did you Ohm out the fuse to check it?
__________________
Stock Baby! Kicker Sub Dual 10's
Reply With Quote
  #12  
Old 11-28-2011, 11:27 PM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Nov 2011
Location: Virginia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
heatherlstevenson@hotmail is on a distinguished road
Re: Audio system has no power

Did not Ohm it out...just pulled it and looked to see if it was in 1 pc or not.....what would I have to do to Ohm it? Or should I just go ahead and replace the fuse anyway?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine Premium Factory Audio System gostan4484 Audio/Visual/Navigation 63 02-12-2012 09:24 AM
SRT Harman Kardon premium audio system Milous Audio/Video/Navigation/Alarms 11 07-11-2011 06:52 PM
Instructions on removing the audio system rfarb Trouble Shooting/Problems/Service 3 07-01-2011 06:04 PM
2011 WK: Premium audio system Milous Trouble Shooting/Problems/Service 9 09-20-2010 05:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.