Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-27-2012, 11:25 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Auto Locks Not Working....

My auto locks aren't working. I noticed after I installed the billet door locks and bezels.

Locks still work with the key fob but they do not automatically lock when I hit that certain mph.

Anybody know of a solution?
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #2  
Old 02-27-2012, 11:30 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Auto Locks Not Working....

Maybe a calibration is needed.....? Which I do not know how to do if that's possible.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #3  
Old 02-27-2012, 11:34 AM
08Hemi's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,290
Thanks: 0
Thanked 25 Times in 30 Posts
Rep Power: 330260
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Re: Auto Locks Not Working....

your jeep is getting some gremlins...mine had them two years back...idk how to calibrate, but have you tried a negitive battery terminal reset with brake pump? that is always my first shot. I enabled my auto locks when I put the new pins/bezels in, I did not have them active before.
__________________
Reply With Quote
  #4  
Old 02-27-2012, 11:47 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Auto Locks Not Working....

I did a reset when I put my shifter module back in.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #5  
Old 02-27-2012, 11:56 AM
Geevis's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Apr 2010
Location: CT
Posts: 532
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1998
Geevis is a jewel in the rough
Re: Auto Locks Not Working....

hmmm.. I don't think my door locks ever automatically lock.. I always have to click the button to lock all doors. I'll have to test it out tonight to see if mine lock at a certain speed.

Not really sure what the issue would be if they open and close correctly using the key fob, so you know it's not a clearance problem. Has to be an electrical issue.
__________________

2006 Jeep Grand Cherokee 3.7l V6 - Sold
Reply With Quote
  #6  
Old 02-27-2012, 11:57 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,315
Thanks: 43
Thanked 126 Times in 108 Posts
Rep Power: 542376
robpp has disabled reputation
Re: Auto Locks Not Working....

do you have a tune?

mine DO lock at i think its 15 MPH automatically


i have the JR locks and never had a problem.
__________________
Reply With Quote
The Following User Says Thank You to robpp For This Useful Post:
  #7  
Old 02-27-2012, 12:14 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Auto Locks Not Working....

I do have a tune but they worked after the tune. I noticed they stopped working after the billet bezels and pins were installed.

I did have to put some torque on the rods to get the plastic door locks off but I was still careful.

And I did have a spare cluster installed for a while but they still worked after that was installed. I thought they would start working again after putting my cluster back in but they don't.

And the PCM has been reset a few times already.

I've searched and can't find anything on this topic.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #8  
Old 02-27-2012, 12:21 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Auto Locks Not Working....

I think you might be on to something Rob. I called a dealer and he said it needs to be reflashed. I have the stock tune, which is the latest tune, saved on my SCT Tuner. A little later, I am going to put the stock tune in an retune it to 93 again.

Thanks Rob.

The guy on the phone said he's had one do that before but that could be a bunch of .
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #9  
Old 02-27-2012, 12:23 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,315
Thanks: 43
Thanked 126 Times in 108 Posts
Rep Power: 542376
robpp has disabled reputation
Re: Auto Locks Not Working....

yup. untune. reflash. retune. GL
__________________
Reply With Quote
The Following User Says Thank You to robpp For This Useful Post:
  #10  
Old 02-27-2012, 03:45 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Auto Locks Not Working....

Untuned, reflashed, retuned.......problem solved.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto headlights not working gc4x4 Grand Cherokee - WK 10 11-01-2011 05:26 PM
05 Laredo PW not working, locks do! Kaliber35 Grand Cherokee - WK 1 07-28-2011 01:51 PM
Auto Door Locks mandm1 Grand Cherokee - WK2 - 20 05-26-2011 05:42 AM
Shutting off Auto Door Locks pop88 Trouble Shooting/Problems/Service 9 04-12-2011 01:15 PM
All power windows and locks quit working Luke Troubleshooting/Problems 3 12-06-2010 06:06 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community