CAI Running car rich? - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-24-2016, 10:38 AM
Kregsxd's Avatar
Member
 
Join Date: Feb 2016
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 362
Kregsxd is on a distinguished road
Garage
CAI Running car rich?

Does someone know why my cold air intake is making my car run rich? Made a custom pvc pipe it's decent no leaks or anything might be bad o2 sensor?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-24-2016, 01:26 PM
08Hemi's Avatar
Senior Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,959
Thanks: 140
Thanked 164 Times in 140 Posts
Rep Power: 368916
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Garage
Re: CAI Running car rich?

Try a hard reset...disconnect the (-) terminal and step on the brake pedal 2-3 times...wait 20 minutes then reconnect. Sometimes that can help the ECU "learn" the new air flow...had to do this on my 08' WK 5.7L when I installed the 4" BWoody intake. Worth a shot!
__________________


2014 WK2 SRT aka "Jack" aFe Pro Dry-S, Corsa Cat-back, BT Goodies, Full LED's, Tint and mostly blacked-out
2008 WK 5.7L Limited aka "Jill" (Sold)
Reply With Quote
Reply

Tags
cai

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1/2 O2 sensor slow response lean to rich Relwarc Troubleshooting/Problems Discussion 6 01-28-2015 08:33 PM
Mopar cai vs k&n cai dom1220 Engine Performance/Intakes/Exhausts 2 10-21-2014 10:42 PM
So I left my car running today for 4 hours. navger Trouble Shooting/Problems/Service 39 07-11-2012 12:02 AM
HELP! P2097 - Downstream Fuel Trim System 1 Rich yshoef Trouble Shooting/Problems/Service 4 06-29-2012 01:36 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.