Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-25-2013, 07:20 AM
Member
 
Join Date: Oct 2012
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 664
chance_p is on a distinguished road
cruise control doesn't set

Hey guys I just picked up a heavily optioned 08 laredo with the 4.7 a couple of days ago. My cruise control quit working about an hour into my 6 hour drive home. Yesterday I pulled and cleared the codes on the Jeep and it instantly started working again. Last night it quit working again. Both times the cruise will still turn on, but not set.

Codes pulled were P0457, p2299, p0884n, c2100.

CHECK GASCAP is on, knew about it before I went to purchase and I know the p0457 is in relation to that.

I didnt have a CEL until yesterday morning when I first started the jeep, which is what triggered me go pull/clear the codes. Since the cruise quit working again im going to read the codes again today.

Anyone have any ideas as to what would cause my issue? Im aware I need to get rid of the evap issue to help with troubleshooting these codes, but I was hoping someone would have a good starting point for me. I found nothing while searching for issues in regards to cruise turning on but not setting.
__________________

__________________
Reply With Quote
  #2  
Old 10-25-2013, 05:15 PM
Member
 
Join Date: Oct 2012
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 664
chance_p is on a distinguished road
Re: cruise control doesn't set

Check codes, didnt have any. New gas cap didnt fix my checkgascap so im ordering an esim switch. I cleared the codes even though the scanner said there werent any. Cruise instantly works again. Any ideas guys?
__________________

__________________
Reply With Quote
  #3  
Old 11-02-2013, 11:59 PM
Member
 
Join Date: Oct 2012
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 664
chance_p is on a distinguished road
Re: cruise control doesn't set

Alright guys, incase anyone stumbles across this in a search. Hooked the jeep up to a snapon computer to try and fix my 0457 issue. Ran a purge evap test, about a minute on the test check gascap went away, cleared the code. Everything is fixed. Im assuming my purge solenoid was stuck and the test pressurized it longer than normal vehicle diagnostics which unstuck it. Thats all I can think of that would make sense. Zero cruise issues after this also. Does the cruise in these operate off vacuum?
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
speedometer cruise control doesn’t aparra84 Troubleshooting/Problems Discussion 0 07-29-2013 08:54 PM
cruise control dippinsoldier92 Troubleshooting/Problems 0 05-28-2013 01:12 PM
Cruise control Armstrong437 Trouble Shooting/Problems/Service 1 09-27-2012 02:11 AM
cruise control windycityjeep Trouble Shooting/Problems/Service 7 02-26-2012 12:14 PM
Air Doesn't Turn on When Set to AUTO bmrisko Trouble Shooting/Problems/Service 6 01-18-2012 02:22 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community