Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-16-2014, 11:10 AM
New Member
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
pappi352 is on a distinguished road
Question Current GC owner with Electronic issues

Hey guy's, I am in need of help. First time ever posting. I have an ABS/Traction control issue. 005 Jeep Grand Cherokee 5.7 Hemi. Changed both front wheel sensors and rewired broken conection on drivers side. Yes I triple checked to make sure I had correct wire to each pin. Ordered Brake Light Switch and plan on putting that in today. Lights still on and front wheel grabs for a split seond when going forward till audible chime goes of then truck rolls freely. ANY IDEAS PLEASE, this is killing me.
Thanks
__________________

__________________
Reply With Quote
  #2  
Old 04-16-2014, 03:17 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,649
Thanks: 41
Thanked 97 Times in 90 Posts
Rep Power: 44186
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Current GC owner with Electronic issues

Quote:
Originally Posted by pappi352 View Post
Hey guy's, I am in need of help. First time ever posting. I have an ABS/Traction control issue. 005 Jeep Grand Cherokee 5.7 Hemi. Changed both front wheel sensors and rewired broken conection on drivers side. Yes I triple checked to make sure I had correct wire to each pin. Ordered Brake Light Switch and plan on putting that in today. Lights still on and front wheel grabs for a split seond when going forward till audible chime goes of then truck rolls freely. ANY IDEAS PLEASE, this is killing me.
Thanks
Offhand, this sounds more like a controller issue...
However, does the 05 still have the problem with crud/corrosion on an ABS connector on the passenger front fender as it passes out of the engine compartment?
[don't have an FSM]
The older ZJ used to get crud in there from having fun in creeks, snow, and mud, and the fix was to carefully remove the connector and clean both sides with something that is NOT a rubber eraser [sulfur just recruds if you don't get it all off] and then reseat it.

Got a scan tool that can pull fault codes?
Three on/off/on cycle pull anything?
__________________

__________________
Reply With Quote
  #3  
Old 04-16-2014, 03:37 PM
New Member
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
pappi352 is on a distinguished road
Re: Current GC owner with Electronic issues

hey thaks for the reply. yup pulled 3 codes c100a driverside sensor c1015 pass sensor & just saw p0571 which was the brake light switch. Changed that today going to hit Advanced and use there reader and see if it clears this up. Didnt notice the connector you were talking about my abs mod is on drivers side behind battery
__________________
Reply With Quote
  #4  
Old 04-16-2014, 05:29 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,649
Thanks: 41
Thanked 97 Times in 90 Posts
Rep Power: 44186
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Current GC owner with Electronic issues

The connector I mentioned is one that goes thru the fender near the front passenger side. Yours is a newer vehicle than the ZJ and might not have one, since those were infamous for crudding up while having fun.

The tone rings need to come thru to the ABS controller from somewhere...
C100A is the left wheel speed sensor, which is not the same as C1014 which would be the abs sensor. I'd suggest checking that out first... but unfortunately I don't have a good diagram, so hopefully someone with one or has troubleshot your year will chime in.
__________________
Reply With Quote
  #5  
Old 04-17-2014, 10:53 AM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: PA
Posts: 4,535
Thanks: 38
Thanked 55 Times in 54 Posts
Rep Power: 408285
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Current GC owner with Electronic issues

Welcome to the JG!!
__________________
2001 Silverstone Metallic WJ Limited
2005 Black Chevy Tahoe Z71
Reply With Quote
  #6  
Old 04-17-2014, 11:12 AM
New Member
 
Join Date: Apr 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
pappi352 is on a distinguished road
Re: Current GC owner with Electronic issues

ok thank you for all your hlp will keep digging, eventually i will find it before the cost hits $2000.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Current Issues: TheStreet16 Troubleshooting/Problems 35 01-15-2013 10:08 PM
current bmw owner, new to jeep - questions aquaanox Grand Cherokee - WK2 - 11 06-14-2011 10:57 PM
Calling all current/past durango 5.9 owners!!! 08Hemi Other Rides 4 06-21-2010 04:59 PM
Current pics of my Jeep ekaz Members Rides 20 03-04-2010 02:50 PM
Question about my current set up LTrainGC Audio, Video, Navigation & Electronic Modifications 8 02-25-2010 08:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.