Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-04-2013, 03:39 AM
New Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Ide.Tyler is on a distinguished road
Dealer couldn't solve my electrical Issues.

Okay, So here goes.

I have a 2007 Grand Cherokee 4.7L V8 Flex Quadra-Drive II etc.

My brake lights illuminate when the key turns on in the ignition circuit. (All 3.. Both right & left as will as the high mount stop light) So it looks like I'm pressing on my brakes where ever I go. I took it to the dealer for a diagnosis and they have no idea what the problem is. They removed all of the fuses that control the brake light circuit, all of the relays, etc. Tested everything, followed the wires, but still nothing. Idk if the BCM is outputting an ignition source to the brake lights but my ESP and BAS lights illuminate after I drive for a few minutes (assuming because the car thinks that the brake is being held at 80 mph for long periods of time? Idk. The EVIC displays service 4WD System constantly. Not throwing any engine codes..

Another weird fact is that if I hold the brake pedal and turn off the vehicle, everything shuts down electronically, except the engine continues to run (Like a remote start) AS soon as I let off the brake pedal, it shuts down. If I press the brakes with the vehicle off, I can hear the pedal energizing some circuit underneath the hood.

I have removed the brake switch to no avail.
I'm at a loss.

The vehicle is completely stock with no aftermarket accessories of any kind.

Thank you!
__________________

__________________
Reply With Quote
  #2  
Old 03-04-2013, 05:08 AM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: Dealer couldn't solve my electrical Issues.

well this is a real longshot but i just read something about disconnecting the battery for like half an hour clearing up alot of electrical issues

heres where i read it: The Famous Jeep Grand Cherokee Electrical Problem - CNET Car Tech Forums

maybe look around real good under the hood and make sure none of the wires are touching the exhaust anywhere
__________________

__________________
Reply With Quote
  #3  
Old 03-04-2013, 10:00 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276905
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Dealer couldn't solve my electrical Issues.

Quote:
Originally Posted by Ide.Tyler View Post

Another weird fact is that if I hold the brake pedal and turn off the vehicle, everything shuts down electronically, except the engine continues to run (Like a remote start) AS soon as I let off the brake pedal, it shuts down. If I press the brakes with the vehicle off, I can hear the pedal energizing some circuit underneath the hood.
This pretty much troubleshoots it for you. Your brake switch and ignition "on" are shorted to one another. When the car is running it is sending voltage to the brake lights. If you shut the car off, and hold the brakes, the brakes are sending a voltage to the run circuit.

There are only so many places these wires could cross like this. It may be a bit of work, but you should certainly be able to get this fixed. Did you tell the dealership about the car running for as long as you hold the brakes down? If you did, and they are still pulling relays, etc., I would take it to a different place...
__________________
Reply With Quote
  #4  
Old 03-04-2013, 02:02 PM
New Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Ide.Tyler is on a distinguished road
Re: Dealer couldn't solve my electrical Issues.

Quote:
Originally Posted by dr.lee.baugh View Post
This pretty much troubleshoots it for you. Your brake switch and ignition "on" are shorted to one another. When the car is running it is sending voltage to the brake lights. If you shut the car off, and hold the brakes, the brakes are sending a voltage to the run circuit.

There are only so many places these wires could cross like this. It may be a bit of work, but you should certainly be able to get this fixed. Did you tell the dealership about the car running for as long as you hold the brakes down? If you did, and they are still pulling relays, etc., I would take it to a different place...
I figured it out after I went to the dealership. I was thinking the same thing but I don't know where to look. The brake circuit is simple but I'm thinking something tripped in the bcm and it is outputting an ignition source to the brake lights. I tried disconnecting the battefy to no avail. This is frustrating stuff.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Issues 98ZJ-Man Grand Cherokee - ZJ 0 05-08-2012 10:35 PM
electrical issues 97jeepcherokee Troubleshooting/Problems Discussion 1 02-23-2012 12:51 AM
Electrical issues tri0829 Troubleshooting/Problems 1 01-23-2012 12:11 PM
Electrical issues wkthursty Grand Cherokee - WK 4 04-11-2011 09:50 AM
electrical issues... smack82 Troubleshooting/Problems Discussion 6 01-21-2010 01:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community