Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-27-2012, 11:06 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2012
Location: Alberta Canada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 856
05rockymountain is on a distinguished road
05 elusive miss/stumble/hesitation,no damn codes

on my 05 wk,4.7 I am getting the elusive hesitation/stumble/on light throttle pressure when cruising at speeds under 80 km/hr.seems like slight ign miss ,with constant throttle it seems to have a slight surge up and down at lower speeds below 90,also exhibits an intermittent high idle (700-750 rpm compared to usual 500-550 rpm)and also sometimes at normal idle it is slightly rough(can feel slight shake in veh)other times its smooth as silk,with hvac on or off eliminating compressor load,today i exhibited another symptom on startup cold,i started jeep ,it died when i went into gear ,then it cranked over 3 times as long to start,after starting it went to 700-800 rpm and wouldnt come down for a few minutes(temp 10 celcius,seems to be getting progressively worse ,a few times at 80 k when taking foot of gas it bucked a bit almost like torque converter clutch not disengaging)i can also hear a hiss by egr valve,not quite a vac leak hiss ,more like air rushing noise.at speeds 100 km/hr plus ,it seems perfect. i have replaced plugs,cleaned iac and port,killed all the mosquitos in my neihborhood with seafoam,lol,cleaned tbody,ran seafoam through fuel tank and oil,tried different grades of fuel,replaced tps,i have an obd II scanner and no codes are present and i have never seen a "check engine" light come on ,it seems like a possible egr concern in my guess from symptoms but it in my view should set codes as dpf sensor monitors this,has anyone had egr failure with similar symptoms with no codes?,i have not had software updates yet but jeep has 140000 km on it ,if software was needed i would think it would have had issue before now
I may just go to steeler tomorrow and get updates done ,but I still am guessing egr leak /sticking open.sorry for the long post but the more details the better in this problem,any ideas from the wk brotherhood?
__________________

__________________
Reply With Quote
  #2  
Old 04-28-2012, 10:12 AM
Premium Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2010
Location: Baltimore, MD
Posts: 431
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 2017
swing4terps is on a distinguished road
Re: egr failing with no codes?

It's definitely possible to have EGR problems and no codes. I was having the rough idle and stall out issues and replaced my EGR ($35 from Advance, 40 minutes of my time) and my idle has greatly improved and I have seldom stalled out since. I used to stall out about once every other day. Since installing the new EGR I've stalled out twice in 8 months. Only other thing I changed was the PCV and I don't think that contributed to the improvement. At no point in time did I have EGR failure codes.

The part is cheap and easy to install, just go grab one. If for nothing else you can eliminate it as the culprit.

There is also a TSB regarding surging you may want to check out.

http://www.wkjeeps.com/tsb/tsb_wk_1801810.pdf
__________________

__________________
Reply With Quote
  #3  
Old 04-28-2012, 11:43 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2012
Location: Alberta Canada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 856
05rockymountain is on a distinguished road
Re: egr failing with no codes?

thanks for the reply Swing4terps ,after my post i was also thinking that the egr appears to have a position sensor so if it is leaking that could still give symptoms with no codes ,does anyone know if it is just a position sensor?or is there a pressure sensor?(dpfe?),I also may have stumbled on the problem,when I ran seafoam through the brake booster vac line I noticed some of the white smoke coming out around the egr vavle area,not exactly sure where from but noticable amount ,so maybe it is leaking or the gaskets pooched,either way ,goin to get a new "standard" brand egr valve for 95.00 cdn ,could order from rock auto but I dont have time ,also thanks for the tsb reference ,I booked it in next sat to steeler,when I gave them the tsb number i heard a sigh ,I spent 14 yrs with GM as a fleet service mgr so I know they hate guys like me that know something. i will repost on how everything goes on egr valve replacement after I get my knuckles bandaged and stop the bleeding ,hope the ratchet wrenches and air ratchet works ,thanks to those with the postings for replacement procedures and tips ,I am lovin this forum ,i think i need the tsb as well ,it seems to go into lockup too early 2,any more ideas or similar experiences by other wk owners?
__________________
Reply With Quote
  #4  
Old 04-28-2012, 04:57 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2012
Location: Alberta Canada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 856
05rockymountain is on a distinguished road
Re: egr failing with no codes?

well,replaced the egr with a new one ,main gasket was in rough shape,wasnt too bad to change with 1/4 inch ratchet and a combination of extensions and deep and shallow sockets ,all in all about an hr ,worst part is cleaning the old gasket material off,roadtested for 1/2 hr from cold to normal operating temp and runs very good so far,all of the symptoms seem to be gone now ,but time will tell,looked like the original egr at 140000km,so i shouldnt complain.i will update this post after i log some more mileage on to see if it all works good
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
egr valve failure with no codes? 05rockymountain Technical Tips/DIY/How-To 11 05-25-2012 04:46 PM
Suspension component failing? Crestwood1001 Suspension/Brakes/Wheels/Tires 4 09-05-2011 05:30 PM
BMW X5, Failing Megatron Other Rides 9 07-29-2010 05:20 PM
Help LED's are failing White WK Swagga Audio, Video, Navigation & Electronic Modifications 31 04-07-2010 05:28 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community