Electrical problems - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-14-2016, 12:26 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2014
Location: Colorado
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
dvero1727 is on a distinguished road
Electrical problems

Hello everyone!
I have a 2007 Grand Cherokee Laredo with the 3.7L and Iv'e been having some really weird electrical problems going on. I was wondering if anyone else has experienced this or has a fix for it.

This all started happening a few weeks ago, I was sitting at a stop light and all of a sudden my radio shut off for about 5 seconds and then turned back on. About 20 seconds later a few warning lights came on but it was so quick I didn't see which ones they were. I then drove a few miles down the road and as i was pulling into a parking spot my jeep completely shut off. All of the gauges were in the same spot before it turned off, and if I tried to turn the key nothing would happen. The doors would't lock, the headlights wouldn't turn on It was like there wasn't even a battery inside the car. I got out and wiggled the battery cables a little bit and the gauges dropped. then the jeep started right up and was perfectly fine.

After that day I went another week before the jeep started acting up again. this time I was driving at night time and all of a sudden the headlights would start flickering. Then the radio was doing the same thing where it would turn off and on again, but this time it did it a few times. I was close to where I was going so I parked. I was out for awhile and when I drove home everything was normal.

My alternator went out about a year ago and I replaced it as well as the battery. I know there is a recall out right now for the ignition switch which I am having the dealer fix this Thursday but I wasn't sure if that would cause all of this to happen or not.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-14-2016, 01:46 PM
Member
 
Join Date: Dec 2015
Posts: 72
Thanks: 9
Thanked 2 Times in 2 Posts
Rep Power: 427
JeepFan101 is on a distinguished road
Re: Electrical problems

Quote:
Originally Posted by dvero1727 View Post
Hello everyone!

I have a 2007 Grand Cherokee Laredo with the 3.7L and Iv'e been having some really weird electrical problems going on. I was wondering if anyone else has experienced this or has a fix for it.



This all started happening a few weeks ago, I was sitting at a stop light and all of a sudden my radio shut off for about 5 seconds and then turned back on. About 20 seconds later a few warning lights came on but it was so quick I didn't see which ones they were. I then drove a few miles down the road and as i was pulling into a parking spot my jeep completely shut off. All of the gauges were in the same spot before it turned off, and if I tried to turn the key nothing would happen. The doors would't lock, the headlights wouldn't turn on It was like there wasn't even a battery inside the car. I got out and wiggled the battery cables a little bit and the gauges dropped. then the jeep started right up and was perfectly fine.



After that day I went another week before the jeep started acting up again. this time I was driving at night time and all of a sudden the headlights would start flickering. Then the radio was doing the same thing where it would turn off and on again, but this time it did it a few times. I was close to where I was going so I parked. I was out for awhile and when I drove home everything was normal.



My alternator went out about a year ago and I replaced it as well as the battery. I know there is a recall out right now for the ignition switch which I am having the dealer fix this Thursday but I wasn't sure if that would cause all of this to happen or not.

Start with the simple stuff. If your battery terminals are corroded clean them off. If that doesn't fix it have the battery tested.
Reply With Quote
  #3  
Old 03-14-2016, 02:29 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2014
Location: Colorado
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
dvero1727 is on a distinguished road
Re: Electrical problems

Quote:
Originally Posted by JeepFan101 View Post
Start with the simple stuff. If your battery terminals are corroded clean them off. If that doesn't fix it have the battery tested.
Yeah the first thing I did was clean the terminals and posts. I brought my battery and alternator into work and both tested fine. From what I can see the Cables look in decent shape.
Reply With Quote
  #4  
Old 03-14-2016, 04:26 PM
Member
 
Join Date: Dec 2015
Posts: 72
Thanks: 9
Thanked 2 Times in 2 Posts
Rep Power: 427
JeepFan101 is on a distinguished road
Re: Electrical problems

Have you done anything recently that could've messed up the computer or possibly made it so some wires are touching.
Reply With Quote
  #5  
Old 03-14-2016, 05:27 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2014
Location: Colorado
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
dvero1727 is on a distinguished road
Re: Electrical problems

Quote:
Originally Posted by JeepFan101 View Post
Have you done anything recently that could've messed up the computer or possibly made it so some wires are touching.
Not that I know of, It has done this once about a year ago where the radio shut off and came back on. And then all the dash lights flashed real quick but nothing else happened and it was fine for over a year. The Jeep has HID bulbs and subs, But they have been in there for over 2 years. I have even installed a switch inside that I turn off and it kills the power to the amp.

On top of all this I'm only averaging 10.1 MPG. I have not been driving any different then I have in the past and yet the best iv'e ever had was 13. I should defiantly be getting more than 10 MPG!
Reply With Quote
  #6  
Old 03-14-2016, 06:17 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,350
Thanks: 254
Thanked 556 Times in 430 Posts
Rep Power: 30279
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: Electrical problems

sounds like it could be a grounding problem. as stated above make sure your battery terminals are clean and tight. also check your grounding points make sure they are tight.
Reply With Quote
  #7  
Old 03-14-2016, 08:28 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2014
Location: Colorado
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
dvero1727 is on a distinguished road
Re: Electrical problems

Do you think the ignition recall could cause any of this?
Reply With Quote
  #8  
Old 03-15-2016, 07:43 AM
Member
 
Join Date: Dec 2015
Posts: 72
Thanks: 9
Thanked 2 Times in 2 Posts
Rep Power: 427
JeepFan101 is on a distinguished road
Re: Electrical problems

Quote:
Originally Posted by dvero1727 View Post
Do you think the ignition recall could cause any of this?

I'm pretty sure the recall only had to do with the drivers knee numbing the key out of the on position while driving. Nothing to do with anything on the car itself malfunctioning.
Reply With Quote
  #9  
Old 03-15-2016, 07:43 AM
Member
 
Join Date: Dec 2015
Posts: 72
Thanks: 9
Thanked 2 Times in 2 Posts
Rep Power: 427
JeepFan101 is on a distinguished road
Re: Electrical problems

Bumping*
Reply With Quote
  #10  
Old 03-15-2016, 12:47 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Mar 2014
Location: Colorado
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
dvero1727 is on a distinguished road
Re: Electrical problems

Quote:
Originally Posted by JeepFan101 View Post
I'm pretty sure the recall only had to do with the drivers knee numbing the key out of the on position while driving. Nothing to do with anything on the car itself malfunctioning.
That's what I was thinking, I was just hoping it was as simple as that haha. Another thing its doing is, every time I start it the jeep almost sounds like its going to stall but after the RPMs dip low it goes back to normal idle. It has never actually stalled and it happens every time I start it.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Overland Electrical Problems VegasView Trouble Shooting/Problems/Service 3 05-22-2011 07:21 AM
2008 Electrical Problems? blackjeep08 Grand Cherokee - WK 2 03-11-2011 09:21 AM
2007 Grand Cherokee SRT8 electrical problems jmckenzie Trouble Shooting/Problems/Service 8 09-13-2010 10:25 AM
Electrical problems (video) DezeWJeep Troubleshooting/Problems Discussion 8 06-20-2010 06:30 PM
WK Limited Electrical Problems kyle.jg Troubleshooting/Problems Discussion 2 06-19-2010 08:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.