Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-12-2013, 06:02 PM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Mar 2011
Location: Ann Arbor, MI
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1149
BravoKilo is on a distinguished road
Front headlamp not working -- any help??

Had my front left headlamp go dead on me a week ago (2008 WK, v6). Purchased new bulbs hoping it would solve the issue, but to no avail.

Headlamps are a HID conversion and had been working great for over a year. Just noticed that one had stopped working.

Working on picking up a volt-meter to start testing connections, but was curious if anybody had any other suggestions?

Tried finding the appropriate fuses/relays at Jeep Grand Cherokee WK - Fuses, but unless I'm blind, I'm not seeing anything for low beams.

Any help??
__________________

__________________
Reply With Quote
  #2  
Old 03-13-2013, 01:00 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,749
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652814
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Front headlamp not working -- any help??

Make sure your powers and grounds are good. Realistically, you didnt say where you got the kit from so I would lean towards a cheaper establishment, 1 year for crappy ballasts is not uncommon.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 03-13-2013, 01:14 AM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Mar 2011
Location: Ann Arbor, MI
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1149
BravoKilo is on a distinguished road
Re: Front headlamp not working -- any help??

Hoping for nicer weather this weekend to get out and start checking connections and grounds. Any easy way to test if a ballast is still good or not? Simple as testing continuity from one end to the other or any specifics I should be reading on a multimeter?

I have one of the Xenon Depot kits if that matters.

Thanks for the help
__________________
Reply With Quote
  #4  
Old 03-14-2013, 01:05 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,749
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652814
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Front headlamp not working -- any help??

xenon depot are much higher quality, if you have questions with their product contact them on here via pm.

Are you using a relay harness? I have had an issue with one harness, no issues since but it actually melted the pins in the connector at the relay... The best way to test a balast is honestly with a known good. Like when one of yours worked, swapping the known good to the non working side. Contact xenon depot and see what they say, I havent dealt with them but I have only heard good things of their customer service!
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #5  
Old 03-14-2013, 10:19 PM
Member
My Jeep: 2008 3.7L WK
 
Join Date: Mar 2011
Location: Ann Arbor, MI
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1149
BravoKilo is on a distinguished road
Re: Front headlamp not working -- any help??

Was eventually thinking I might and try to contact them, but the only issue is that I bought the kit from a board member (almost exactly 2 years ago), and not direct. It was never installed by the previous owner, but still leaves me without original paperwork, and last I checked (actually PM'ed them before I purchased the kit), warranty is only good for original owner.

Figure I'll cross my fingers and still give it a shot...
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Thumbdrive into the front USB port, not working? armoredsaint Audio/Visual/Navigation 3 07-13-2012 11:08 PM
Headlamp Washer pora10 Export Grand Cherokee 2011+ 4 03-25-2012 07:21 PM
Taillights and front light not working g2damax Troubleshooting/Problems Discussion 3 07-19-2011 11:55 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community