Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-01-2012, 08:30 PM
Chas's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Jan 2012
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1021
Chas is on a distinguished road
Gauge Cluster Stopped Working

So about 30 minutes ago I was coming to a stop light and my gauge cluster lit up like a Christmas tree with every possible warning light coming on. My speedometer wouldn't work nor my revo's. The information center said "Check Gauges". The Jeep still drove but I couldn't see my revs nor my speed, radio wouldn't work nor was my key fob able to lock or unlock my Jeep. Manual doesn't give any indication and general searches so far haven't yielded anything. When I turned the Jeep off my cluster remained lit up as well as the radio dials and buttons even once the Jeep was locked and all other lights off. Almost was like the cluster froze. Disconnected the battery and let it reset and seems things are ok now. Drove it around the block for about 10 minutes with no issues. Anyone have any experience with this or ever had this happen to them? Its a 2010 with about 58,000 miles, 3.7L Laredo.
__________________

__________________
Reply With Quote
  #2  
Old 10-01-2012, 10:42 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255357
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Gauge Cluster Stopped Working

check to see if your battery is low
__________________

__________________
Reply With Quote
  #3  
Old 10-02-2012, 08:00 AM
Chas's Avatar
Member
My Jeep: 2010 3.7L WK
 
Join Date: Jan 2012
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1021
Chas is on a distinguished road
Re: Gauge Cluster Stopped Working

I'll have it checked out today, seems through more searching that the battery might be the cause. I bought it used at 40,000 miles and believe its the original battery.
__________________
Reply With Quote
  #4  
Old 10-02-2012, 01:15 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255357
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Gauge Cluster Stopped Working

definately check the battery because when the batteries in the WK start to run low they start throwing all kinds of warning lights
__________________
Reply With Quote
  #5  
Old 10-02-2012, 06:24 PM
05ltdhemi's Avatar
Member
 
Join Date: Mar 2012
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1015
05ltdhemi is on a distinguished road
Re: Gauge Cluster Stopped Working

i have the issue of all the lights coming on and off. gauge needles drop and then come back up. mine says service electric brake system. head lights flash also. then all of the sudden everything goes back to normal. any ideas?
__________________
Reply With Quote
  #6  
Old 10-02-2012, 06:39 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255357
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Gauge Cluster Stopped Working

Quote:
Originally Posted by 05ltdhemi View Post
i have the issue of all the lights coming on and off. gauge needles drop and then come back up. mine says service electric brake system. head lights flash also. then all of the sudden everything goes back to normal. any ideas?
did you read the post directly above the one you just made?
__________________
Reply With Quote
  #7  
Old 10-02-2012, 06:48 PM
05ltdhemi's Avatar
Member
 
Join Date: Mar 2012
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1015
05ltdhemi is on a distinguished road
Re: Gauge Cluster Stopped Working

i did. but im not having the problem of my key fob not working nor the lights staying on after turning the vehicle off. will do.
__________________
Reply With Quote
  #8  
Old 10-03-2012, 08:58 AM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72972
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Gauge Cluster Stopped Working

Quote:
Originally Posted by 05ltdhemi View Post
i did. but im not having the problem of my key fob not working nor the lights staying on after turning the vehicle off. will do.
Check your battery, double check your battery, the check it again. The WK is a sensitive little beast when it comes to batteries.
__________________
Reply With Quote
  #9  
Old 12-19-2012, 09:19 PM
New Member
My Jeep: 2005
 
Join Date: Dec 2012
Location: CT
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
chrispmnm is on a distinguished road
Re: Gauge Cluster Stopped Working

I have had the same issue numerous times. I just switched out the battery and hasn't happened since...Keeping my figures crossed.
__________________
Reply With Quote
  #10  
Old 12-20-2012, 12:28 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 940
Thanks: 2
Thanked 15 Times in 15 Posts
Rep Power: 3608
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: Gauge Cluster Stopped Working

Check in this order: battery, multifunction stalk, ignition switch.
__________________

__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WK Custom Gauge Cluster Colors? YES!!! Diboblo LXHarness 51 10-09-2012 03:01 AM
99 WJ Gauge Cluster idea... bsmith0612 Interior/Exterior/Visual 3 06-19-2012 08:37 PM
Gauge cluster upgrade Gus9890 Interior/Exterior/Visual 61 04-21-2012 11:25 PM
srt8 cluster gauge copley2596 Grand Cherokee - WK 15 08-18-2009 04:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community