Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-06-2013, 08:42 PM
JHutch2012's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Sep 2012
Location: Fredericton, NB
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 716
JHutch2012 is on a distinguished road
Garage
Having issues with HIDís not coming on.

So i had some silver eagle 8000K hidís installed on my low beams with a relay harness, they worked great for about 3 months. Now they decided that they wont turn on at times. I have to turn the headlight switch from park lights to low beams a few times and they eventually turn on. However when they do decide to work they have randomly shut off while driving, so i then have to flicker the lights to get them to come back on.. i have completely disconnected and re connected them, that worked a few times but the problem returns. any advise?
__________________

__________________
Reply With Quote
  #2  
Old 02-07-2013, 10:49 AM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 1959
ALPINEST4RS is on a distinguished road
Re: Having issues with HIDís not coming on.

Multifunction switch is bad.
__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 COBB AP/CS TIP-SRI/ CPE Axle Back/ Stage 1 RMM/ Internals/ Wiseco Pistons/ Forged Rods
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 09:26 PM
OEM HID's are on their way! How to coming soon! Scottina06 2011+ Dodge Durango-WD 6 05-16-2012 06:23 AM
Oem HID Projector headlight issues DanD2124 Troubleshooting/Problems 50 11-09-2011 11:22 AM
Anyone run a 55w HID kit in the Gen III Projectors without issues? Amelie Interior/Exterior/Visual 10 03-03-2011 09:05 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community