Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2012, 03:36 PM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Heat cold when idle?

The heat is abnormally cold while idle, but will pickup after accelleration. Heater core replaced last 2,000 miles.147k on the clock.

New Waterpump
New Thermostat
...less than 100 miles and is still the problem.

2005 WK JEEP LIMITED 4.7 V8

???
Confused
__________________

__________________
Reply With Quote
  #2  
Old 02-12-2012, 06:21 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,157
Thanks: 9
Thanked 116 Times in 109 Posts
Rep Power: 526172
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Heat cold when idle?

Check the heater hoses in the engine bay for any kinks or sharp bends, this would restrict the liquid flow.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-12-2012, 06:26 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,808
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54414
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
I would double check the thermostat if the hoses are ok. The new t stat is the same temp (195 I believe) as the old one right? Could also be a blockage in the heater core.
__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #4  
Old 02-13-2012, 01:24 AM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Re: Heat cold when idle?

Problems were before water pump and tstat removal.

I flushed the core once, it was so hot for a while then after that it was no longer... But i am also loosing coolant still.

I dont see signs of headgasket leakage either.

Plugged radiator maybe? I will double check but last time i tried to drain the radiator nothing would come out not a drop...
__________________
Reply With Quote
  #5  
Old 02-13-2012, 06:26 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,157
Thanks: 9
Thanked 116 Times in 109 Posts
Rep Power: 526172
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Heat cold when idle?

With plugged radiator you probably mean a plugged heater core. A plugged radiator would cause the engine temperature to rise or even overheat it.
If after flushing it, it was heating strong and then stopped again, its probably a plugged heater core. You could try to reverse flush it, to get any particles out of it. You could also have a slight leak from the heater core. No wet carpet on the passenger side?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 02-13-2012, 03:43 PM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Re: Heat cold when idle?

Wet carpet. Soaked. But can't tell if it's soaked from when heater core gave out last time at 1443k
__________________
Reply With Quote
  #7  
Old 02-13-2012, 05:58 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,157
Thanks: 9
Thanked 116 Times in 109 Posts
Rep Power: 526172
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Heat cold when idle?

If youre still loosing coolant, you have a good change that there still is a leak on the cabin side, maybe one of the hoses.
Did you check the heater hoses in the engine bay if they run free, without sharp bends or kinks?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 02-13-2012, 07:02 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653035
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Heat cold when idle?

Its not uncommon to have an aftermarket heater core leak... sometimes mopar ones leak, if you have wet coolant coming down the firewall its sounding like the dash is going to need to come back out.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #9  
Old 02-14-2012, 03:51 PM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Re: Heat cold when idle?

Dropped it back at the shop I had the heater core done. They will be removing the dash and redoing their work.
__________________
Reply With Quote
  #10  
Old 02-28-2012, 09:29 PM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Re: Heat cold when idle?

Got it back from PALMER DODGE In ROswell no leaks in coolant so far, pressure tests come back normal. It has been not leaking since repairs but heat still sucks i mean only when i accellerate.

MY FAN DOES NOT MOVE IN THE FRONT BY RADIATOR??????????? WHEN EVERYTHING IS RUNNING? COULD CAUSE LOSS HEAT?
__________________
Reply With Quote
  #11  
Old 02-28-2012, 09:45 PM
Member
 
Join Date: Dec 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
ThR1LLr is on a distinguished road
Re: Heat cold when idle?

noticed my electrical fan will never cut on?
__________________
Reply With Quote
  #12  
Old 02-28-2012, 10:01 PM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,031
Thanks: 0
Thanked 23 Times in 21 Posts
Rep Power: 155028
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Heat cold when idle?

In your first post you indicate that the low/no heat condition is while idling, and in Post No. 10 you indicate the low/no heat condition occurs when accelerating. Which is it? I am not sure, but I believe they are, if the control valves are vacuum operated (vacuum motors), they will go to the "unloaded" (probably off) position at low vacuum, such as when accelerating. They will go back to the correct (heat) position once the vacuum increases at cruise or deceleration. Try sticking a vacuum gauge on it and drive it to see if low vacuum conditions mirrors the low/no heat condition. Also, make sure there are no vacuum leaks (disconnected/broken hoses), especially under the dash in the area of the heater control valves. Let us know what you find.
__________________

__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat afhanson72 Troubleshooting/Problems 2 01-26-2012 10:50 PM
heat problems JeepFreak12 Engine Performance/Intake/Exhaust 5 01-21-2012 10:16 PM
azc has no heat JeradyDavis Troubleshooting/Problems 34 01-09-2011 02:28 PM
Heat vnbWK2 Trouble Shooting/Problems/Service 3 11-05-2010 08:06 AM
A/C and heat only will go out through defroster.. SRTWJ04 Troubleshooting/Problems 7 08-28-2010 06:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.