Help! P0016, P0137, P0344 codes after repairs - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-15-2016, 07:57 PM
New Member
 
Join Date: Sep 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Bens935 is on a distinguished road
Help! P0016, P0137, P0344 codes after repairs

Hello,
I was hoping I can get some help here.

My mother in law gave me her 2005 JGC, 3.7L. that had a blown right cylinder head thanks to a cracked heater core.

I replaced the heater core, right cylinder head, replaced the old timing chain (with tensioners and guides), and performed a tune up (to specs with bosch plat. plugs). I even did a coolant flush and replaced with OEM fluids.

When I started up the jeep, it started, but it wasn't easy. It was difficult to start and the idle seemed low. It idled with no issues that I can hear nor see for over 20 minutes. I shut it down but couldn't restart it, no matter how much I cranked it.

I ran the OBD reader and it spit out codes P0016, P0137 and P0344.
I replaced both the cam and crank sensors and still to no avail.
I even took everything apart again just to make sure everything was lined up properly.

I need help.

Do I need my PCM flashed? Can it be my temp control sensor?

I also tried to recharge the AC system (after vacuum) and the A/C was blowing out hot. The compressor engaged and the 134a went in with no issues. Any ideas?

Any help is greatly appreciated. Thanks!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-10-2016, 12:54 AM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Aug 2015
Location: San Mateo, CA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 642
nathanjaybar is on a distinguished road
Re: Help! P0016, P0137, P0344 codes after repairs

Did you ever find a solution? I'm getting P0016 and P0344 too.
Reply With Quote
  #3  
Old 10-10-2016, 10:22 AM
Senior Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 1,331
Thanks: 0
Thanked 73 Times in 61 Posts
Rep Power: 156217
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Help! P0016, P0137, P0344 codes after repairs

Even though the codes don't indicate this, the first thing I'd do is get rid of the Bosch Platinum plugs and put the right type ones in. Also, on my Autel DS708, there is a "sync" feature to be used when installing new crank/cam sensors. Don't know if this is his problem though. I've run it on both my Hemi vehicles (that run fine) WITHOUT replacing any sensors just to see what happens. The cam and crank sensors were off by only ~.02 degrees. I don't know what the maximum tolerance is though, but .02* isn't very much. I would guess that if they're off by more than a degree or two there may be a problem.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
O2 sensor problem? Getting code P0137... Triplecrown Troubleshooting/Problems 4 11-29-2013 11:41 AM
Code P0137 02 Circuit Low Voltage (Bank 1, Sensor 2) Triplecrown Troubleshooting/Problems 0 10-24-2013 02:00 PM
occaisional P0016 crank sensor w/ CK Eng stone Trouble Shooting/Problems/Service 1 06-20-2013 08:20 AM
P0137 amw5 Troubleshooting/Problems 2 10-10-2011 02:00 PM
OBD codes P0016, P000B --- 93 octane stone Trouble Shooting/Problems/Service 5 09-29-2011 10:43 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.