Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-25-2013, 11:55 AM
ahamay115's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: Jun 2009
Posts: 161
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2027
ahamay115 is on a distinguished road
HVAC intermittent issues - works then doesn't work

Hey guys, I have been searching for a while on this issue and cannot seem to located any direct information on it, so please forgive me if there is something that I have missed.

I have a 2006 Overland and this past summer I was experiencing on random occasions where the ac would not blow at all. It didn't matter at what setting it was set to, whether set to Auto or even manually turning on the fan at any speed; it would not blow any air.

Then all of a sudden after several minutes, always random, it would come on full blast and cool the car down and work perfect.

It is completely random when it does work and when it doesn't and the length of time for it to start blowing is completely at random as well.

I have now experienced where this issue has now trickled into the heating as well, as I found out on my 35 drive to work earlier this week


I had taken the Jeep to a local shop that was offering a free ac inspection towards the end of the summer and had it checked out. Of course, at that time everything was working perfectly and they noted that the system was working as it should be.

They also noted that something was loose and the technician "plugged" it back in, but it may come out again. When I left the shop everything worked perfect, as it should, for over 3 weeks.

Now, had I been thinking, I would have asked them to show me exactly what this was that he had to plug in, but I didn't ask and they now do not remember, and of course they are not offering a free check anymore.

Does anyone have any idea what it could be that is causing this issue? The summer was not so bad, as you would sweat a little before being cooled down, but that isn't gonna work as well in the wintertime.

Are there any "plugs" that would be easily accessible to the control unit that could quickly be checked?

Sorry for the long post! I appreciate any and all help!!

Thanks!!
-Chris
__________________

__________________
-CHRIS
2006 GRAND CHEROKEE OVERLAND
Reply With Quote
  #2  
Old 10-26-2013, 03:25 PM
ahamay115's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: Jun 2009
Posts: 161
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2027
ahamay115 is on a distinguished road
No one else has ever experienced this? :/
__________________

__________________
-CHRIS
2006 GRAND CHEROKEE OVERLAND
Reply With Quote
  #3  
Old 10-26-2013, 07:38 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: HVAC intermittent issues - works then doesn't work

Not familiar with the WK, but check the connector on the blower motor, which is probably visible looking up from the passengers footwell. There is probably a controller or resistor pack close to it, so check that connector as well. On the WJ those connectors are known to give bad contact and finally melt.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 11-08-2013, 08:50 AM
ahamay115's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: Jun 2009
Posts: 161
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2027
ahamay115 is on a distinguished road
Re: HVAC intermittent issues - works then doesn't work

Small Update:

I opened up the glove box, but couldn't figure out how to completely remove it and didn't want to pull on it until I was sure that is the correct removal procedure.

But, I am able to see the blower motor control module (Full Auto HVAC) and everything looks to be correct. I cannot see anything that appears to be loose or unplugged.

I have noticed lately that the system will not work upon first startup, but it seems that hitting a 'sizable' bump in the road will all of the sudden kick the system on!

I'll keep updating this thread as I experience new things and troubleshoot the system, but as always any input is greatly appreciated!!

Thanks!
-Chris
__________________
-CHRIS
2006 GRAND CHEROKEE OVERLAND
Reply With Quote
  #5  
Old 11-18-2013, 07:45 AM
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2012
Location: Fillmore, New York
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 816
croth is on a distinguished road
Re: HVAC intermittent issues - works then doesn't work

I was having a similar problem with my '05, but I have manual A/C.

After changing the resistor pack several times, my fan would also cut in and out when I went over a good bump.

Finally figured out it was the connection to the resistor pack. Changed out the connector and it took care of the problem.

Hope this helps!

Craig
__________________
Reply With Quote
  #6  
Old 11-19-2013, 07:16 AM
ahamay115's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: Jun 2009
Posts: 161
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2027
ahamay115 is on a distinguished road
Re: HVAC intermittent issues - works then doesn't work

I'm at a loss right now on this one...

I finally broke down and bought a new blower motor power module for the auto hvac. [HAF] part #: RL885482AC in case anyone else needs it.

But of course, the system has been working perfectly all week!! I cannot explain it at this point. I am going to pull the glove box off again and check the wiring harness visually and with a multimeter to see if there is something hocky going on there.

I'll continue to update as I find more!!

Thanks guys!
-Chris
__________________

__________________
-CHRIS
2006 GRAND CHEROKEE OVERLAND
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Works/Doesn't Work in Canada Nomorecars Audio/Visual/Navigation 5 08-14-2013 09:11 PM
AUDIO/NAVIGATION ALL doesn't work srtN Audio/Video/Navigation/Alarms 1 05-21-2013 12:28 PM
Help! A/C doesn't work. janisonh Troubleshooting/Problems 6 07-04-2012 04:10 PM
Horn Doesn't Work sjmst Grand Cherokee - WK 3 09-04-2011 03:13 PM
Intermittent blower issues mjl2610 Troubleshooting/Problems 1 02-04-2010 03:18 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community