Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-08-2012, 11:30 AM
jkt009's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Location: Springfield, MO
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1263
jkt009 is on a distinguished road
I think I messed up.... real bad

ok I was changing my EGR valve this morning and I just finished but now the jeep wont start. I disconnected the negative battery terminal before I did the EGR and I followed the how to thread on here and I thought everything went well. I reconnected the negative wire and the cheap wont start. The dash lights come on and the check engine light is on as well. The check engine light is solid for about 5 seconds then it flashes at me for probably 10 seconds. Does this mean its in limp mode? Its a 2005 with the 5.7. Please help
__________________

__________________
Reply With Quote
  #2  
Old 08-08-2012, 11:34 AM
jkt009's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Location: Springfield, MO
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1263
jkt009 is on a distinguished road
Re: I think I messed up.... real bad

sorry cheap was suppose to be jeep
__________________

__________________
Reply With Quote
  #3  
Old 08-08-2012, 11:47 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Feb 2012
Location: mallorca
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1123
tom58 is on a distinguished road
Re: I think I messed up.... real bad

why do you think its in limp mode??didnt you say it doesnt start at all. is it cranking at all?
__________________
Reply With Quote
  #4  
Old 08-08-2012, 12:22 PM
jkt009's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Location: Springfield, MO
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1263
jkt009 is on a distinguished road
Re: I think I messed up.... real bad

Well i feel stupid now because everything worked out fine. I guess the battery just wasn't charged enough because I tried to jump start it but it wouldn't start so I just let it sit for about 10 minutes and when I tried starting it, it started right up. I just took it out for a drive and everything seems to be just fine. Sorry to waste a thread and thanks for the reply tom58
__________________
Reply With Quote
  #5  
Old 08-08-2012, 01:47 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Feb 2012
Location: mallorca
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1123
tom58 is on a distinguished road
Re: I think I messed up.... real bad

no worries glad everything is fine
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is your Chrome Bumper molding messed up? JeepMonster Interior/Exterior/Visual 3 05-24-2012 02:29 PM
Horn Getting Messed up from Heavy Amounts of Water. DurangoZJ Grand Cherokee - WK2 - 4 04-07-2012 04:45 PM
HELP! Bilstein shocks just delivered and I think one is messed up rayjr2785 Grand Cherokee - WK 11 05-05-2011 01:15 PM
I think the dealer Messed w/my car. TimmyB Grand Cherokee - WK 10 04-03-2010 08:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.