Idle issues :( - Page 3 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 11-13-2014, 08:03 PM
Member
 
Join Date: Jan 2012
Posts: 181
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 2027
Boomer914 is on a distinguished road
Updates?

Reply With Quote
Sponsored Links
Advertisement
 
  #26  
Old 11-14-2014, 11:05 AM
Jeff1119's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Nov 2014
Location: Staten Island, New York
Posts: 294
Thanks: 32
Thanked 9 Times in 9 Posts
Rep Power: 1104
Jeff1119 is on a distinguished road
Re: Idle issues :(

Quote:
Originally Posted by Boomer914 View Post
How bout that whistle?
Well when I got it, it still does the idle thing. So I asked the mechanic what's up and he said its normal even after the flash. He said its suppose to idle at 600rpm and may sometimes drop once in a while and go back up. He said its just the way the engine is. I just decided to live with this since everything I could think of has been done and it's still doing the same thing. Maybe it's idled like this and I haven't noticed till a few weeks ago when it dropped real low and went back up.

He also said every time the battery gets disconnected or throttle body, the jeep needs to be re flashed. il believe the throttle body part but disconnecting the battery should not require a reflash every time. That's just a waste of money.
Also forgot to ask about the whistle but believe it's the torque converter according to my mechanic.
Reply With Quote
  #27  
Old 11-25-2014, 11:33 PM
Jeff1119's Avatar
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Nov 2014
Location: Staten Island, New York
Posts: 294
Thanks: 32
Thanked 9 Times in 9 Posts
Rep Power: 1104
Jeff1119 is on a distinguished road
Re: Idle issues :(

Quote:
Originally Posted by DCFD522 View Post
I'd suggest not throwing anymore money at it. Take it to the dealership, have them check your trans fluid and make sure your pcm is up to date. Those are steps I haven't taken that have been recommended to me.
turned out to be the camshaft sensor for me lol. Replaced the crankshaft and iat sensor anyways while i was there. Sucks I wasted money on all those other parts and a dealer reflash which did nothing. But hey, got it working now with a whole bunch of new sensors so i guess you could say prevented future maintenance

p.s. This was just an update to my issue in case anyone else was looking at this thread for a solution.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crap Idle? 4.7 V8 NHWK05 Troubleshooting/Problems Discussion 24 11-25-2014 08:10 PM
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 10:26 PM
2003 Jeep 4.7l HO idle issues 360ramsst Troubleshooting/Problems 3 03-18-2012 08:27 PM
Hemi idle issues noquarter Grand Cherokee - WK 10 03-20-2011 12:22 PM
More stalling/funky idle issues. NHWK05 Grand Cherokee - WK 12 08-15-2010 12:12 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:29 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.